Fatal Installation Error - Module "" not accessible.

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
jamie_hari
Registered User
Posts: 3
Joined: Thu Nov 08, 2007 5:08 am

Fatal Installation Error - Module "" not accessible.

Post by jamie_hari »

Support Information:

Your board's URL: Home web server, currently unavailable on the internet.
Version of phpBB3: RC2 -> RC7
Was this a fresh install or a(n) update/upgrade/conversion (please be specific)? An upgrade from RC2 - RC7
Was this an install through your host? I am performing the install myself, on my home web server
MODs you have installed: none
When the problem started: During the RC2 to RC7 upgrade process

Template(s) used: Prosilver (default, unmodified)
Language(s) used: British English? (default, unmodified)
Version of PHP used: 5.0.3
Database and version used: MySQL 4.1.7nt

Details:

Code: Select all

Fatal installation error

Fatal installation error

index.php [ 396 ]

Module "" not accessible.
Steps I am taking:
1. I take db and file structure backups... (like a good admin.)
2. I download and extract the RC2 to RC7 zip files
3. I place the docs and install directories into my existing phpbb3 RC2 installation.
4. I visit my upgrade index page
http://localhost/forums/install/index.php
5. I get the error on the upgrade tab immediately...



Any thoughts?
jamie_hari
Registered User
Posts: 3
Joined: Thu Nov 08, 2007 5:08 am

Re: Fatal Installation Error - Module "" not accessible.

Post by jamie_hari »

Instead of using 'changed files', I did an upgrade using the 'full package'...
It seems to have worked.

Buggy upgrade, but this is RC after all! ;)
User avatar
darcie
Community Team Member
Community Team Member
Posts: 5541
Joined: Thu Jul 27, 2006 9:52 am
Location: Davis, California
Name: Darcie Griffin
Contact:

Re: Fatal Installation Error - Module "" not accessible.

Post by darcie »

Next time if you use the changed files or just do the overwrite, do not browse to install/index.php. Go directly to install/database_update.php to bring your database to the current version. And if you haven't completed this step for this update (can't tell from your posts above), please do so!
phpBB on Facebook | Site Rules | Former Community Team leader
davidwhthomas
Registered User
Posts: 1
Joined: Tue Jan 15, 2008 9:56 am

Re: Fatal Installation Error - Module "" not accessible.

Post by davidwhthomas »

I've just downloaded the complete package (PHPBB3.0.0.tar.gz) from here
http://www.phpbb.com/downloads/olympus.php
and received the same error message.

The 'final stage' of the install fails with the message:
Fatal installation error
Fatal installation error
index.php [ 396 ]
Module "" not accessible.
Has anyone else had this problem? If so, any advice on how to fix it!

thanks,

DT

My Support Information:
Your board's URL: Under Construction
Version of phpBB3: 3.0.0 Stable Release
Was this a fresh install or a(n) update/upgrade/conversion (please be specific)? Fresh Install
Was this an install through your host? I created the db, assigned the user and installed manually myself
MODs you have installed: none
When the problem started: during the fresh install process

Template(s) used: Prosilver (default, unmodified)
Language(s) used: British English? (default, unmodified)
Version of PHP used: 5.2.5
Database and version used: 5.0.45-community
Attachments
screenshot of error message
screenshot of error message
phpbb3_install_fatal_error.png (21.69 KiB) Viewed 3810 times
brucey666
Registered User
Posts: 11
Joined: Sat Sep 01, 2007 12:36 pm

Re: Fatal Installation Error - Module "" not accessible.

Post by brucey666 »

Hey

I had the exact same problem as post above but its now fixed

I simply deleted everything in index/cache/ accept for .htaccess and index.htm

Then install again

Hope this helps
ccquadman
Registered User
Posts: 1
Joined: Thu Sep 27, 2007 3:16 am

Re: Fatal Installation Error - Module "" not accessible.

Post by ccquadman »

I did the same to update. Deleted everything but .htaccess and index.htm from the cache. Then, the update went fine w/o getting that error.

I first tried to delete everything from the cache but two files listed above and the test_lock / install_lock files, however, I still got the error. Not sure what those lock files do but I had to delete them, too. Purging the cache from the admin panel did not, uh, purge enough. Hopefully, in the future there can be a step to purge the cache from the admin panel that will purge enough to get past this error.

Pretty slick and easy upgrade once I got past this as I dont have Mods on 3.0.1.
User avatar
Eelke
Registered User
Posts: 2903
Joined: Thu Dec 20, 2001 8:00 am
Location: NL, Bussum
Name: Eelke Blok
Contact:

Re: Fatal Installation Error - Module "" not accessible.

Post by Eelke »

jamie_hari wrote:3. I place the docs and install directories into my existing phpbb3 RC2 installation.
I can't help but notice no-one has mentioned this. It is not sufficient to copy just the install and docs directory, you need to copy all files found in the package, replacing any files of the same name in your installation. That is the actual update of the PHP code, there is no script within the install-directory to update the PHP code, only to update the database. Maybe I'm stating the obvious...

[Edit: or maybe I'm wrong. If you use the automatic update package, the install directory is sufficient.]
Last edited by Eelke on Sat Jun 28, 2008 8:31 am, edited 1 time in total.
ottermann
Registered User
Posts: 4
Joined: Sat Jun 28, 2008 2:22 am

Re: Fatal Installation Error - Module "" not accessible.

Post by ottermann »

I downloaded the full package and did a new install per the instructions.
All seemed fine. I used the "conversion" tab in the installer to convert my old phpbb2 forums to the new phpbb3 one.

I recieve:
Fatal installation error
Fatal installation error

index.php [ 396 ]

Module "" not accessible.

almost instantly.


I have tried deleting the install and reinstalling the forum again, but it does the same thing.
I know I did something wrong, but I cant figure out what.

If anyone has any suggestions, I'd love to hear them.

Oh, and if the answer could be simple, it would help. I'm not a big code monkey.
CardShark88
Registered User
Posts: 14
Joined: Fri Jul 18, 2008 5:10 pm

Re: Fatal Installation Error - Module "" not accessible.

Post by CardShark88 »

I had the same problem when I used the link provided to me in the "System" Tab.

I then tried to go to www.mysite.com/forum/install.php

Went onto a information page.. yet still no update button.

I then went directly to www.mysite.com/forum/install/database_update.php

and that worked perfectly. The error found on so called line [ 396 ] in the index.php didnt affect the update.

However this was strictly to upgrade from 3.0.1 to 3.0.2, not a fresh change from V2 to V3. However that was the way i worked round the pointless error.
Locked

Return to “[3.0.x] Support Forum”