Log me on automatically each visit, don't work

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
dtleahy
Registered User
Posts: 169
Joined: Sun Aug 24, 2008 5:47 pm

Re: Log me on automatically each visit, don't work

Post by dtleahy »

darcie wrote:@ dtleahy: Now that the DNS has resolved, please change the domain name in server settings to MyDomainName.com, script path /phpBB3; change cookie domain to .MyDomainName.com, path /phpBB3, and slightly alter cookie name to force a new cookie immediately.
Thank you darcie. Trying it out right now...

Dennis
biffstallion
Registered User
Posts: 34
Joined: Thu Aug 28, 2008 3:19 pm

Re: Log me on automatically each visit, don't work

Post by biffstallion »

darcie wrote:
@ biffstallion: It looks like your cookies are being set with path /phpbb3 while the board is at /phpBB3 (note capitalization). Can you change this and slightly alter your cookie name to force a new cookie? Oh, and the Knowledge Base article you linked is written for phpBB2.
OH MY GOD darcie !!!! That WORKED !!!! I can't believe I didn't notice that. What a dolt. THANK YOU :)
dtleahy
Registered User
Posts: 169
Joined: Sun Aug 24, 2008 5:47 pm

Re: Log me on automatically does not work - cookie problem

Post by dtleahy »

dtleahy wrote:
darcie wrote:@ dtleahy: Now that the DNS has resolved, please change the domain name in server settings to MyDomainName.com, script path /phpBB3; change cookie domain to .MyDomainName.com, path /phpBB3, and slightly alter cookie name to force a new cookie immediately.
Thank you darcie. Trying it out right now...

Dennis
Still does not work, and I think no cookies are being set. (Well, style_cookie is being set, but it is null.)

OK, here are my current settings:

Server Configuration
- Server Settings
---- Domain Name: www(dot)mydomainname.org
(if I type it in here, this forum resolves it to http)
---- Script Path /phpBB3

- Security Settings
---- Allow Persistent logins: Yes

- Load Settings
---- Session length: 7200 sec

- Cookie Settings
----Cookie domain: .www.mydomainname.org
----Cookie name: phpBB3_gdvwlx
----Cookie path: /phpBB3
----Cookie secure: Disabled


I did note an error I had made: the script path was phpbb3 and should have been phpBB3 . I also changed the cookie name to reflect the case of the 'BB', even though I am pretty sure that would not matter.

I performed Purge the Cache, even though I'm not sure if that would affect the cookie setting or not.

BTW, this was a fresh install of phpBB3 3.0.2, no mods.

Any additional help, from anyone, will be greatly appreciated!

Dennis
ashdaw
Registered User
Posts: 14
Joined: Wed May 14, 2008 9:41 am

Re: Log me on automatically each visit, don't work

Post by ashdaw »

I have to admit that I truly can't understand some of the talk here, I just know that I login,then I go about my business and then I leave the site and come back to it and I have to log in again. I have tried IE7 and Firefox 3 and it happens in both browsers.

On this server I have another forum running (different brand) and I have no troubles with that one at all.

I have set the Cookie thing and it STILL doesn't work, cleared cookies too in both browsers, NOTHING.
One guy I noticed said something about a setting in the ACP to allow log in to be auto but I cant find it??

I would truly appreciate some assistance. :roll:
User avatar
darcie
Community Team Member
Community Team Member
Posts: 5543
Joined: Thu Jul 27, 2006 9:52 am
Location: Davis, California
Name: Darcie Griffin
Contact:

Re: Log me on automatically each visit, don't work

Post by darcie »

dtleahy wrote:- Cookie Settings
----Cookie domain: .www.mydomainname.org
----Cookie name: phpBB3_gdvwlx
----Cookie path: /phpBB3
----Cookie secure: Disabled

I did note an error I had made: the script path was phpbb3 and should have been phpBB3 . I also changed the cookie name to reflect the case of the 'BB', even though I am pretty sure that would not matter.

I performed Purge the Cache, even though I'm not sure if that would affect the cookie setting or not.
Cookie domain should be simply .mydomainname.org -leave out the additional .www
Capitalization in the cookie name does not matter. :) Purging the cache does not either.

@ ashdaw: Despite your lack of understanding, let's see if we can help you out. :)
The ACP setting you mentioned is on the main page of the ACP under the Server Configuration header. Go to Security settings and see that the top line, "Allow persistent logins," is set to yes. If that is set, we'll want to know the URL you use to access your board and the cookie settings you have:

Code: Select all

Cookie domain:
Cookie name:
Cookie path:
Cookie secure:
phpBB on Facebook | Site Rules | Former Community Team leader
dtleahy
Registered User
Posts: 169
Joined: Sun Aug 24, 2008 5:47 pm

Re: Log me on automatically each visit, don't work

Post by dtleahy »

Oh, darcie, we're getting close! I can smell the finish line!

Your step to remove the www. from the cookie path was the key to getting the cookies to be created! Yay!
However, I don't think the cookies are being written properly.

In addition to the style_cookie, I now have 3 new cookies: one ending with _sid, one ending with _k, and one ending with _u

When I am in the forum:
_sid contains a big hex string: 7fe79338d7...
_k contains a hex string
_u is 125

When I close down my forum tab in the browser (without logging out)
_sid contains a big hex string: 7fe79338d7...
_k is (empty)
_u is 1

What do I need to do to get these cookies to be set properly?

Thanks!

Dennis
{edited}
User avatar
darcie
Community Team Member
Community Team Member
Posts: 5543
Joined: Thu Jul 27, 2006 9:52 am
Location: Davis, California
Name: Darcie Griffin
Contact:

Re: Log me on automatically each visit, don't work

Post by darcie »

dtleahy wrote:Your step to remove the www. from the cookie path was the key to getting the cookies to be created! Yay!
Just to be sure, since we wrote the removed portion differently, do be sure that there is a leading dot for the cookie domain. This will allow the cookie to be valid for visiting the site both with and without the www.
dtleahy wrote:However, I don't think the cookies are being written properly.
I don't see a problem here... Is the automatic login function now working, or still failing?
phpBB on Facebook | Site Rules | Former Community Team leader
dtleahy
Registered User
Posts: 169
Joined: Sun Aug 24, 2008 5:47 pm

Re: Log me on automatically each visit, don't work

Post by dtleahy »

darcie wrote:
dtleahy wrote:Your step to remove the www. from the cookie path was the key to getting the cookies to be created! Yay!
Just to be sure, since we wrote the removed portion differently, do be sure that there is a leading dot for the cookie domain. This will allow the cookie to be valid for visiting the site both with and without the www.
Yes, the cookie path is .mydomainname.org
darcie wrote:
dtleahy wrote:However, I don't think the cookies are being written properly.
I don't see a problem here... Is the automatic login function now working, or still failing?
Still failing. (As an aside, I have a feeling that "remember me" would be a better phrase than "Log me on automatically each visit." From reading many posts here, I think a lot of folks are expecting a fully automatic login. I'm just hoping the username and password boxes will be filled-in, automatically.)

Again, the forum cookies that hold the data (blabla_u and blabla_k) hold completely different values when I am in the forum than when I close down the forum (without logging out.) In fact the blabla_k cookie is blank after closing the tab that contained the forum. That sure doesn't seem right. I had hoped that would be a good clue as to why it is still failing.

Thanks for your diligent support!

Dennis
User avatar
darcie
Community Team Member
Community Team Member
Posts: 5543
Joined: Thu Jul 27, 2006 9:52 am
Location: Davis, California
Name: Darcie Griffin
Contact:

Re: Log me on automatically each visit, don't work

Post by darcie »

dtleahy wrote: (As an aside, I have a feeling that "remember me" would be a better phrase than "Log me on automatically each visit." From reading many posts here, I think a lot of folks are expecting a fully automatic login. I'm just hoping the username and password boxes will be filled-in, automatically.)
The username and password are something that your browser would save, not phpBB. The intended behavior is this:
  • Log in using your username and password, checking "Log me on automatically each visit"
  • Close the board but do not manually log out
  • Return to the board (after minutes, days, anything up to the specified maximum allowed by the "Persistent login key expiration length" in the Security settings of the ACP)
  • Be automatically logged in- do not have to visit login page, Logout [ username ] visible instead of Login
Your cookie values seem just fine to me from the examples you have given. At this point, I have provided all the theoretical values possible. If this is still not working for you, I will need you to provide actual URL and cookie settings.
phpBB on Facebook | Site Rules | Former Community Team leader
dtleahy
Registered User
Posts: 169
Joined: Sun Aug 24, 2008 5:47 pm

Re: Log me on automatically each visit, don't work

Post by dtleahy »

darcie wrote:...Your cookie values seem just fine to me from the examples you have given. At this point, I have provided all the theoretical values possible. If this is still not working for you, I will need you to provide actual URL and cookie settings.
Hi darcie,

I have PMd the info to you.

Thanks!

Dennis
ashdaw
Registered User
Posts: 14
Joined: Wed May 14, 2008 9:41 am

Re: Log me on automatically each visit, don't work

Post by ashdaw »

I did ask for assistance so I guess I need to start a new topic?
dtleahy
Registered User
Posts: 169
Joined: Sun Aug 24, 2008 5:47 pm

Re: Log me on automatically each visit, don't work

Post by dtleahy »

Hi,

I wanted to let folks know that darcie figured out my auto login problem, and the problem is resolved. The problem was evidently partially case sensitivity, and partially from not having a fully resolved link (like http://mysite.com rather than the correct http://www.mysite.com)

Here is my note to darcie:
============================
Success!

I'm a php newbie, and guess I got caught in the trap of case sensitivity.

I changed the link from the site to the forum, and changed the cookie name slightly, deleted my cookies, and now it works. (Probably did not need to delete my cookies.)

Thank you for hanging in there with me. You are awesome!

Dennis
===========================
User avatar
darcie
Community Team Member
Community Team Member
Posts: 5543
Joined: Thu Jul 27, 2006 9:52 am
Location: Davis, California
Name: Darcie Griffin
Contact:

Re: Log me on automatically each visit, don't work

Post by darcie »

ashdaw wrote:I did ask for assistance so I guess I need to start a new topic?
No, you simply missed part of a post directed at you above. I'll quote it here for you:
darcie wrote:@ ashdaw: Despite your lack of understanding, let's see if we can help you out. :)
The ACP setting you mentioned is on the main page of the ACP under the Server Configuration header. Go to Security settings and see that the top line, "Allow persistent logins," is set to yes. If that is set, we'll want to know the URL you use to access your board and the cookie settings you have:

Code: Select all

Cookie domain:
Cookie name:
Cookie path:
Cookie secure:
phpBB on Facebook | Site Rules | Former Community Team leader
linuz
Registered User
Posts: 4
Joined: Thu Sep 11, 2008 4:46 pm

Re: Log me on automatically each visit, don't work

Post by linuz »

Hi everybody, I have the same problem of most of you... the autologin problem.
(first of all I want to apoligyze for my english, as u can easily understand I am not a native speaker)

Let's go to the point: I think I followed all the instructions I found on this halpfull topic, and infact now many users of my forum can log in, close the browser, and enter again the forum without having to login again.
Unfortunately for few users the problem is still persistent: they have to login every single time they enter the forum.
I checked their browser configuration, and i can guarantee that it is not their problem: everything about cache and cookies on their browser is pretty fine.
On the other hand I can log in, leave the forum and enter again without any problem, and without any need to login again: and I can do that with 4 different browsers, with 2 different usernames, and from different IP addresses.

I post here the cookie configuration of my Administrator Panel Control (please notice that My APC is actually in italian, so I will just translate the settings into english)
the forum is www.forum.amicidilenza.it (or http://www.amicidilenza.it/forum/)
I did put tese settings:
-cookie domain: .amicidilenza.it
-cookie name: phpbb3_jehui
-cookie path: / (I also tryed with /forum but it doesn't seem to work)
-cookie secure: disabled

Of course in the security settings I allowed automatic connections
I don't know wheather I should disable the validation of IP address. Right know It is set on A.B.C

Well, I guess that's it.
I really thanks u in advance for the help u will give me
I licterally going crazy due to this problem
What I cannot figure out is why many users can automatically login, and some users cannot!
Thank u again
Bye bye
linuz
User avatar
darcie
Community Team Member
Community Team Member
Posts: 5543
Joined: Thu Jul 27, 2006 9:52 am
Location: Davis, California
Name: Darcie Griffin
Contact:

Re: Log me on automatically each visit, don't work

Post by darcie »

You'll need to choose one of these and stick to it. Although these are somewhat the same, they are also different enough to cause the problem you are seeing. I would suggest the standard http://www.amicidilenza.it/forum for simplicity.
phpBB on Facebook | Site Rules | Former Community Team leader
Locked

Return to “[3.0.x] Support Forum”