Please help me restore my database!

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
fiznat
Registered User
Posts: 3
Joined: Tue Dec 18, 2007 5:32 am

Please help me restore my database!

Post by fiznat » Tue Dec 18, 2007 6:00 am

Hello everyone!

I am trying to move my database from the free hosts over at informe.com to my new DNS/mySQL which I have set up with phpBB3. I BELIEVE my database at informe.com is phpBB2X but I am not sure.

I was able to get a database dump from the informe people, which is a file of 530 or so kb, but I have been unsuccessful in getting phpBB3 to take it. I first tried to upload the file into the "store" directory and restore the database using the admin restore feature, but for some reason the file (in .sql and .gz zipped) is not recgonized by phpBB. I don't see any files at all in the list.

After searching here I learned about the bigdump script, so I tried that next. I uploaded the modified bigdump.php to a "dump" directory, along with my dump file that I got from informe.com. Running the script, I get these errors:
Error at the line 2206: ) ENGINE=InnoDB DEFAULT CHARSET=utf8;

Query: CREATE TABLE `wiki_categorylinks` (
`cl_from` int(8) unsigned NOT NULL default '0',
`cl_to` varchar(255) character set utf8 collate utf8_bin NOT NULL default '',
`cl_sortkey` varchar(86) character set utf8 collate utf8_bin NOT NULL default '',
`cl_timestamp` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
UNIQUE KEY `cl_from` (`cl_from`,`cl_to`),
KEY `cl_sortkey` (`cl_to`,`cl_sortkey`),
KEY `cl_timestamp` (`cl_to`,`cl_timestamp`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;

MySQL: Specified key was too long; max key length is 1000 bytes
A lot of errors.

Alright, so I tried it another way. I downloaded a big dump using the admin panel that is accessible to me on informe.com. This is a much larger file, uncompressed is 6.29mb. I made a whole fresh database with a brand new installation of phpBB3, edited the bigdump.php file, added it to a "dump" directory, and tried to restore again. (whew)

The script actually runs this time (now it is obvious it didn't last time), and after waiting for it to cook bigdump tells me this:
Congratulations: End of file reached, assuming OK

However, when I try to look at the forums, I get this:

General Error
SQL ERROR [ mysql4 ]

Unknown column 'is_dynamic' in 'where clause' [1054]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

Not sure where to go from here.

Any advice?
Last edited by zeroK on Tue Dec 18, 2007 9:09 am, edited 1 time in total.
Reason: Marked as solved

Colin Kaminski
Registered User
Posts: 55
Joined: Wed Jun 09, 2004 4:06 pm
Contact:

Re: Please help me restore my database!

Post by Colin Kaminski » Tue Dec 18, 2007 6:30 am

It is common to change the database during an upgrade. It would be really helpful if you can find the version number.

fiznat
Registered User
Posts: 3
Joined: Tue Dec 18, 2007 5:32 am

Re: Please help me restore my database!

Post by fiznat » Tue Dec 18, 2007 7:44 am

Hah! Okay I think I've figured it out on my own haha. Thanks anyways guys!

For future reference in case someone has this same problem: my original database at informe.com was indeed a 2nd generation (phpBB2xx). I think that is what was causing my restore issues. What I did was download a full version of phpBB2 from the website, install that on my server using a very small "test" database. I was able to restore the data using this version with no problem from the files I dumped off of my informe.com forums.

Once that was set up and running, I then installed phpBB3 on another (much larger) separate database, and was able to convert the older one to the 3rd gen without an issue. I couldn't do this before because informe.com doesn't supply us with database server information, but once it was installed on my own servers it was easy.

Everything is up and running nicely now! :P

Locked

Return to “[3.0.x] Support Forum”