Login problem

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
soddy
Registered User
Posts: 11
Joined: Fri Jan 04, 2008 11:30 am

Re: Login problem

Post by soddy » Mon Jan 07, 2008 6:04 pm

Ultimately after hours of struggle i ws able to solve the problem...this seems to be a really nasty bug in phpBB3
wat i did was reinstall phpBB3....and replace the new database with the older one but the problem was still there. this proved that problem was not due to installation but due to some entry in the database. So i again installed phpBB3 and copied each table that was required one by one from the older database and checking the forum after every change i made. The effort paid and now my forum works fine.
It was really frustrating taking so much pains. Still the source of the bug is unknown as different people are solving it in different ways and one way may not work for the other.

jema
Registered User
Posts: 22
Joined: Fri Apr 05, 2002 11:10 am

Re: Login problem

Post by jema » Mon Jan 07, 2008 6:20 pm

Any idea what table the answer was in?



I have a working phpbb3 and a broken phpbb3 on the same server and running identical code, so this must be in the database somehow and it is really frustrating.

AlbertSz
Registered User
Posts: 48
Joined: Mon Nov 10, 2003 2:01 pm

Re: Login problem

Post by AlbertSz » Mon Jan 07, 2008 6:39 pm

the best thing is that my forum fixed it self around 3 a.m. some users where able to login and post. And it broke again aroung 10 a.m. No changes made in this time to server or files or DB.

cmwoodard14
Registered User
Posts: 6
Joined: Thu Nov 15, 2007 10:45 pm
Contact:

Re: Login problem

Post by cmwoodard14 » Mon Jan 07, 2008 7:02 pm

I'm having the same issue. The problem is only with members using Internet Explorer. Firefox, Safari and Opera work fine. This problem started for me when I moved my forum from one server to another. I did a fresh install of phpBB 3.0.0 on the new server and then restored the database. This when things went wrong for me.

If anyone has further information about this problem I would appreciate it.
I have tried everything that was mentioned in this post but I still have the problem.

AlbertSz
Registered User
Posts: 48
Joined: Mon Nov 10, 2003 2:01 pm

Re: Login problem

Post by AlbertSz » Mon Jan 07, 2008 7:37 pm

fixed my problem :)

you need to empty phpbb_sessions and phpbb_sessions_keys

make shure that the "Type" is the same everywhere i.e. MyISAM or InnoDB

I will post later on how I did it

Janetfl
Registered User
Posts: 44
Joined: Fri Jan 04, 2008 3:23 am
Contact:

Re: Login problem

Post by Janetfl » Mon Jan 07, 2008 8:26 pm

Hi,

Sounds like you are having a similar problem to me.

I have had it since starting the board just a few days ago, and I use firefox.

I have to log in twice to get to the control panel. Then I am sent to relog in again often, from 2-10 minute intervals. This goes on continually. I can log in 20 times a day while setting this board up. VERY annoying.

I have clicked keep me logged in, and remember password, but neither work.

I think it is something to do with:

General/load settings:
Session length, Sessions will expire after this time, in seconds. Mine is set to 0, but I don't know how many seconds is the best to set it for.

Also there is a log in expiration length in days in general/security settings for the person who was looking for it.

Janet
http://www.life-inspirations.net/forum
Janet Greene
Change Your Life with Reverse Metaphysics
Greene'sRelease.com

User avatar
lampstandstudy
Registered User
Posts: 53
Joined: Sun Mar 26, 2006 6:46 pm
Location: Colorado
Contact:

Re: Login problem

Post by lampstandstudy » Mon Jan 07, 2008 10:05 pm

I have one user complaining of this same problem but no one else. Has anyone found a solution yet? Does not appear any support staff has replied on this topic yet.

AlbertSz
Registered User
Posts: 48
Joined: Mon Nov 10, 2003 2:01 pm

Re: Login problem

Post by AlbertSz » Mon Jan 07, 2008 10:42 pm

lampstandstudy wrote:I have one user complaining of this same problem but no one else. Has anyone found a solution yet? Does not appear any support staff has replied on this topic yet.
I managed to solve my similar probem

try setting cookies and other parameters

http://www.phpbb.com/kb/article/configu ... -settings/

if it does not work try to "empty" DB tables phpbb_sessions and phpbb_sessions_keys
make shure that the "Type" is set to MyISAM or InnoDB

User avatar
lampstandstudy
Registered User
Posts: 53
Joined: Sun Mar 26, 2006 6:46 pm
Location: Colorado
Contact:

Re: Login problem

Post by lampstandstudy » Mon Jan 07, 2008 11:18 pm

I tried the two dot before domain suggestion before the last reply, now I can't get in either, help!

Janetfl
Registered User
Posts: 44
Joined: Fri Jan 04, 2008 3:23 am
Contact:

Re: Login problem

Post by Janetfl » Tue Jan 08, 2008 5:04 am

HI,

Not sure if this will help, but I found this article in the knowledge base and it has some good info about logging in probs.

http://www.phpbb.com/kb/article/configu ... -settings/


Good luck

Janet
http://www.life-inspirations.net
Janet Greene
Change Your Life with Reverse Metaphysics
Greene'sRelease.com

User avatar
lampstandstudy
Registered User
Posts: 53
Joined: Sun Mar 26, 2006 6:46 pm
Location: Colorado
Contact:

Re: Login problem

Post by lampstandstudy » Tue Jan 08, 2008 9:47 am

Thanks for your reply but that mod is for phpbb2x. Will it work for 3? THanks!

furious23
Registered User
Posts: 3
Joined: Sat Jan 05, 2008 8:37 pm

Re: Login problem

Post by furious23 » Tue Jan 08, 2008 10:27 am

I've done the manual fix from the how-to.. it seem that it is working now... :-) my Cookie-Domain was http://www.ecarpc.de instead of .ecarpc.de an my cookie-path was / instead of /phpBB3 (without ending backslash).

soddy
Registered User
Posts: 11
Joined: Fri Jan 04, 2008 11:30 am

Re: Login problem

Post by soddy » Tue Jan 08, 2008 8:40 pm

AlbertSz wrote:fixed my problem :)

you need to empty phpbb_sessions and phpbb_sessions_keys

make shure that the "Type" is the same everywhere i.e. MyISAM or InnoDB

I will post later on how I did it
i tried this before but it didn't help but later replacing the whole database solved my problem.

soddy
Registered User
Posts: 11
Joined: Fri Jan 04, 2008 11:30 am

Re: Login problem

Post by soddy » Tue Jan 08, 2008 8:43 pm

jema wrote:Any idea what table the answer was in?



I have a working phpbb3 and a broken phpbb3 on the same server and running identical code, so this must be in the database somehow and it is really frustrating.
i skipped phpbb_config,phpbb_sessions and phpbb_sessions_keys while copying data from older database and it solved the problem. Maybe problem lied in there. But before that i had already tried emptying phpbb_sessions and phpbb_sessions_keys but it didn't help.

cmwoodard14
Registered User
Posts: 6
Joined: Thu Nov 15, 2007 10:45 pm
Contact:

Re: Login problem

Post by cmwoodard14 » Tue Jan 08, 2008 10:29 pm

If you delete the phpbb_config file in your database do you lose all of your configuration settings such as Forum permissions and any other settings you have made?

Locked

Return to “[3.0.x] Support Forum”