Login problem

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
User avatar
Eelke
QA Team
Posts: 2903
Joined: Thu Dec 20, 2001 8:00 am
Location: NL, Bussum
Name: Eelke Blok
Contact:

Re: Login problem

Post by Eelke » Thu Nov 20, 2008 8:10 am

I think he is speaking about the session validation settings in the ACP, that determine whether a request with a certain session ID is indeed a valid request for that particular session.

One of the safety checks (that can be disabled), checks the browser identification string to see whether it is identical to the previous request (if not, it would indicate that the browser was switched, which could indicate the session being hijacked).

There was at least one report about a browser plugin messing with the browser identification string, meaning it would change during a session (which would cause this browser validation check to fail and log you out). I believe this was with CoolIris, not sure what browser, could have been IE7. I think it was reported in this thread, have a read through it.

mikeel100
Registered User
Posts: 3
Joined: Thu Oct 30, 2008 1:20 am

Re: Login problem

Post by mikeel100 » Tue Nov 25, 2008 9:33 pm

Same problem here with IE on XP. Registered and logged on users can play Windows Media type files in a topic, but when they leave the topic, they get logged off. It's got me scratching my head. I've tried changing user, forum, and global settings but to no avail. IE just doesn't keep them logged in. I sure could use some help on this one.

Firefox and Chrome works fine...

Tried IE7 again after reading this FAQ:

Why do I get logged off automatically?
If you do not check the Log me in automatically box when you login, the board will only keep you logged in for a preset time. This prevents misuse of your account by anyone else. To stay logged in, check the box during login. This is not recommended if you access the board from a shared computer, e.g. library, internet cafe, university computer lab, etc. If you do not see this checkbox, it means the board administrator has disabled this feature.


I clicked on "log me in automatically", played media files, and switched forums just fine. Logged out and back in without checking "log me in automatically". IE should have remembered me from the last session since I hadn't removed cookies...but it had already lost my identity. So, I logged in, browsed, and played media files then switched forums and it didn't kick me off this time. It's acting like it should now, with the exception of losing my identity for automatic login...

What's going on?

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29247
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Re: Login problem

Post by Marshalrusty » Tue Dec 23, 2008 6:27 pm

As this topic has become long and unreadable, I am going to close it.

If your question has not been answered, please start a new topic with the Support Request Template filled out.
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

Locked

Return to “[3.0.x] Support Forum”