Login problem

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
cmwoodard14
Registered User
Posts: 6
Joined: Thu Nov 15, 2007 10:45 pm
Contact:

Re: Login problem

Post by cmwoodard14 » Wed Jan 09, 2008 3:24 am

soddy wrote:
jema wrote:Any idea what table the answer was in?



I have a working phpbb3 and a broken phpbb3 on the same server and running identical code, so this must be in the database somehow and it is really frustrating.
i skipped phpbb_config,phpbb_sessions and phpbb_sessions_keys while copying data from older database and it solved the problem. Maybe problem lied in there. But before that i had already tried emptying phpbb_sessions and phpbb_sessions_keys but it didn't help.
OK, I have fixed the login issues at my forum. I did the same thing as soddy and it worked for me too. I skipped phpbb_config,phpbb_sessions and phpbb_sessions_keys while copying data from older database and it solved the problem.

Soddy, thanks for posting your solution it was a real life saver.

Tullamore
Registered User
Posts: 21
Joined: Tue Jun 01, 2004 6:09 pm

Re: Login problem

Post by Tullamore » Wed Jan 09, 2008 8:42 pm

My solution was to set "Force server URL settings:" to Yes
Running a custom phpBB 2.1 powered knowledge base with over 100 forums/catagories.

Blink
Registered User
Posts: 21
Joined: Thu Jan 03, 2008 3:17 pm

Re: Login problem

Post by Blink » Thu Jan 10, 2008 9:46 am

I'm still having issues with this, if it is a cookie issue then I would wonder how come some people are logging in fine and some aren't? Also I randomly have trouble logging in.

With regard to the db issue, I exported my phpBB3 database without the sessions, sessions_keys and config and then reinstalled a fresh phpbb3. I then dropped all the tables except the three mentioned above and re-imported my SQL dump. It appears to have helped a bit (some users who couldn't login now can) but it's still causing issues. (my board settings are here - http://www.phpbb.com/community/viewtopi ... &sk=t&sd=a)

This must be a problem with the forum code somewhere, do any of the developers or support team have a view on this?

BioLogIn
Registered User
Posts: 172
Joined: Sun Jan 06, 2008 10:51 am

Re: Login problem

Post by BioLogIn » Thu Jan 10, 2008 12:21 pm

we experience the same problem.
trying the Tullamore solution now.

soddy
Registered User
Posts: 11
Joined: Fri Jan 04, 2008 11:30 am

Re: Login problem

Post by soddy » Thu Jan 10, 2008 12:44 pm

cmwoodard14 wrote:
soddy wrote:
jema wrote:Any idea what table the answer was in?



I have a working phpbb3 and a broken phpbb3 on the same server and running identical code, so this must be in the database somehow and it is really frustrating.
i skipped phpbb_config,phpbb_sessions and phpbb_sessions_keys while copying data from older database and it solved the problem. Maybe problem lied in there. But before that i had already tried emptying phpbb_sessions and phpbb_sessions_keys but it didn't help.
OK, I have fixed the login issues at my forum. I did the same thing as soddy and it worked for me too. I skipped phpbb_config,phpbb_sessions and phpbb_sessions_keys while copying data from older database and it solved the problem.

Soddy, thanks for posting your solution it was a real life saver.
its gr8 that it worked for u too...but still the cause of the problem is unknown. I think its a bug in the code since so many ppl are having the same problem. Will the developers read this and take any action? This bug is causing so much problems and loss to many who rely on phpBB. How to bring this to the notice of the developers?

BioLogIn
Registered User
Posts: 172
Joined: Sun Jan 06, 2008 10:51 am

Re: Login problem

Post by BioLogIn » Thu Jan 10, 2008 12:49 pm

Tullamore's solution doesn't work for us. Moreover, it looks like it has nothing to do with the cookies - I
have rewritten all data of one user that has this problem, changed e-mail to mine, changed password, reactivated account just in case - still I can't log in as him, and _can_ login as myself. I wiped all cookies multiple times, I have all possible checks (IP check, header, etc) disabled - no luck still. So I guess this has something to so with database and users' entries.

I'll be trying to drop some mentioned tables from sql database later today.

Very nasty issue, I hope this will get attention and help of support team (

cmwoodard14
Registered User
Posts: 6
Joined: Thu Nov 15, 2007 10:45 pm
Contact:

Re: Login problem

Post by cmwoodard14 » Thu Jan 10, 2008 1:19 pm

I agree, it is a big problem.
I lost some members of my "new" board (when it's critical to gain members) as a result of this issue.

Blink
Registered User
Posts: 21
Joined: Thu Jan 03, 2008 3:17 pm

Re: Login problem

Post by Blink » Thu Jan 10, 2008 1:21 pm

I've submitted it on the bug tracker, hopefully the development team can address this issue as it appears quite common now. Quite a serious one as well.

BioLogIn
Registered User
Posts: 172
Joined: Sun Jan 06, 2008 10:51 am

Re: Login problem

Post by BioLogIn » Thu Jan 10, 2008 2:12 pm

Hmmm, I think that bug you submitted was deleted. I saw it a hour ago, and now I don't.

Blink
Registered User
Posts: 21
Joined: Thu Jan 03, 2008 3:17 pm

Re: Login problem

Post by Blink » Thu Jan 10, 2008 2:37 pm

Apparently it's been changed to Support Request. I'm not sure what that means as i'm not much of a user of these forums and site but I hope it gets looked at. :P

BioLogIn
Registered User
Posts: 172
Joined: Sun Jan 06, 2008 10:51 am

Re: Login problem

Post by BioLogIn » Thu Jan 10, 2008 3:02 pm

2Blink
can you give a link to it, please?

==

To be more specific:
The website is http://forum.fighting.ru
The board version is phpbb 3.0.0. installation was manual (i.e. no wizard at hoster, etc.), database was converted from vB 3.0.6. No mods were installed. The only theme is prosilver. Server runs PHP5.

Security settings:
Allow persistent logins: yes,
Session IP validation: none,
Validate browser: no,
Validated X_FORWARDED_FOR header: no,
Check IP against DNS Blackhole List: no,
Check e-mail domain for valid MX record: yes (this user has a gmail.com mailbox).

The user is 'Droid'. The password is set by me to 'rrrrrr' (that is 6 'r'). The user is not in a ban list. Charging and\or retrieving passwod via email doesn't help.

Everybody is welcome to try and log in as Droid ))
Last edited by BioLogIn on Thu Jan 10, 2008 4:36 pm, edited 1 time in total.

Blink
Registered User
Posts: 21
Joined: Thu Jan 03, 2008 3:17 pm

Re: Login problem

Post by Blink » Thu Jan 10, 2008 3:26 pm

Here is my submitted ticket - http://www.phpbb.com/bugs/phpbb3/ticket ... t_id=19085

Apologies if that's not how they should be filled out.

User avatar
lampstandstudy
Registered User
Posts: 53
Joined: Sun Mar 26, 2006 6:46 pm
Location: Colorado
Contact:

Re: Login problem

Post by lampstandstudy » Thu Jan 10, 2008 4:55 pm

Interesting that this thread has not had a support staff suggestion, especially considering how long it has been running.

User avatar
splashy11
Registered User
Posts: 30
Joined: Thu Jan 10, 2008 10:47 pm

Re: Login problem

Post by splashy11 » Fri Jan 11, 2008 12:31 am

Most members are not affected... just a select few who are reporting problems.

Have tried the fixes above... waiting to hear back from the members to see if they work (fingers crossed).
Would be nice to finally get it sorted.

My foum is http://www.justcanals.com/forum/ if your interested.

Blink
Registered User
Posts: 21
Joined: Thu Jan 03, 2008 3:17 pm

Re: Login problem

Post by Blink » Fri Jan 11, 2008 9:56 am

Any official word on this? I'm still stuck with hardly anyone being able to login, I wished I hadn't upgraded so quickly now.

Locked

Return to “[3.0.x] Support Forum”