Access to the Administration Control Panel is not allowed as

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
dmkizer
Registered User
Posts: 1
Joined: Fri Jul 16, 2010 6:24 pm

Re: Access to the Administration Control Panel is not allowe

Post by dmkizer » Fri Jul 16, 2010 6:25 pm

I had the same problem. I played with it a while and have something of a solution. It involves establishing yourself as a member, then as a moderator, and THEN as the Administrator.

1) Log in.
2) See the screen that says you are now logged in. Wait a moment.
3) It should redirect to a screen that gives you access to the Moderator Control Panel.
4) Click that.
5) Click on Members (top right)
6) Click on your own name.
7) Top middle, click where it says "Administrate User" next to your own name.
8) Sign in again (re-authenticate yourself)
9) You should now be looking at the admin control panel.

majick
Registered User
Posts: 5
Joined: Thu May 13, 2010 3:33 am

Re: Access to the Administration Control Panel is not allowe

Post by majick » Tue Aug 10, 2010 6:57 pm

got totally sick of this issue, i haven't been able to access my acp for ages no matter what i did.
in the end, why have "re-authentication" at all if it is now a BUG *not* a FEATURE?
(until someone can actually fix this properly...)

my 2c: session_admin is simply not being set to 1 somewhere along the line. i've tried to track
down where but to no avail. probably somewhere in includes/sessions.php or includes/auth.php
couldn't it just be explicitly set from the permissions in the first place?!

so to get your acp back go to adm/index.php and comment out the re-authentication code like this:
// if (!isset($user->data['session_admin']) || !$user->data['session_admin'])
// {
// login_box('', $user->lang['LOGIN_ADMIN_CONFIRM'], $user->lang['LOGIN_ADMIN_SUCCESS'], true, false);
// }

at least then you can get to your acp! and it isn't that big a deal since you still need to
login with admin privelages to be able to get into it anyway. re-authenticate that!
(excuse me, i'm so sick of typing in my password and being taken back to the same screen)

and if ur lucky you can then change ur security settings to authenticate browser off, ip check off,
and then change the code back and hope it works like it was sposed to (but it didn't for me.)

enuf. sleep now.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50867
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Access to the Administration Control Panel is not allowe

Post by stevemaury » Tue Aug 10, 2010 7:32 pm

It is not a bug. It works perfectly well. There is something wrong with your installation, but with no information, I cannot say any more. It works in hundreds of thousands of installations.

EDIT. If you do decide you want help, please start your own topic. This one is 2 years old and marked solved. Thanks.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

majick
Registered User
Posts: 5
Joined: Thu May 13, 2010 3:33 am

Re: Access to the Administration Control Panel is not allowe

Post by majick » Thu Aug 19, 2010 1:29 am

thanks for the offer but I've spent way too much time on this already that's why I
decided to turn re-authentication off. I had checked about half a dozen topics
posting a similar problem and tried every solution I could find to no avail.
it doesn't bother me not having it, in fact I actually prefer it not being there now. :-)

semirza
Registered User
Posts: 6
Joined: Sat Jan 14, 2012 12:13 pm

Re: Access to the Administration Control Panel is not allowe

Post by semirza » Sun Apr 01, 2012 10:39 am

Thanks dmkizer for posting on Fri Jul 16, 2010 9:25 pm.....
I had the same problem. I played with it a while and have something of a solution. It involves establishing yourself as a member, then as a moderator, and THEN as the Administrator.

1) Log in.
2) See the screen that says you are now logged in. Wait a moment.
3) It should redirect to a screen that gives you access to the Moderator Control Panel.
4) Click that.
5) Click on Members (top right)
6) Click on your own name.
7) Top middle, click where it says "Administrate User" next to your own name.
8) Sign in again (re-authenticate yourself)
9) You should now be looking at the admin control panel.
Bravo! and thanks a lot. I was denied access to ACP after assigning forum permissions to a new forum. The above post worked perfectly. I am using Olympus 3.0.9 ProSilver.

Once again thanks a lot.

nicotinemilk
Registered User
Posts: 13
Joined: Sun Nov 08, 2015 3:10 pm

Re: Access to the Administration Control Panel is not allowed as

Post by nicotinemilk » Wed Nov 11, 2015 8:19 pm

I know this is an old topic, I just was having the same issue and found no solution in here short of something drastic... I solved this problem myself by adding {S_HIDDEN_FIELDS} before the submit button. This fixed it not letting me in the ACP.

Hope this helps somebody else as it took me 2 hours to figure out. :ugeek:

Locked

Return to “[3.0.x] Support Forum”