help needed-not able to see index page.

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Surf007
Registered User
Posts: 141
Joined: Wed Jun 20, 2007 1:16 pm

help needed-not able to see index page.

Post by Surf007 »

Your board's URL: desi-tadka.com
Version of phpBB3: 3.0.0
Was this a fresh install or a(n) update/upgrade/conversion (please be specific)? upgraded from 2.0.22
Was this an install through your host? No
MODs you have installed: recently installed MOD- User Reputation System and Popup on birthday
When the problem started: Last week

There has been a problem with my board. I have phpbb3 portal installed when i login or wherever i click for board index, it transfers me to the default page of root

eg- http://desi-tadka.com/desi-tadka/

which previously used to be index.php now its portal.php, although this problem was not there when i installed this mod, it started after few days of installation.

Is there anything where i can manually put index.php on Board index url, coz it is not letting me or members come to index.php by the time they type it manually-

http://desi-tadka.com/desi-tadka/index.php
Surf007
Registered User
Posts: 141
Joined: Wed Jun 20, 2007 1:16 pm

Re: help needed-not able to see index page.

Post by Surf007 »

When i was using phpbb 2.0 i was getting more quicker response from moderators, M nt sure why the problem is here in this dept.

I currently have 2 unsolved problems since yesterday, n few more b4 never got replied.
Last edited by Jim_UK on Sun Mar 16, 2008 5:57 pm, edited 1 time in total.
Reason: Please take notice of our 6 hour bump rule. http://www.phpbb.com/rules/
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52228
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: help needed-not able to see index page.

Post by Brf »

In includes/functions.php, you shoul dhave this line:

Code: Select all

	'U_INDEX'				=> append_sid("{$phpbb_root_path}index.$phpEx"),
Apparently, it has been redefined as "./" on your board.
Surf007
Registered User
Posts: 141
Joined: Wed Jun 20, 2007 1:16 pm

Re: help needed-not able to see index page.

Post by Surf007 »

Brf wrote:In includes/functions.php, you shoul dhave this line:

Code: Select all

	'U_INDEX'				=> append_sid("{$phpbb_root_path}index.$phpEx"),
Apparently, it has been redefined as "./" on your board.

The line is there as it is, in the file.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52228
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: help needed-not able to see index page.

Post by Brf »

Then you must be redefining it somewhere else....

This is the code in your prosilver/template/overall_header.html:

Code: Select all

<li class="icon-home"><a href="{U_PORTAL}">{L_PORTAL}</a> &#187; <a href="{U_INDEX}" accesskey="h">{L_INDEX}</a> 
and this is the generated code in your index:

Code: Select all

<li class="icon-home"><a href="./portal.php">Portal</a> &#187; <a href="./" accesskey="h">Board index</a> 
Therefore "U_INDEX" is "./"

If you have recently corrected your overall_header.html, then you will need to clear your board's cache to pull in the corrected template.
Surf007
Registered User
Posts: 141
Joined: Wed Jun 20, 2007 1:16 pm

Re: help needed-not able to see index page.

Post by Surf007 »

and this is the generated code in your index:

Code: Select all

<li class="icon-home"><a href="./portal.php">Portal</a> &#187; <a href="./" accesskey="h">Board index</a> 
This code is not there, i have purged the cache as well.

Which file do i need to correct, coz the other code which u have given me is there in overall_header.html
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52228
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: help needed-not able to see index page.

Post by Brf »

yes. I told you it was there.

If your cache is up-to-date, then you must have some piece of code somewhere that is setting "U_INDEX" to '"./"
Surf007
Registered User
Posts: 141
Joined: Wed Jun 20, 2007 1:16 pm

Re: help needed-not able to see index page.

Post by Surf007 »

How do i search it now, DO i need to find ./ this in all php files.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52228
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: help needed-not able to see index page.

Post by Brf »

It would be much easier to search for "U_INDEX"
Surf007
Registered User
Posts: 141
Joined: Wed Jun 20, 2007 1:16 pm

Re: help needed-not able to see index page.

Post by Surf007 »

Code: Select all

$phpbb_root_path = (defined('PHPBB_ROOT_PATH')) ? PHPBB_ROOT_PATH : './../';
This is the code i found in index.php

is there anything wrong with it?
Surf007
Registered User
Posts: 141
Joined: Wed Jun 20, 2007 1:16 pm

Re: help needed-not able to see index page.

Post by Surf007 »

bump.
Surf007
Registered User
Posts: 141
Joined: Wed Jun 20, 2007 1:16 pm

Re: help needed-not able to see index page.

Post by Surf007 »

bump bump bump.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52228
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: help needed-not able to see index page.

Post by Brf »

Surf007 wrote:

Code: Select all

$phpbb_root_path = (defined('PHPBB_ROOT_PATH')) ? PHPBB_ROOT_PATH : './../';
This is the code i found in index.php

is there anything wrong with it?
What does that have to do with 'U_INDEX' ?
Locked

Return to “[3.0.x] Support Forum”