Board has no forums

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
pavilion1250
Registered User
Posts: 13
Joined: Thu Mar 20, 2008 6:16 pm

Board has no forums

Post by pavilion1250 »

Guests were able to view my forums but now they cannot. When they go to the index page it says Board has no forums. The guests permissions are set to read only. Not sure what to do.. PLEASE HELP!!!

Thanks
Pavilion1250
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52229
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Board has no forums

Post by Brf »

Did you remove the Anonymous user from the Guests group?
pavilion1250
Registered User
Posts: 13
Joined: Thu Mar 20, 2008 6:16 pm

Re: Board has no forums

Post by pavilion1250 »

Yes I did
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52229
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Board has no forums

Post by Brf »

Put it back.
pavilion1250
Registered User
Posts: 13
Joined: Thu Mar 20, 2008 6:16 pm

Re: Board has no forums

Post by pavilion1250 »

Thanks for the help. As soon as you said that knew what ws wrong. I'm Trying figure that out now.

Thanks again
Pavilion1250
pavilion1250
Registered User
Posts: 13
Joined: Thu Mar 20, 2008 6:16 pm

Re: Board has no forums

Post by pavilion1250 »

This may sound dumb, but how do I put back the Anonymous user?
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52229
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Board has no forums

Post by Brf »

Brf wrote: The SQL to create it, pulled from schema_data.sql is:

Code: Select all

INSERT INTO phpbb_users (user_type, group_id, username, username_clean, user_regdate, user_password, user_email, user_lang, user_style, user_rank, user_colour, user_posts, user_permissions, user_ip, user_birthday, user_lastpage, user_last_confirm_key, user_post_sortby_type, user_post_sortby_dir, user_topic_sortby_type, user_topic_sortby_dir, user_avatar, user_sig, user_sig_bbcode_uid, user_from, user_icq, user_aim, user_yim, user_msnm, user_jabber, user_website, user_occ, user_interests, user_actkey, user_newpasswd, user_allow_massemail) VALUES (2, 1, 'Anonymous', 'anonymous', 0, '', '', 'en', 1, 0, '', 0, '', '', '', '', '', 't', 'a', 't', 'd', '', '', '', '', '', '', '', '', '', '', '', '', '', '', 0);
and

Code: Select all

INSERT INTO phpbb_user_group (group_id, user_id, user_pending, group_leader) VALUES (1, 1, 0, 0);
pavilion1250
Registered User
Posts: 13
Joined: Thu Mar 20, 2008 6:16 pm

Re: Board has no forums

Post by pavilion1250 »

Will this work for phpBB3.0?
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52229
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Board has no forums

Post by Brf »

Yes. That is from the phpbb3 install... Except that you have to set the user_id back to "1"
pavilion1250
Registered User
Posts: 13
Joined: Thu Mar 20, 2008 6:16 pm

Re: Board has no forums

Post by pavilion1250 »

I cannot find that file. I'm sorry but this is very new to me. I'll Keep trying.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52229
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Board has no forums

Post by Brf »

What file?
You do not need a file.
Just run those two SQL statements in phpmyadmin, then adjust the user_id for that one back to "1"
pavilion1250
Registered User
Posts: 13
Joined: Thu Mar 20, 2008 6:16 pm

Re: Board has no forums

Post by pavilion1250 »

Where do I find this (phpmyadmin)? Is this the admin control panel?
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52229
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Board has no forums

Post by Brf »

How did you delete the anonymous user?
pavilion1250
Registered User
Posts: 13
Joined: Thu Mar 20, 2008 6:16 pm

Re: Board has no forums

Post by pavilion1250 »

Users and groups tab/manage groups/ select mebers in the guests line/ check the box next to anonymous user and remove from the drop down. Really dumb move right.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52229
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Board has no forums

Post by Brf »

Then you didnt really delete the anonymous user.
All you did was remove him from the Guests group.
Select the anonymous user by checking the checkbox in Manage Users and add him back to the Guests group.
Locked

Return to “[3.0.x] Support Forum”