Page 1 of 2

Board has no forums

Posted: Thu Mar 27, 2008 1:56 pm
by pavilion1250
Guests were able to view my forums but now they cannot. When they go to the index page it says Board has no forums. The guests permissions are set to read only. Not sure what to do.. PLEASE HELP!!!

Thanks
Pavilion1250

Re: Board has no forums

Posted: Thu Mar 27, 2008 1:57 pm
by Brf
Did you remove the Anonymous user from the Guests group?

Re: Board has no forums

Posted: Thu Mar 27, 2008 2:14 pm
by pavilion1250
Yes I did

Re: Board has no forums

Posted: Thu Mar 27, 2008 2:37 pm
by Brf
Put it back.

Re: Board has no forums

Posted: Thu Mar 27, 2008 2:46 pm
by pavilion1250
Thanks for the help. As soon as you said that knew what ws wrong. I'm Trying figure that out now.

Thanks again
Pavilion1250

Re: Board has no forums

Posted: Thu Mar 27, 2008 4:33 pm
by pavilion1250
This may sound dumb, but how do I put back the Anonymous user?

Re: Board has no forums

Posted: Thu Mar 27, 2008 4:38 pm
by Brf
Brf wrote: The SQL to create it, pulled from schema_data.sql is:

Code: Select all

INSERT INTO phpbb_users (user_type, group_id, username, username_clean, user_regdate, user_password, user_email, user_lang, user_style, user_rank, user_colour, user_posts, user_permissions, user_ip, user_birthday, user_lastpage, user_last_confirm_key, user_post_sortby_type, user_post_sortby_dir, user_topic_sortby_type, user_topic_sortby_dir, user_avatar, user_sig, user_sig_bbcode_uid, user_from, user_icq, user_aim, user_yim, user_msnm, user_jabber, user_website, user_occ, user_interests, user_actkey, user_newpasswd, user_allow_massemail) VALUES (2, 1, 'Anonymous', 'anonymous', 0, '', '', 'en', 1, 0, '', 0, '', '', '', '', '', 't', 'a', 't', 'd', '', '', '', '', '', '', '', '', '', '', '', '', '', '', 0);
and

Code: Select all

INSERT INTO phpbb_user_group (group_id, user_id, user_pending, group_leader) VALUES (1, 1, 0, 0);

Re: Board has no forums

Posted: Thu Mar 27, 2008 4:40 pm
by pavilion1250
Will this work for phpBB3.0?

Re: Board has no forums

Posted: Thu Mar 27, 2008 4:44 pm
by Brf
Yes. That is from the phpbb3 install... Except that you have to set the user_id back to "1"

Re: Board has no forums

Posted: Thu Mar 27, 2008 5:01 pm
by pavilion1250
I cannot find that file. I'm sorry but this is very new to me. I'll Keep trying.

Re: Board has no forums

Posted: Thu Mar 27, 2008 5:03 pm
by Brf
What file?
You do not need a file.
Just run those two SQL statements in phpmyadmin, then adjust the user_id for that one back to "1"

Re: Board has no forums

Posted: Thu Mar 27, 2008 5:09 pm
by pavilion1250
Where do I find this (phpmyadmin)? Is this the admin control panel?

Re: Board has no forums

Posted: Thu Mar 27, 2008 5:12 pm
by Brf
How did you delete the anonymous user?

Re: Board has no forums

Posted: Thu Mar 27, 2008 5:17 pm
by pavilion1250
Users and groups tab/manage groups/ select mebers in the guests line/ check the box next to anonymous user and remove from the drop down. Really dumb move right.

Re: Board has no forums

Posted: Thu Mar 27, 2008 5:21 pm
by Brf
Then you didnt really delete the anonymous user.
All you did was remove him from the Guests group.
Select the anonymous user by checking the checkbox in Manage Users and add him back to the Guests group.