Problems with update to 3.0.1

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
User avatar
Phil
Former Team Member
Posts: 10403
Joined: Sat Nov 25, 2006 4:11 am
Name: Phil Crumm
Contact:

Re: Problems with update to 3.0.1

Post by Phil » Tue Apr 08, 2008 3:53 am

In the event of a conflict, the updater will allow you to preview the conflicts and select the best option (use new or keep existing code). I generally take note of any conflicts that I cannot automatically resolve (the file they occur in, where, and the suggested change) in a text file, then go back and remedy it myself.
Moving on, with the wind. | My Corner of the Web

clight77
Registered User
Posts: 907
Joined: Sun May 11, 2003 11:09 pm

Re: Problems with update to 3.0.1

Post by clight77 » Tue Apr 08, 2008 4:20 am

clight77 wrote:Just finished auto updating, not heavily modded but all seemed to go well that i can tell.
Actually some problems, some things do not work as expected.

Advanced bbcode re-turns to basic bbcode, not a loss as default is way faster.
Topic preview does not work.

Thanks
I Follow Up On My Posts.
So Should Everybody...

Sarrene
Registered User
Posts: 77
Joined: Wed Jan 23, 2008 10:20 am
Name: Sarrene Grant
Contact:

Re: Problems with update to 3.0.1

Post by Sarrene » Tue Apr 08, 2008 5:12 am

I am glad I had come across this thread. I was in the process of making backups just in case something did go wrong. Once I get this done, I will go ahead and do the update and then let everyone here know what happened.

Mods and personal modifications I am using:
  • Who Was Here
    Last Topic Post
    Calender Mod (modified)
    Photo Album (modified)
    Add User
    Custom Rich Text Editor
    Custom theme
    Custom Profile
    Custom Profile display for users
    Joomla Bridge
    Email new Registrants
    Welcome Post
    Additional files modified to fit our community
I am sure it is not a lot as some of you here, but does add up for sure!So, once I get done here with the back ups and updates, I can let you all know what my experience is. Perhaps that might help out others with an idea of what could or does need to be changed and what the risks are.

Peace,
♥ Sarrene'

Sarrene
Registered User
Posts: 77
Joined: Wed Jan 23, 2008 10:20 am
Name: Sarrene Grant
Contact:

Re: Problems with update to 3.0.1

Post by Sarrene » Tue Apr 08, 2008 6:25 am

Hello again. Well I have completed the upgrade, and merged all the files that were required.
One thing I did notice off the bat was how if you selected to view the changes or conflicting files, it just opens up a window with the same exact information as your primary. Did not seem very usefull to me.

Okay, I just got started, and realised that my forum permissions were reset. Guests and regestered members did not have any permissions set. So I went in to redo those again. However, once I went to create a new User Role, I recieved the following error:
  • SQL ERROR [ mysql4 ]

    Duplicate entry '23-0' for key 1 [1062]

    SQL

    INSERT INTO phpbb_acl_roles_data (role_id, auth_option_id, auth_setting) VALUES (23, 0, 1), (23, 0, 1), (23, 0, 1), (23, 0, 1), (23, 0, 1)

    BACKTRACE

    FILE: includes/db/mysql.php
    LINE: 158
    CALL: dbal_mysql->sql_error()

    FILE: includes/db/dbal.php
    LINE: 438
    CALL: dbal_mysql->sql_query()

    FILE: includes/acp/auth.php
    LINE: 966
    CALL: dbal_mysql->sql_multi_insert()

    FILE: includes/acp/acp_permission_roles.php
    LINE: 214
    CALL: auth_admin->acl_set_role()

    FILE: includes/functions_module.php
    LINE: 471
    CALL: acp_permission_roles->main()

    FILE: adm/index.php
    LINE: 74
    CALL: p_master->load_active()
I will see what else happens as well for me. I am not sure what is causing this exactly, as I just recieved the error, however I can see that I am very happy I made backups of my files. ;)

Okay, back to testing. Any one have any thoughts or ideas to a work around for this, it would be great. If not, I will be going back to my original files that I was using. TO be honest, I do see at least three more errors happening, as the files that I was told were unable to be upgraded and merged with the modified files, seems to be giving some problems already.

Odd thing is, the files that this error above are coming from was NOT one that was listed as critical, but safe. So we shall see.

Peace.
♥ Sarrene'

[Edit: It appears as if i am not able to change or alter any permissions. Looking on the db it appears as if several of the tables were messed up. Many duplicate entries as well as some missing peramiters as well in some of them. I am able to adjust current users permissions however, so that is a good thing.]

User avatar
Trinity
Registered User
Posts: 474
Joined: Wed Dec 11, 2002 10:06 pm
Location: Hollywood, CA

Re: Problems with update to 3.0.1

Post by Trinity » Tue Apr 08, 2008 8:06 am

I just did this update using the updater option, and this is what I obtained:
The update files are incomplete.
After the database update/check. Any idea what to do here? Should I just download the updated files only and replace the ones I have?
Shop smart, shop S-mart.

User avatar
kaanuslu
Registered User
Posts: 131
Joined: Sun Jul 03, 2005 4:24 pm
Contact:

Re: Problems with update to 3.0.1

Post by kaanuslu » Tue Apr 08, 2008 8:19 am

greenmtn wrote:I agree. This whole auto updater thing is a bust. I haven't even modified all that much and with the auto updater I get a general error that "the update files are incomplete". Without a documented list of the code changes I have no real options for updating.
I have similar problems, please read this http://www.phpbb.com/community/viewtopi ... 6&t=880975

For the moment I will NOT make any update for my main forum.

User avatar
Interlog
Registered User
Posts: 1258
Joined: Sat Jun 11, 2005 4:11 pm
Location: London, UK
Contact:

Re: Problems with update to 3.0.1

Post by Interlog » Tue Apr 08, 2008 8:42 am

Well my automatic upgrade also went wrong. I'm now in the process to put the files prior to the upgrade back onto the server.

I do miss the code changes as had these be present I could have amended the conflicting files myself.

To the developers:

Please, please could you not write the upgrade process in such a way that those files that have not been amended are automatically updated whilst those files that have conflicts are left alone with a code changes options similar to the phpBB2 code changes package being shown so users can manually update the file.

Mark :D
Image

Sarrene
Registered User
Posts: 77
Joined: Wed Jan 23, 2008 10:20 am
Name: Sarrene Grant
Contact:

Re: Problems with update to 3.0.1

Post by Sarrene » Tue Apr 08, 2008 9:36 am

Well, it has been a long night. I had gone back in and tried to correct the db changes that the update made, and I am still getting a few errors things like posting, profiles and of course, groups/ranks.

So, what I am doing now is dumping the whole thing (Thank the lords it is a test server) and then going to try with a fresh install. Once that is done, I will make all the modifications again to my site both on the default and the custom theme i made.

I am curious as to what has actualy changed. While Im waiting on the delete/re-uploads, I am going through the files and it does seems as if some of the major changes were done to the following files:
  • functions.php
    includudes/sessions.php
    laqnguage/en/acp/common.php
Hopefully these were not modified too much as to make it difficult to have custom themes as well as some of the wonderful mods that people have created over time.

I will let you all know (whether you want to or not :P ) how this goes. Of course, it might take a wee bit, since I have a lot to do.

If anyone else is doing this, let me know how things are progressing and any kinks you have found.

Peace,
♥ Sarrene'

Sarrene
Registered User
Posts: 77
Joined: Wed Jan 23, 2008 10:20 am
Name: Sarrene Grant
Contact:

Re: Problems with update to 3.0.1

Post by Sarrene » Fri Apr 11, 2008 6:25 am

Okay, I promised an update on the reload. On a good note, everything worked but three little things. And two were not even mod related. 1) Polls and poll results did not transfer over. 2) Avatars did not transfer. 3) Gallery Categories did not transfer. Other then that, everything else did, and it went smooth!

So anyone that might have difficulties, and not sure what to do, here is what I did and what happened. Yes, I know it seems like a lot of work, but I had tried everything on my test server and came up with several errors if I was using modified files. Of course, this is for those like me, that have heavily modified boards.

Made backups of all my files, including mysql.
Dumped the server files and did a fresh install
Through mysql, dropped and imported the following tables: (Bold are phpbb defaults)
  • phpbb_attachments
    phpbb_calendar_config
    phpbb_calendar_event_types
    phpbb_calendar_events
    phpbb_forums
    phpbb_forums_track
    phpbb_forums_watch

    phpbb_gallery_albums
    phpbb_gallery_comments
    phpbb_gallery_config
    phpbb_gallery_images
    phpbb_gallery_rates
    phpbb_poll_options
    phpbb_poll_votes
    phpbb_posts
    phpbb_smilies
    phpbb_topics
    phpbb_topics_posted
    phpbb_topics_track
    phpbb_topics_watch
    phpbb_users
Then I reinstalled the mods again, and uploaded my custom themes. So initially this was more like a restoring a backup, just upgraded from 3.0.0 to 3.0.1 It was a bit of work, of course I tested this out in several ways.

The polls and uploaded avatars did not transfer even on an unmodified board. Test #3 was clean install, created two categories, made a few posts and made one poll. Did the above, and poll/poll results still did not transfer over. So might be a bug, might be because of some of the changes in the structure, I do not know. It would take someone with more knowledge and know how then me to find out.

So, if you want to upgrade a highly modded forum with out much of a problem. Just some time, this seems to be the best way. Most mods were effected, though not all by a strait up upgrade.

I think total time it took me for my live forum was 2.5 hours. That was from making backups to finish. I hope this can help someone out. Or others pipe in with what they did to upgrade and avoided the many errors that can occur with a highly modified board. I am sure there are better ways that I had not thought of.

Peace,
Sarrene'

User avatar
noth
Registered User
Posts: 2481
Joined: Fri Jan 07, 2005 7:10 pm
Location: North Surrey
Contact:

Re: Problems with update to 3.0.1

Post by noth » Fri Apr 11, 2008 6:50 am

Soemthing needs to be done to streamline the update process for admins who have used any mods

The previous posts make scary and highly disappointing reading.

If there ever was a reason NOT to update to the next version THIS TOPIC IS IT :shock:

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Problems with update to 3.0.1

Post by karlsemple » Fri Apr 11, 2008 6:52 am

The simple solution is to use the auto-updater, once the updater has checked the files you can use the unofficial code changes linked in my sig to update the files/ or code around any conflicts found, then save the files and do the file check again.... all being well the updater would then find no conflicts and you can proceed with the auto-updater :)
Image

User avatar
noth
Registered User
Posts: 2481
Joined: Fri Jan 07, 2005 7:10 pm
Location: North Surrey
Contact:

Re: Problems with update to 3.0.1

Post by noth » Fri Apr 11, 2008 7:02 am

Where is the auto updater please? :oops:

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Problems with update to 3.0.1

Post by karlsemple » Fri Apr 11, 2008 7:03 am

noth wrote:Where is the auto updater please? :oops:
Click the download link at the top of the page(in the header) and then click the 3.0.1 download link, on the downloads page you will find the auto-updater under the headerin "[ Update Packages (0/1-RC1 to 3.0.1) ]"
Image

User avatar
kaanuslu
Registered User
Posts: 131
Joined: Sun Jul 03, 2005 4:24 pm
Contact:

Re: Problems with update to 3.0.1

Post by kaanuslu » Fri Apr 11, 2008 7:24 am

Thank you for your help but 490KB :shock: changed text file is NOT a simple solution for any amateur user.

I definitly NOT recommend any amateur user like me, to update from 3.0.0 to 3.0.1
I am waiting for next update :!:

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Problems with update to 3.0.1

Post by karlsemple » Fri Apr 11, 2008 7:28 am

kaanuslu wrote:Thank you for your help but 490KB :shock: changed text file is NOT a simple solution for any amateur user.

I definitly NOT recommend any amateur user like me, to update from 3.0.0 to 3.0.1
I am waiting for next update :!:
karlsemple wrote:The simple solution is to use the auto-updater, once the updater has checked the files you can use the unofficial code changes linked in my sig to update the files/ or code around any conflicts found, then save the files and do the file check again.... all being well the updater would then find no conflicts and you can proceed with the auto-updater :)
As I clearly said in my last post the code change are best used to only update the files showing conflicts.....and how is the next update going to solve this issue? Then there is going to be even more code which needs updating :)
Image

Locked

Return to “[3.0.x] Support Forum”