Error after installing phpbb3

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
divigo
Registered User
Posts: 15
Joined: Wed Apr 23, 2008 7:58 pm

Error after installing phpbb3

Post by divigo »

Hello

I'm trying to get phpbb3 to work on my PC.
I'm using wamp for this.
The installation worked out well but I can't get on the forum.
When entering I get the following error.

Code: Select all

General Error
SQL ERROR [ sqlite ]
SQL logic error or missing database [1]
An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
It seems something is wrong with the connection to my database.
As a test to see if wamp is working I also installed phpbb2.
This didn't cause any problems.

I'm trying to install the forum on my PC so I can do tests with mods before I will use them on the live forum.
Can anybody help me with this issue?

Gr Dennis
User avatar
battye
Extension Customisations
Extension Customisations
Posts: 10952
Joined: Wed Feb 11, 2004 11:02 am
Location: Australia
Contact:

Re: Error after installing phpbb3

Post by battye »

It mentions missing database... I just want to make sure that the database component is turned on in WAMP? I haven't used WAMP myself, but many of the home servers allow you to turn on and off the database, PHP, etc.
Customisations Team Member

https://github.com/battye/php-array-parser - Give it a Star! :D
divigo
Registered User
Posts: 15
Joined: Wed Apr 23, 2008 7:58 pm

Re: Error after installing phpbb3

Post by divigo »

I did start all services and phpbb2 works fine with it.
To me it looks something in the connection is "missing" but I don't know how phpbb3 and a database work together.
I have tried reinstalling wamp a couple of times and also phpbb3 with no results.
Downloaded a new version of wamp and phpbb3 that also didn't give me any results.

Gr Dennis
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51470
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Error after installing phpbb3

Post by stevemaury »

Did you create a database?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
divigo
Registered User
Posts: 15
Joined: Wed Apr 23, 2008 7:58 pm

Re: Error after installing phpbb3

Post by divigo »

stevemaury wrote:Did you create a database?
Yes I did but i´m doubting if it´s done correctly.

Gr Dennis
divigo
Registered User
Posts: 15
Joined: Wed Apr 23, 2008 7:58 pm

Re: Error after installing phpbb3

Post by divigo »

Anybody who can help me with this?

Gr Dennis
User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Re: Error after installing phpbb3

Post by A_Jelly_Doughnut »

I haven't been able to get SQLite to work with WAMP 1.8. I'm not really sure what the problem is with that. I'd suggest using MySQL if you can.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish
divigo
Registered User
Posts: 15
Joined: Wed Apr 23, 2008 7:58 pm

Re: Error after installing phpbb3

Post by divigo »

I solved the problem with installing xampp instead of wamp.
It isn't a solution for the problem with wamp but atleast I'm able now to work on the forum in a test zone.
Thanks for helping me.

Gr Dennis
Locked

Return to “[3.0.x] Support Forum”