"Hello World!" - Extension & Skeleton Tool

Discussion forum for Extension Writers regarding Extension Development.
User avatar
Stoker 4.0
Registered User
Posts: 1433
Joined: Sun Feb 13, 2011 1:33 pm
Location: Funen, Denmark
Name: Ulrik Christensen
Contact:

Re: "Hello World!" - Extension

Post by Stoker 4.0 » Sat Mar 29, 2014 3:58 pm

Thanks

asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

Re: "Hello World!" - Extension

Post by asinshesq » Sun Mar 30, 2014 3:58 pm

PayBas wrote:Too early. Either use licence (instead of license), or wait for beta 2.
Thanks. Where would I change this in the sample extension?

User avatar
Prosk8er
Registered User
Posts: 1387
Joined: Sun Mar 12, 2006 3:30 am
Location: Rochester, NY
Name: Tyler
Contact:

Re: "Hello World!" - Extension

Post by Prosk8er » Mon Mar 31, 2014 12:51 am

ext/user/mod/composer.json
see viewtopic.php?f=461&t=2234931
formerly bprsk8r4272 Proud Kiss Portal user on phpBB 3.0.14 + 1.0.20 (build 311-020)
Image
Validated Extensions, Mods, and Styles My Mods: Smashable Christmas Lights 3.0.x Add a group to teampage 3.0.x

aaronnz220
Registered User
Posts: 10
Joined: Sat Jul 26, 2014 6:27 am

Re: "Hello World!" - Extension

Post by aaronnz220 » Sat Jul 26, 2014 7:24 am

How do you change the page title from 'world' to something like About Us.

User avatar
tmbackoff
Former Team Member
Posts: 6995
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: "Hello World!" - Extension

Post by tmbackoff » Sat Jul 26, 2014 3:25 pm

Code: Select all

$this->helper->render('demo_body.html', $name);
The $name variable is the page title displayed in the browser tab/window.

User avatar
bbthailand
Translator
Posts: 54
Joined: Wed Jun 18, 2008 6:00 am
Contact:

Re: "Hello World!" - Extension

Post by bbthailand » Mon Aug 11, 2014 3:52 pm

Thanks.

User avatar
wkuzma
Registered User
Posts: 389
Joined: Sun Sep 02, 2007 10:18 pm
Contact:

Re: "Hello World!" - Extension

Post by wkuzma » Mon Oct 27, 2014 5:53 pm

Thanks for the extension I will use it to edit mt system

User avatar
Phillip
Registered User
Posts: 61
Joined: Tue Oct 29, 2013 4:41 am
Location: The index
Contact:

Re: "Hello World!" - Extension

Post by Phillip » Tue Oct 28, 2014 1:20 am

Nice work on the extension.
“Be who you are and say what you feel, because those who mind don't matter, and those who matter don't mind.”
― Bernard M. Baruch​

Bruninoit
Registered User
Posts: 500
Joined: Thu Jun 13, 2013 2:34 pm
Location: Florence (Italy)
Name: Bruno Andrew
Contact:

Re: "Hello World!" - Extension

Post by Bruninoit » Fri Nov 21, 2014 8:58 pm

There is a bug. When I go to my forum root without index.php on link (for exemple http://mysite.com/forum) when I click to "demo" open the page forum/demo/world and the server give error. When I go on mysite.com/forum/index.php and click to demo it work. Thanks

User avatar
M.O.B.
Registered User
Posts: 887
Joined: Tue Jan 04, 2005 1:07 am
Location: San Diego CA USA
Contact:

Re: "Hello World!" - Extension

Post by M.O.B. » Sat Nov 22, 2014 3:05 am

Thanks for this, it helps. I wish there was an automatic app to help us convert some old phpBB 3.0.x MODs into 3.1.x extensions. :)
Image

Bruninoit
Registered User
Posts: 500
Joined: Thu Jun 13, 2013 2:34 pm
Location: Florence (Italy)
Name: Bruno Andrew
Contact:

Re: "Hello World!" - Extension

Post by Bruninoit » Wed Dec 10, 2014 12:27 pm

Brunino wrote:There is a bug. When I go to my forum root without index.php on link (for exemple http://mysite.com/forum) when I click to "demo" open the page forum/demo/world and the server give error. When I go on mysite.com/forum/index.php and click to demo it work. Thanks
The bug continues with phpBB 3.1.2 :oops:

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 16543
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: "Hello World!" - Extension

Post by DavidIQ » Fri Dec 12, 2014 2:12 pm

Brunino wrote:
Brunino wrote:There is a bug. When I go to my forum root without index.php on link (for exemple http://mysite.com/forum) when I click to "demo" open the page forum/demo/world and the server give error. When I go on mysite.com/forum/index.php and click to demo it work. Thanks
The bug continues with phpBB 3.1.2 :oops:
Sounds like a problem with your server configuration. Not sure what this extension has to do with this issue though. :?:
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: "Hello World!" - Extension

Post by nickvergessen » Thu Jan 22, 2015 10:36 pm

DavidIQ wrote:
Brunino wrote:
Brunino wrote:There is a bug. When I go to my forum root without index.php on link (for exemple http://mysite.com/forum) when I click to "demo" open the page forum/demo/world and the server give error. When I go on mysite.com/forum/index.php and click to demo it work. Thanks
The bug continues with phpBB 3.1.2 :oops:
Sounds like a problem with your server configuration. Not sure what this extension has to do with this issue though. :?:
We fixed that für 3.1.2, it was a bug in phpBB itself
No Support via PM

User avatar
serek
Registered User
Posts: 45
Joined: Fri Jan 30, 2015 12:47 pm
Location: London
Name: Serge Victor
Contact:

Re: "Hello World!" - Extension

Post by serek » Sat Jan 31, 2015 2:41 pm

When I uninstall extension and remove all data, there is still some leftover left in Extensions subdirectory in ACP modules - I think it is a bug.
No, sorry, it was a false report. I have installed a clean version of phpbb and everything is working correctly. Sorry again.

Bruninoit
Registered User
Posts: 500
Joined: Thu Jun 13, 2013 2:34 pm
Location: Florence (Italy)
Name: Bruno Andrew
Contact:

Re: "Hello World!" - Extension

Post by Bruninoit » Thu Feb 12, 2015 6:22 am

Brunino wrote:There is a bug. When I go to my forum root without index.php on link (for exemple http://mysite.com/forum) when I click to "demo" open the page forum/demo/world and the server give error. When I go on mysite.com/forum/index.php and click to demo it work. Thanks
Here the solution: viewtopic.php?f=466&t=2287356&p=13934441#p13934441

Post Reply

Return to “Extension Writers Discussion”

Who is online

Users browsing this forum: No registered users and 22 guests