Page 1 of 1

Is there a template variable to check the phpBB version?

Posted: Thu Dec 22, 2016 12:53 pm
by Big Monstro
Hello,

In addition to a phpBB 3.1.x board, I manage a phpBB 3.2.0-RC2 one for testing purpose.

I noticed the board styles designed for phpBB 3.1.x actually work fine on phpBB 3.2, unlike phpBB 3.0.x styles on phpBB 3.1. Obviously, there are some minor bugs but they remains definitely usable.

About custom styles: instead of releasing two different package (from the phpBB 3.2 release until the phpBB 3.1 end of support), it make sense to release only one, including some fixes which target phpBB 3.2.

My question is : is there a template variable to detect the phpBB version? Such as...

Code: Select all

<!-- IF phpBB_version gte 3.2.0 --> specific instruction for phpBB 3.2 boards <!-- ELSE --> specific instruction for phpBB 3.1 boards <!-- ENDIF -->
It would be useful, for example, in captcha_default.html (if phpBB 3.1 => google reCAPTCHA v1, if phpBB 3.2 => google reCAPTCHA), bbcode.html (some changes for quote tag), etc.

Thank you for your answers !