Page 1 of 1

Error I got when it wanted to create dB tables!

Posted: Wed Apr 23, 2014 10:00 am
by MNIAL95
Hello there, how're you doing today?
Today I just wanted to try installing phpBB 3.1 Beta2 on my website (it was just a testing site) but I got the following error when the installation guide was creating dB tables:

Code: Select all

Fatal error: Uncaught exception 'Symfony\Component\DependencyInjection\Exception\InvalidArgumentException' with message 'The service definition "auth.provider." does not exist.' in /home/daythrea/domains/day-threads.com/public_html/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php:875 

Stack trace:
#0 /home/daythrea/domains/day-threads.com/public_html/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php(483): Symfony\Component\DependencyInjection\ContainerBuilder->getDefinition('auth.provider.') 
#1 /home/daythrea/domains/day-threads.com/public_html/phpbb/session.php(579): Symfony\Component\DependencyInjection\ContainerBuilder->get('auth.provider.') 
#2 /home/daythrea/domains/day-threads.com/public_html/phpbb/session.php(500): phpbb\session->session_create() 
#3 /home/daythrea/domains/day-threads.com/public_html/app.php(23): phpbb\session->session_begin() 
#4 {main} thrown in /home/daythrea/domains/day-threads.com/public_html/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php on line 875
I have Linux Ubuntu 12.04.2LTS hosting with MySQL 5.5 and PHP 5.3.28 with PERL support ...
The weird thing is that I could install successfully the Beta1 of phpBB 3.1 - Why can't I install Beta2?

Re: Error I got when it wanted to create dB tables!

Posted: Thu Apr 24, 2014 4:14 pm
by MNIAL95
Please help me to understand why I get that error with beta2 and not with beta1 at all!!

Re: Error I got when it wanted to create dB tables!

Posted: Fri Apr 25, 2014 3:52 am
by Noxwizard
This is a fresh install and not an upgrade?

Re: Error I got when it wanted to create dB tables!

Posted: Sat Apr 26, 2014 11:27 am
by MNIAL95
Noxwizard wrote:This is a fresh install and not an upgrade?
Yes, it's a fresh install and I get that error with only installation of Beta2 which I don't absolutely get with Beta1 and I still wonder of the specific reason! I hope it won't happen with Beta3 or RC1 next time!

I'm also sure I downloaded the fresh install .zip pack from your download resource!