Page 1 of 1

More questions about 3.1

Posted: Tue Oct 21, 2014 4:19 pm
by cally6008
I have never used prosilver before so apologies if these seem dumb questions.

Do birthdays only show on prosilver when it is someone's birthday ?
On subsilver2, there is still a box at the bottom mentioning no birthdays

Has the "location" and "last active" been removed from the members list on 3.1 ?

Is this Mod (or extension) needed in 3.1 or is this featured on 3.1 as standard now ?
Prime Notify Mod - Inserts the content of a post or private messages into the notification e-mail.
https://www.phpbb.com/customise/db/mod/prime_notify

Edit 22.06pm to add another question

I just looked at the phpBB 3.1.0-RC5 released topic here - viewtopic.php?f=14&t=2265346
Requirements
Please note that phpBB 3.1 has some requirements that differ from phpBB 3.0:
PHP version 5.3.3 or greater is required
PHP’s json extension is required
NA to me - For PostgreSQL users, only versions 8.3 and above are supported
NA to me - Firebird is not supported anymore


I've checked on my website hosting and I'm using PHP version 5.3.28
Does that need updating by the web hosting company before I can use phpbb 3.1 ?

What is "PHP’s json extension" ?

Sorry for all questions but I want to be ready to upgrade forum 3.1 and have a better idea of what I'm doing before it comes to actually doing it

Re: More questions about 3.1

Posted: Tue Oct 21, 2014 11:57 pm
by KaileyT
cally6008 wrote:Do birthdays only show on prosilver when it is someone's birthday ?
On subsilver2, there is still a box at the bottom mentioning no birthdays
I've never used subsilver2, so I can't really say for sure.
cally6008 wrote:Has the "location" and "last active" been removed from the members list on 3.1 ?
I can't see them either. It appears they have been removed.
cally6008 wrote:Is this Mod (or extension) needed in 3.1 or is this featured on 3.1 as standard now ?
Prime Notify Mod - Inserts the content of a post or private messages into the notification e-mail.
The language files don't indicate that the content is included, so most likely the extension will be needed.
cally6008 wrote:
Requirements
Please note that phpBB 3.1 has some requirements that differ from phpBB 3.0:
PHP version 5.3.3 or greater is required
PHP’s json extension is required
NA to me - For PostgreSQL users, only versions 8.3 and above are supported
NA to me - Firebird is not supported anymore


I've checked on my website hosting and I'm using PHP version 5.3.28
Does that need updating by the web hosting company before I can use phpbb 3.1 ?

What is "PHP’s json extension" ?
If you are running 5.3.28, then you're fine. As for the json extension, upload a file to your server called phpinfo.php with the following code:

Code: Select all

<?php
phpinfo();
?>
Then, browse to the file in your favorite web browser. About halfway down, you should see something like this:
json.png
json.png (4.03 KiB) Viewed 787 times

Re: More questions about 3.1

Posted: Wed Oct 22, 2014 12:09 am
by Danielx64
kinerity wrote:
cally6008 wrote:Do birthdays only show on prosilver when it is someone's birthday ?
On subsilver2, there is still a box at the bottom mentioning no birthdays
I've never used subsilver2, so I can't really say for sure.
cally6008 wrote:Has the "location" and "last active" been removed from the members list on 3.1 ?
I can't see them either. It appears they have been removed.
cally6008 wrote:Is this Mod (or extension) needed in 3.1 or is this featured on 3.1 as standard now ?
Prime Notify Mod - Inserts the content of a post or private messages into the notification e-mail.
The language files don't indicate that the content is included, so most likely the extension will be needed.
cally6008 wrote:
Requirements
Please note that phpBB 3.1 has some requirements that differ from phpBB 3.0:
PHP version 5.3.3 or greater is required
PHP’s json extension is required
NA to me - For PostgreSQL users, only versions 8.3 and above are supported
NA to me - Firebird is not supported anymore


I've checked on my website hosting and I'm using PHP version 5.3.28
Does that need updating by the web hosting company before I can use phpbb 3.1 ?

What is "PHP’s json extension" ?
If you are running 5.3.28, then you're fine. As for the json extension, upload a file to your server called phpinfo.php with the following code:

Code: Select all

<?php
phpinfo();
?>
Then, browse to the file in your favorite web browser. About halfway down, you should see something like this:
json.png

Location and last active is showing up for me: memberlist.php?mode=viewprofile&u=1136425 please note that I'm set to hidden so you won't see the date and time when I'm last active

Re: More questions about 3.1

Posted: Wed Oct 22, 2014 12:25 am
by Jessica
For the location and last active in the memberlist, I can still see "last active" but not "location". They still appear on a profile though

Re: More questions about 3.1

Posted: Wed Oct 22, 2014 2:34 am
by KaileyT
OP said "members list" so I'm guessing they meant memberlist.php. :?

Re: More questions about 3.1

Posted: Wed Oct 22, 2014 6:30 am
by nachtelb
You need the rights to see "last active" (normal user = no, admin = yes). But you are able to change it, i think.

Re: More questions about 3.1

Posted: Wed Oct 22, 2014 6:32 am
by Danielx64
kinerity wrote:OP said "members list" so I'm guessing they meant memberlist.php. :?
Yeah I missed that part.

Re: More questions about 3.1

Posted: Wed Oct 22, 2014 7:42 am
by Oyabun1
kinerity wrote:If you are running 5.3.28, then you're fine. As for the json extension, upload a file to your server called phpinfo.php with the following code:
Why bother doing that rather than just viewing it in the ACP?
ACP > GENERAL > Quick Links > PHP information

Re: More questions about 3.1

Posted: Wed Oct 22, 2014 8:31 am
by cally6008
Many thanks everyone
I'm at work at the moment but will re-read again when I get home
Great to hear I'll be good to go on tuesday when 3.1 comes out

Re: More questions about 3.1

Posted: Wed Oct 22, 2014 12:19 pm
by KaileyT
I was under the impression they didn't have phpBB installed, but re-reading the post, it seems they do. :oops: