Error when upgrading from 3.0.12 to 3.1

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
keepingitodd
Registered User
Posts: 3
Joined: Thu Oct 30, 2014 9:02 pm

Error when upgrading from 3.0.12 to 3.1

Post by keepingitodd » Thu Oct 30, 2014 9:09 pm

I've been trying to upgrade to 3.1 and it's giving me fits. I finally got to the point where I can update the database, and I'm getting the following message.

I don't know if it's relevant, but I have PHPBB integrated into Wordpress via WP-United. I've tried deactivating the plugin but it doesn't make any difference.

Has anyone else experienced this? Is there something I need to change? Do I need to back out the update and change a setting before I do it? This is driving me nuts. :(

Code: Select all

Illegal use of $_SERVER. You must use the request class or request_var() to access input data. Found in {MYPATH}/wp-content/plugins/wp-united/base-classes.php on line 666. This error message was generated by deactivated_super_global.

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/request/deactivated_super_global.php
LINE: 67
CALL: trigger_error()

FILE: [ROOT]/phpbb/request/deactivated_super_global.php
LINE: 87
CALL: phpbb\request\deactivated_super_global->error()

FILE: {MYPATH}/wp-content/plugins/wp-united/base-classes.php
LINE: 666
CALL: phpbb\request\deactivated_super_global->offsetGet()

FILE: {MYPATH}/wp-content/plugins/wp-united/base-classes.php
LINE: 735
CALL: WP_United_Plugin_Main_Base->assess_required_wp_actions()

FILE: [ROOT]/includes/hooks/hook_wp-united.php
LINE: 46
CALL: WP_United_Plugin_Main_Base->should_run_wordpress()

FILE: [ROOT]/install/database_update.php
LINE: 127
CALL: include('[ROOT]/includes/hooks/hook_wp-united.php')

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51876
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Error when upgrading from 3.0.12 to 3.1

Post by Brf » Thu Oct 30, 2014 9:18 pm

Your error message is coming from wp-united.
You will need to seek support wherever you got that.
Be aware that you are supposed to remove all of the mods before trying to upgrade phpBB to 3.1.

Locked

Return to “[3.1.x] Support Forum”