no SOFT DELETE moderator permission after 3.0.12 upgrade

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
User avatar
P_I
Registered User
Posts: 930
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by P_I » Sat Nov 01, 2014 3:14 pm

After upgrading a board from 3.0.12, I cannot find where in ACP to grant the SOFT DELETE moderator permission to our moderators that is required per Deleting a topic or post.

A vanilla phpBB 3.1 installation has the SOFT DELETE moderator permission granted as part of the Full Moderator Role.

What steps need to be taken on an upgraded 3.0.12 to 3.1 board to enable this new feature?
Last edited by P_I on Sat Nov 01, 2014 8:41 pm, edited 1 time in total.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69299
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: SOFT DELETE moderator permission after 3.0.12 upgrade

Post by KevC » Sat Nov 01, 2014 3:20 pm

permissions
global moderators
advanced

misc tab
Can soft delete posts
Moderators, who have the approve posts permission, can restore soft deleted posts.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
P_I
Registered User
Posts: 930
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

Re: SOFT DELETE moderator permission after 3.0.12 upgrade

Post by P_I » Sat Nov 01, 2014 3:30 pm

KevC wrote:permissions
global moderators
advanced
That's the issue, on a vanilla 3.1 installation the setting is there. On my upgraded 3.0.12 board the option does appear at all, so I'm looking for a place to enable it. Possible bug in the database upgrade script?
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

Lady_G
Registered User
Posts: 234
Joined: Fri Jun 08, 2012 12:38 pm
Location: US

Re: SOFT DELETE moderator permission after 3.0.12 upgrade

Post by Lady_G » Sat Nov 01, 2014 7:47 pm

I have the same problem. My database is postgreSQL, updated from 3.0.12 to 3.1.0.

Permissions --> Global Moderators --> Global Moderators (Select) --> Edit Permissions --> Advanced Permissions --> Misc Tab.

I see 3 permissions, nothing more:

Can manage bans
Can view post details
Can issue warnings

I reported this as a bug: Upgrading from 3.0.12 to 3.1.0 does not display moderator soft delete permissions

User avatar
P_I
Registered User
Posts: 930
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

Re: no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by P_I » Sat Nov 01, 2014 9:30 pm

I've worked my way through the database a bit and think I have figured out the database changes. Here's what my new phpBB 3.1 database shows.

Code: Select all

mysql> SELECT * 
FROM phpbb_acl_options
WHERE auth_option LIKE  "%_softdelete";
+----------------+--------------+-----------+----------+--------------+
| auth_option_id | auth_option  | is_global | is_local | founder_only |
+----------------+--------------+-----------+----------+--------------+
|             31 | f_softdelete |         0 |        1 |            0 |
|             43 | m_softdelete |         1 |        1 |            0 |
+----------------+--------------+-----------+----------+--------------+
So checking the other acl* tables to see where m_softdelete is assigned,

Code: Select all

mysql> SELECT auth_option_id, role_name, auth_setting
FROM phpbb_acl_roles_data AS d, phpbb_acl_roles AS r
WHERE auth_option_id =43
AND d.role_id = r.role_id;
+----------------+-------------------+--------------+
| auth_option_id | role_name         | auth_setting |
+----------------+-------------------+--------------+
|             43 | ROLE_MOD_FULL     |            1 |
|             43 | ROLE_MOD_STANDARD |            1 |
|             43 | ROLE_MOD_SIMPLE   |            1 |
+----------------+-------------------+--------------+
On my upgraded 3.0.12 database there are matches for the 1st query, which give me auth_option_id = 121 for m_softdelete. When I run the 2nd query using this value I get a NULL set as the result.

Something in the upgrade procedure isn't adding the necessary entries.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69299
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by KevC » Sat Nov 01, 2014 9:32 pm

Have you reported it in the bug tracker?
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
P_I
Registered User
Posts: 930
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

Re: no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by P_I » Sat Nov 01, 2014 9:35 pm

Lady_G has -- PHPBB3-13270 which include a link back to this topic.

I'm not familiar with the bug tracker protocol, should I be adding the above information directly in bug tracker?
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69299
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by KevC » Sat Nov 01, 2014 9:43 pm

You can post that as extra information in the report. If it helps the devs track the problem down it's all useful stuff.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
P_I
Registered User
Posts: 930
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

Re: no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by P_I » Sat Nov 01, 2014 9:59 pm

Done.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

User avatar
Walther
Registered User
Posts: 269
Joined: Fri Jul 09, 2004 5:21 pm
Location: The Netherlands

Re: no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by Walther » Sun Nov 02, 2014 1:45 pm

Have the exact same problem.
- 3.0.12 with the soft-delete mod installed
- deleted all the forum contents exept of /images /files /store and config.php
- during installing, lot of soft-delete items, no problems however

Now (version 3.1.1) going to the mcp, al the pre-deleted topics and deleted postings appear fine
But when deleting a posting as an admin, it's gone....

And, as above, no where to be found in the permission settings. :cry:

Lady_G
Registered User
Posts: 234
Joined: Fri Jun 08, 2012 12:38 pm
Location: US

Re: no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by Lady_G » Sun Nov 02, 2014 10:32 pm

I repeated the update process from 3.0.12 to 3.1.1. No change was seen.

I modified the bug title and affected versions to indicate 3.1.1:
Upgrading from 3.0.12 to 3.1.1 does not display moderator soft delete permissions

Lady_G
Registered User
Posts: 234
Joined: Fri Jun 08, 2012 12:38 pm
Location: US

Re: no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by Lady_G » Sat Nov 08, 2014 12:53 am

The bug tracker status shows this fixed, waiting for verification.
Walther wrote:Now (version 3.1.1) going to the mcp, al the pre-deleted topics and deleted postings appear fine
But when deleting a posting as an admin, it's gone....

And, as above, no where to be found in the permission settings. :cry:
Should an admin have soft delete permissions? I cannot soft delete a post, hard delete only.

Permissions --> Global Permissions --> Administrators --> Administrator group --> Advanced --> Misc. has no entry for soft delete.

I added a bug tracker comment to check administrator permissions.

Lady_G
Registered User
Posts: 234
Joined: Fri Jun 08, 2012 12:38 pm
Location: US

Re: no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by Lady_G » Sat Nov 08, 2014 1:14 am

I received an answer from the bug tracker. [PHPBB3-13270]

Permissions for admins to soft delete posts can be achieved in this way:
prototech wrote:The permission in question is a moderator permission and not an administrator permission so it will not be listed under the global administrator permissions.

If you wish to grant this permission (once 3.1.2 is released and this fix is included), then the course of action would be Permissions -> Global Permissions -> Group Permissions - select Administrators group - submit.

In the "Select type" dropdown, choose Global Moderator permissions, which will list moderator permissions. Or just add administrators to the Global Moderators group.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66569
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by Lumpy Burgertushie » Sat Nov 08, 2014 2:12 am

If you expect admins to be able to moderate your board ( edit/delete/move posts, etc. ) then you should put them in a moderator group. admin permissions are only to access the admin panel not to moderate.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

Lady_G
Registered User
Posts: 234
Joined: Fri Jun 08, 2012 12:38 pm
Location: US

Re: no SOFT DELETE moderator permission after 3.0.12 upgrade

Post by Lady_G » Sat Nov 08, 2014 2:19 am

Good point. My forum has a small number of moderators; the admins help moderate when needed.

Locked

Return to “[3.1.x] Support Forum”