Page 1 of 2

Blank feed

Posted: Sat Nov 29, 2014 2:07 pm
by Marcus Wendel
Since moving to 3.1 one of my boards only generates a blank feed with zero content (not even an error messages). When I check the feed settings "Enable new topics feed" is enabled and some of the forums are selected in the "News feed" list.
Any suggestions on how to fix this issue?

I'm currently running 3.1.2 with only official phpbb extensions installed on a MySQL(i) 5.5.31.

/Marcus

Re: Blank feed

Posted: Sat Nov 29, 2014 6:37 pm
by kinerity
Please fill out the Support Request Template and post it back here.

Re: Blank feed

Posted: Sat Nov 29, 2014 7:00 pm
by Marcus Wendel
kinerity wrote:Please fill out the Support Request Template and post it back here.
I've already posted the relevant parts of the support template in the post above.

/Marcus

Re: Blank feed

Posted: Sat Nov 29, 2014 7:05 pm
by Lumpy Burgertushie
the point of the SRT is so we can check several things for you. If you do not wish to give us the info we need then we may not be able to help you as well.


robert

Re: Blank feed

Posted: Sat Nov 29, 2014 7:07 pm
by kinerity
I'm sorry, did I miss it? I don't see a board url, who you host your board with, what the most recent action you did, is registration required to reproduce, etc. The reason I pointed you to the SRT is because I can't reproduce this on my site and I can't help if you only provided some of the information.

Re: Blank feed

Posted: Sat Nov 29, 2014 7:08 pm
by Marcus Wendel
Lumpy Burgertushie wrote:the point of the SRT is so we can check several things for you. If you do not wish to give us the info we need then we may not be able to help you as well.
Fair point.

Support Request Template
What version of phpBB are you using? phpBB 3.1.2
What is your board's URL? http://forum.axishistory.com
Who do you host your board with? Own server
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
What version of phpBB3 did you update from? phpBB 3.1.1
What styles do you currently have installed? default
What language(s) is your board currently using? default
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
When did your problem begin? See above
Please describe your problem. See above
Generated by SRT Generator

Some of the choices there should be updated to make more sense, for example mods are only pre 3.1.
Also the question about the most recent action is not really relevant in this case as two updates have been done since the problem was first noticed.

/Marcus

Re: Blank feed

Posted: Sat Nov 29, 2014 7:10 pm
by kinerity
If I browse to http://forum.axishistory.com/feed.php, I get "The requested feed is not available". Can you post a screenshot of your feed settings?

Re: Blank feed

Posted: Sat Nov 29, 2014 7:14 pm
by Marcus Wendel
kinerity wrote:If I browse to http://forum.axishistory.com/feed.php, I get "The requested feed is not available". Can you post a screenshot of your feed settings?
Sure, forgot that in my above post.

Sorry for not using the support template, I did not mean to be rude.

/Marcus

Re: Blank feed

Posted: Sat Nov 29, 2014 7:20 pm
by kinerity
OK, if I mirror your settings, I get the same error. It's weird, it works with post settings. Have you filed a bug report yet?

Re: Blank feed

Posted: Sat Nov 29, 2014 7:21 pm
by Marcus Wendel
kinerity wrote:OK, if I mirror your settings, I get the same error. It's weird, it works with post settings. Have you filed a bug report yet?
No bug report yet, I did not think it was a bug but if you get the same thing then I will create one.

/Marcus

Re: Blank feed

Posted: Sat Nov 29, 2014 7:26 pm
by kinerity
Yeah, please do that. Maybe the developers can take a look and see what's going on.

By the way, you weren't rude. ;) It's going to take A LOT more than that to come across as rude to me.

Re: Blank feed

Posted: Sat Nov 29, 2014 7:26 pm
by Marcus Wendel

Re: Blank feed

Posted: Sat Dec 06, 2014 3:05 pm
by nickvergessen
Well feed.php?mode=topics_new works and you disabled all other feeds.
So works as intended for me?

Re: Blank feed

Posted: Sat Dec 06, 2014 4:54 pm
by Marcus Wendel
nickvergessen wrote:Well feed.php?mode=topics_new works and you disabled all other feeds.
So works as intended for me?
Where does it work?

/Marcus

Re: Blank feed

Posted: Sat Dec 06, 2014 5:01 pm
by nickvergessen
In my test board with the settings from the screenshot