A required module does not exist: ACP_CAT_DOT_MODS

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
User avatar
advocatus
Registered User
Posts: 290
Joined: Tue Aug 12, 2014 11:58 am
Location: Ontario, Canada.
Contact:

A required module does not exist: ACP_CAT_DOT_MODS

Post by advocatus » Fri Dec 12, 2014 2:42 pm

Alright, so I've set up a beta board running 3.1.2 to make sure everything works before I convert my 3.0.12 board over. Before I converted the beta board, I uninstalled all modifications I had, including AutoMOD. I also deleted the modules related to the modifications. I've been trying to bring the board as close to vanilla without doing a fresh install as possible.

I've picked about a dozen extensions (all are in the customization database and have been validated) to add to the beta forum. The ones that are added without a problem are: Auto Database Backup, Browse Happy, Database Optimize & Repair Tool, Error pages, Google Analytics, Password Strength and Scroll to Top.

The ones that I can't add are: About us, Board Announcements, Board Rules, Pages and Precise Similar Topics. They each give me an error message when I click the 'Enable' button on the confirmation page. That error is:
Something went wrong during the request and an exception was thrown. The changes made before the error occurred were reversed to the best of our abilities, but you should check the board for errors.
A required module does not exist: ACP_CAT_DOT_MODS
I've recently learned my way around phpBB a little bit, but I'm at a complete loss as to what to do here.
Hi, I'm advocatus and I own www.forumgames.in.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66897
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: A required module does not exist: ACP_CAT_DOT_MODS

Post by Lumpy Burgertushie » Fri Dec 12, 2014 2:58 pm

that is a left over from automod and/or one of your old 3.0 MODs.

not sure why it says it is required.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
david63
Registered User
Posts: 16795
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: A required module does not exist: ACP_CAT_DOT_MODS

Post by david63 » Fri Dec 12, 2014 3:13 pm

It looks as if at some point during your conversion that you have, either knowingly or not, deleted the module ACP_CAT_DOT_MODS which should be there (and is created in a vanilla install of 3.1) for adding extensions to the extensions tab (the "old" Mods tab). The name is a bit misleading as it is a carry over from 3.0.
Lumpy Burgertushie wrote:that is a left over from automod and/or one of your old 3.0 MODs.

not sure why it says it is required.
See answer above - it is not left over and it is needed
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
advocatus
Registered User
Posts: 290
Joined: Tue Aug 12, 2014 11:58 am
Location: Ontario, Canada.
Contact:

Re: A required module does not exist: ACP_CAT_DOT_MODS

Post by advocatus » Fri Dec 12, 2014 3:15 pm

Can I re-add it without having to do a reinstall?

[Edit: I just totally realized I should have done a search before I made this thread. During my search, a thread linked to another thread with this post. The post is +3.5 years old, so I'm just wondering if it's still applicable?]
Hi, I'm advocatus and I own www.forumgames.in.

User avatar
david63
Registered User
Posts: 16795
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: A required module does not exist: ACP_CAT_DOT_MODS

Post by david63 » Fri Dec 12, 2014 3:31 pm

To be honest I do not know if you can recreate it or not. Looking at the link the module_id, left_id, right_id have all changed in the vanilla table that I have just looked at.

You could try this after backing up at least the modules table if not the database. (No guarantees that it will work)

Code: Select all

INSERT INTO `phpbb_modules` (`module_id`, `module_enabled`, `module_display`, `module_basename`, `module_class`, `parent_id`, `left_id`, `right_id`, `module_langname`, `module_mode`, `module_auth`) VALUES (32, '1', '1', '', 'acp', '0', '283', '284', 'ACP_CAT_DOT_MODS', '', '')
Playing around with modules manually is full of potential dangers
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: A required module does not exist: ACP_CAT_DOT_MODS

Post by Oyabun1 » Fri Dec 12, 2014 9:03 pm

It would be better to add the module via module management in the ACP, then the left and right ids are sure to be correct:

ACP > SYSTEM > Module Management > Administration Control Panel >
  • Create new module: Extensions
    • Module language name: ACP_CAT_DOT_MODS
      Module type: Category
      Parent: No parent:
      Module enabled: Yes
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
advocatus
Registered User
Posts: 290
Joined: Tue Aug 12, 2014 11:58 am
Location: Ontario, Canada.
Contact:

Re: A required module does not exist: ACP_CAT_DOT_MODS

Post by advocatus » Fri Dec 12, 2014 9:08 pm

Perfect! Thank-you. I didn't realize it'd be so easy. :P

I feel a bit silly now.
Hi, I'm advocatus and I own www.forumgames.in.

womandrogyne
Registered User
Posts: 23
Joined: Sun May 19, 2013 7:54 am

Re: A required module does not exist: ACP_CAT_DOT_MODS

Post by womandrogyne » Sun Feb 21, 2016 11:12 am

I tried adding the module as described above, but now trying to enable the extensions that wouldn't before results in a page of SQL errors instead of that "can't find ACP_CAT_DOT_MODS" message. Is there any way around doing a reinstallation of the board?
phpBB 3.1.7pl1

Locked

Return to “[3.1.x] Support Forum”