3.0.12 to 3.1.2

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
Charlie2
Registered User
Posts: 154
Joined: Tue May 12, 2009 6:55 pm
Location: Germany
Name: Ilona

3.0.12 to 3.1.2

Post by Charlie2 »

Hello again

Before I upgrade the next two forums I have a few questions.

In the automatic update download there is no 3.0.12 version to choose in the drop down box. Is it at all possible to do an automatic update from 3.0.12 to 3.1.2?


According to this I can't even do it this way.
Upgrading from 3.0 to 3.1
phpBB 3.1 is not compatible with 3.0 and most of the previous files will need to be removed prior to upgrading to 3.1.

Is installing the full package the only option to update?

Thanks in advance
Ilona
Ilona

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4607
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: 3.0.12 to 3.1.2

Post by HiFiKabin »

This is the correct way to move from 3.0.x to 3.1.x

Prepare you 3.0.x board
  1. Backup all board files and the database of your 3.0 board.
  2. Download and install the Support Toolkit.
  3. Run the included database cleaner function to remove any and all MOD entries from the 3.0 database.
  4. In your admin panel of the 3.0 board, set the default style to prosilver and set override user to yes.
  5. Now follow the install instructions below.
Installing phpbb 3.1.x

  1. Download the full package.
  2. Unzip to your desktop and open the phpBB3 directory.
  3. Remove (delete) the config.php file, and the /images and /files directories from the package.
  4. Via FTP or SSH delete everything from your board installation on the server EXCEPT for the config.php file, and the /files, /images, and /store directories.
  5. Via FTP or SSH upload the remaining files and directories (from step 3 above) to the root of your board installation on the server overwriting the existing files.
  6. In your browser go to http://www.example.com/yourforum/instal ... update.php
  7. Let that run to completion.
  8. Via FTP or SSH delete the folder named /install/ from the root of your board installation.

Charlie2
Registered User
Posts: 154
Joined: Tue May 12, 2009 6:55 pm
Location: Germany
Name: Ilona

Re: 3.0.12 to 3.1.2

Post by Charlie2 »

Thank you for the information so far.

I've never used the Support Toolkit before. Do I run it from my computer or online?

Figured out how to do it.
Ilona

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4607
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: 3.0.12 to 3.1.2

Post by HiFiKabin »

No problem. As you have discovered, the STK is accessed from http://www.example.com/yourforum/stk

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69716
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: 3.0.12 to 3.1.2

Post by KevC »

Charlie2 wrote:In the automatic update download there is no 3.0.12 version to choose in the drop down box. Is it at all possible to do an automatic update from 3.0.12 to 3.1.2?
There's no point in one.
None of the MODs or styles are compatible so there's no reason to copy over any code, so you go with all new files.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Charlie2
Registered User
Posts: 154
Joined: Tue May 12, 2009 6:55 pm
Location: Germany
Name: Ilona

Re: 3.0.12 to 3.1.2

Post by Charlie2 »

I have done all the above and am getting this error message


Updating database to latest stable release

Database type :: mysqli
Previous version :: 3.0.12

Fatal error: Uncaught exception 'RuntimeException' with message 'Unable to write to migrator log file' in /home/thegloe0/public_html/phpbb/db/log_wrapper_migrator_output_handler.php:67 Stack trace: #0 /home/thegloe0/public_html/phpbb/db/log_wrapper_migrator_output_handler.php(51): phpbb\db\log_wrapper_migrator_output_handler->file_open('./../store/migr...') #1 /home/thegloe0/public_html/install/database_update.php(177): phpbb\db\log_wrapper_migrator_output_handler->__construct(Object(phpbb\user), Object(phpbb\db\html_migrator_output_handler), './../store/migr...') #2 {main} thrown in /home/thegloe0/public_html/phpbb/db/log_wrapper_migrator_output_handler.php on line 67
Ilona

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4607
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: 3.0.12 to 3.1.2

Post by HiFiKabin »

Reading the topic the store/ folder had been deleted/unwritable.
https://tracker.phpbb.com/browse/PHPBB3-13237

Charlie2
Registered User
Posts: 154
Joined: Tue May 12, 2009 6:55 pm
Location: Germany
Name: Ilona

Re: 3.0.12 to 3.1.2

Post by Charlie2 »

Thank you very much. That solved the problem. One of these days this will be the death of me. :D
Ilona

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4607
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: 3.0.12 to 3.1.2

Post by HiFiKabin »

No problem, glad you got there in the end

User avatar
robertmf
Registered User
Posts: 94
Joined: Wed Sep 25, 2002 7:26 pm
Location: 55 min. by commuter RR outside Filthadelphia
Contact:

Re: 3.0.12 to 3.1.2

Post by robertmf »

I finished the update 3.0.12 -> 3.1.2 according to the instructions on localhost box. Kudoes to the database_update. Smooth.

But, until the phpbb gallery ext comes along, I won't put 3.1.12 onto my website. This is a critical mod (for me) :)
DLI Alumni & Friends Community at DLIFLC.ORG

Locked

Return to “[3.1.x] Support Forum”