Random apache segmentation faults (11) if PHPBB3 is running

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
fmal
Registered User
Posts: 7
Joined: Wed Feb 15, 2006 8:19 pm

Random apache segmentation faults (11) if PHPBB3 is running

Post by fmal » Mon Jan 26, 2015 2:00 pm

Support Request Template
What version of phpBB are you using? phpBB 3.1.2
What is your board's URL? http://forum.amiminerals.it
Who do you host your board with? myself
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
What version of phpBB3 did you update from? phpBB 3.0.2
What styles do you currently have installed? Aero
What language(s) is your board currently using? It-en-fr-de
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
When did your problem begin? I converted from v2 to 3.0.2 and then upgraded to 3.1.2
Sice I used V3, my apache web server began to show randomly segmentation faults (11)
Please describe your problem. Most dumps are related to zend_stack.c
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00007f7c9c2b39dd in zend_stack_push (stack=stack@entry=0x7f7c9c7e6a88 <compiler_globals+616>,
element=element@entry=0x7f7c9c7e6a68 <compiler_globals+584>, size=size@entry=32) at /usr/src/debug/php-5.4.20/Zend/zend_stack.c:42
42 stack->elements[stack->top] = (void *) emalloc(size);

The problem began on OpenSuse x86_64 13.1 with php5-5.4.20 apache2-2.4.6.
After trying several patches and tricks, I moved only the phpbb3 forum to a new OpenSuse 13.2 server dedicated to him, with php5-5.6.1 and apache2-2.4.10.

The segfault started immediatly only on the new server, and the old one started to work for others sistes without any error because no phpbb code was no more running there.
Generated by SRT Generator

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50582
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Random apache segmentation faults (11) if PHPBB3 is running

Post by stevemaury » Mon Jan 26, 2015 4:18 pm

Sorry, but that is beyond the scope of support available here. https://www.phpbb.com/rules/#support-scope
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

Locked

Return to “[3.1.x] Support Forum”