Problem upgrading from 3.0.12 to 3.1.3

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Post Reply
User avatar
TawmN
Registered User
Posts: 19
Joined: Wed Nov 10, 2004 11:19 pm

Problem upgrading from 3.0.12 to 3.1.3

Post by TawmN » Mon Feb 09, 2015 9:33 pm

Support Request Template
What version of phpBB are you using? phpBB 3.0.12
What is your board's URL? http://www.blackdogdualsport.com/forum/
Who do you host your board with? Powweb
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
What version of phpBB3 did you update from? phpBB 3.0.12
What styles do you currently have installed? prosilver
What language(s) is your board currently using? british english
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
When did your problem begin? Upgrading from 3.0.12 to 3.1.3
Please describe your problem. Am simply trying to perform the upgrade from 3.0.12 to 3.1.3. I followed all the steps described in the FAQ, which are:
====
Upgrading from 3.0 to 3.1

Upgrading to phpBB 3.1 will render previously installed MODifications and styles unusable.

phpBB 3.1 is not compatible with 3.0 and most of the previous files will need to be removed prior to upgrading to 3.1.

To upgrade, perform the following steps:

Ensure that your server meets the requirements for running phpBB 3.1: Section 1.1, ???Requirements???

Make a backup of the original files

Make a backup of the database

Download the phpBB 3.1 Full Package archive

Extract the contents of the archive to your computer and open the phpBB3 directory

Delete the following files from the package:

The config.php file

The images/ directory

The files/ directory

The store/ directory

On your website, delete all files from your board EXCEPT for:

The config.php file

The images/ directory

The files/ directory

The store/ directory

Upload the contents of the phpBB3 directory from your computer to your forum's directory. You may be prompted to overwrite the remaining files. If prompted to merge or overwrite directories, choose to merge them.

Using your web browser, visit install/database_update.php in your board's root. (e.g. http://www.example.com/yourforum/instal ... update.php)
=====

Once I do this, nothing happens. I double checked the CHMOD for each directory and still get nothing - just a blank screen. I did not overwrite my config.php.

Thanks in advance for your help on this.
-Tom
Generated by SRT Generator
Last edited by TawmN on Mon Feb 09, 2015 10:21 pm, edited 1 time in total.

User avatar
Lumpy Burgertushie
Registered User
Posts: 63196
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Problem upgrading from 3.0.12 to 3.1.13

Post by Lumpy Burgertushie » Mon Feb 09, 2015 10:07 pm

I am getting a blank page for your index and probably all the other php files.

for now, remove the install folder so your board will work again.

then, go check the server logs to see what is causing the php error that is causing the blank page.

and/or check with your host.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.
Premium phpBB 3.2 Styles by PlanetStyles.net

New phpbb 3.0 support site

User avatar
TawmN
Registered User
Posts: 19
Joined: Wed Nov 10, 2004 11:19 pm

Re: Problem upgrading from 3.0.12 to 3.1.13

Post by TawmN » Mon Feb 09, 2015 10:12 pm

I went in and renamed the /install folder to /temp_install. The message board doesn't even come up using index.php. It is still blank.

I will check the server logs.
-Tom

User avatar
Lumpy Burgertushie
Registered User
Posts: 63196
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Problem upgrading from 3.0.12 to 3.1.13

Post by Lumpy Burgertushie » Mon Feb 09, 2015 10:19 pm

exactly which update files did you download from here and exactly what files/folders did you upload to the server?
your post says upgrading from 3.0.12 to 3.1.13 there is no such thing as 3.1.13
there is a 3.0.13 and there is a 3.1.3
so , we don't really know what files you downloaded etc.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.
Premium phpBB 3.2 Styles by PlanetStyles.net

New phpbb 3.0 support site

User avatar
TawmN
Registered User
Posts: 19
Joined: Wed Nov 10, 2004 11:19 pm

Re: Problem upgrading from 3.0.12 to 3.1.13

Post by TawmN » Mon Feb 09, 2015 10:20 pm

My sincere apologies, that would be upgrading to the latest of: 3.1.3

I will update the original post entry.

I uploaded all files except the config.php. I also chose to overwrite all files as it uploaded.
-Tom

User avatar
Oyabun1
Former Team Member
Posts: 23164
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Problem upgrading from 3.0.12 to 3.1.3

Post by Oyabun1 » Tue Feb 10, 2015 12:05 am

Your server is reporting running PHP Version 4.4.9, it needs to be at least 5.3.3 to run phpBB 3.1. Contact your host about updating the PHP version on the server.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
TawmN
Registered User
Posts: 19
Joined: Wed Nov 10, 2004 11:19 pm

Re: Problem upgrading from 3.0.12 to 3.1.3

Post by TawmN » Tue Feb 10, 2015 1:15 am

Thank you. I will prod them to get updated.
-Tom

tawmass
Registered User
Posts: 15
Joined: Wed Jul 20, 2005 7:56 pm

Re: Problem upgrading from 3.0.12 to 3.1.3

Post by tawmass » Wed Feb 11, 2015 7:33 pm

Just wanted to say thank you very much. Updating the webhost's PHP did it.
-Tom

flydoc
Registered User
Posts: 66
Joined: Tue Dec 13, 2011 3:49 am

Re: Problem upgrading from 3.0.12 to 3.1.3

Post by flydoc » Fri Mar 13, 2015 7:12 am

Whether make upgrading 3.0.12 to 3.1.3 in my forum for this way? My version is PHP Version 5.3.28

User avatar
Mick
Support Team Member
Support Team Member
Posts: 17832
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Problem upgrading from 3.0.12 to 3.1.3

Post by Mick » Fri Mar 13, 2015 7:39 am

The upgrade instructions are here and the PHP version is ok.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

flydoc
Registered User
Posts: 66
Joined: Tue Dec 13, 2011 3:49 am

Re: Problem upgrading from 3.0.12 to 3.1.3

Post by flydoc » Fri Mar 13, 2015 8:03 am

Thanks Mick, I'll try, if something goes wrong I'll get it here.

brian47374
Registered User
Posts: 11
Joined: Fri Aug 14, 2015 5:09 pm

Re: Problem upgrading from 3.0.12 to 3.1.3

Post by brian47374 » Mon Sep 18, 2017 4:15 pm

Looks somewhat successful… however, it gives me this…
SQL ERROR [ mysqli ]

Unknown column 'ext_active' in 'where clause' [1054]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 17832
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Problem upgrading from 3.0.12 to 3.1.3

Post by Mick » Tue Sep 19, 2017 10:18 am

@brian47374: This topic has been marked solved and it's two years old. Please start your own topic by please filling out the Support Request Template and posting it back in the new topic to enable us to assist you better.

Edit: I see you have another topic open on the subject.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

Post Reply

Return to “[3.1.x] Support Forum”

Who is online

Users browsing this forum: No registered users and 20 guests

cron