Softdelete does not work

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
Lucan
Registered User
Posts: 46
Joined: Fri Jun 13, 2008 10:24 pm

Softdelete does not work

Post by Lucan »

Hello,

I've got a problem with the soft delete feature.
I want that "normal" moderators only can soft delete posts and not permanent.

For that i granted the following moderator rights:
"Can permanently delete posts" NO
"Can soft delete posts" YES

So i expect, that the user can now delete post but doesn't geht the checkbox to permanent delete posts.

But when I granted this permissions, and the moderator tries to delete a posting, he gets the message:
"You cannot delete posts in this forum."

When i give him the following rights:
"Can permanently delete posts" YES
"Can soft delete posts" YES

He can delete posts - but also permanent.

Is this a bug at the actual 3.1.3?
Last edited by Lucan on Fri Mar 20, 2015 12:14 pm, edited 1 time in total.
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Softdelete does not work

Post by Oyabun1 »

Seems to be.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
Lucan
Registered User
Posts: 46
Joined: Fri Jun 13, 2008 10:24 pm

Re: Softdelete does not work

Post by Lucan »

Is there already a ticket for that or even a fix?
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Softdelete does not work

Post by Oyabun1 »

I have no idea. Have a look in the phpBB Bug Tracker,
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
Lucan
Registered User
Posts: 46
Joined: Fri Jun 13, 2008 10:24 pm

Re: Softdelete does not work

Post by Lucan »

Locked

Return to “[3.1.x] Support Forum”