Page 1 of 1

Changing the db prefix breaks installation

Posted: Mon Mar 23, 2015 11:34 am
by javiexin
Hello,

I have recently installed a new development forum using 3.1.3, and I found an annoying bug that made me waste a very long time, that would not like others to suffer from.

The issue is with the DB table prefix. Specifically, if during the installation process, you change the default prefix phpbb_ to something longer (in my case it was just phpbb3_ for historical reasons in my forum), then the installation process fails giving a very unclear error as to the cause of this. The exact error given I don't remember, and I don't have it handy now, but it was something like "Index name too long" on the un_mtch index for the search_wordmatch table.

So, my request that there should be some provision in the installation process to block this issue from happening, like giving a warning/error when the prefix is longer that expected, or at the very least showing this as a limitation in the associated field comments text (_EXPLAIN language description).

Another (better) alternative would be to allow for longer identifiers, or for the core to not exhaust the identifier length.

Thanks in advance,
-javiexin

PD: I do not have access to the bugtracker, so if someone wants to open an issue there, please go ahead.

Re: Changing the db prefix breaks installation

Posted: Mon Mar 23, 2015 11:40 am
by Mick
javiexin wrote:I do not have access to the bugtracker
Why?

Re: Changing the db prefix breaks installation

Posted: Mon Mar 23, 2015 3:17 pm
by Lumpy Burgertushie
or, when you get the error simply change the table prefix to a shorter one.

I agree the error message could be better.

and, I think this is basically a problem with your database settings not allowing more than x number of characters, not a problem with phpbb not allowing it.


robert