Page 1 of 1

Trying to upgrade to 3.1 - Completely Broke!

Posted: Wed Apr 08, 2015 6:25 pm
by SteStory
Hi all,

Just trying to update my forum to the latest version, as per instructions here: https://www.phpbb.com/support/docs/en/3 ... /upgrade3/

I downloaded the full package, uploaded it (minus the config files etc), and now when I try to go to the install folder (or even just the root) nothing atall is loading, it's just showing a completely blank page!

The forum is at http://www.barrowafc.net

I've looked in the ftp and all the files are there etc so I have no idea what's going on!

Please help,
Thanks
Ste

Re: Trying to upgrade to 3.1 - Completely Broke!

Posted: Wed Apr 08, 2015 6:51 pm
by KevC
Most likely is that one of the files hasn't uploaded correctly.

You can check the server error logs for a message to see what it might be.
Your users and posts are fine, they're in the database.

Re: Trying to upgrade to 3.1 - Completely Broke!

Posted: Wed Apr 08, 2015 7:05 pm
by SteStory
Thanks for the reply.

The error I seem to be getting is:

[08-Apr-2015 12:44:55] PHP Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home4/barrowaf/public_html/viewtopic.php on line 791
[08-Apr-2015 12:44:55] PHP Parse error: syntax error, unexpected T_STRING in /home4/barrowaf/public_html/viewtopic.php on line 791

But the /install link to upgrade the database is also showing absolutely nothing too?

Re: Trying to upgrade to 3.1 - Completely Broke!

Posted: Wed Apr 08, 2015 7:19 pm
by SteStory
I've also tried uploading the full install files to a fresh folder at www.barrowafc.net/forum and that's also doing the same thing and giving this in the error log:

[08-Apr-2015 12:51:39] PHP Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home4/barrowaf/public_html/forum/index.php on line 59
[08-Apr-2015 12:51:39] PHP Parse error: syntax error, unexpected T_STRING in /home4/barrowaf/public_html/forum/index.php on line 59

Re: Trying to upgrade to 3.1 - Completely Broke!

Posted: Wed Apr 08, 2015 7:28 pm
by KevC
You don't have the minimum server requirements to run it. The server you are trying to install on needs to be running at least PHP 5.3.3. You will need to contact your host about updating the PHP version (a later version may already be available on the server).

Re: Trying to upgrade to 3.1 - Completely Broke!

Posted: Wed Apr 08, 2015 7:45 pm
by SteStory
Hmm... I got the host to change my PHP version before I attempted it.

"The php version is set to PHP 5.2 (FastCGI). I have now set the php version to PHP 5.4 (Single php.ini).

But yes when I look now it seems to have reverted itself back to PHP 5.2. Going to reupload all the files and try again now they've set it back to 5.4.

Re: Trying to upgrade to 3.1 - Completely Broke!

Posted: Wed Apr 08, 2015 8:01 pm
by SteStory
Been back in touch with the hosts who re-set the PHP to the required level and voila, it worked!

All that faff for a two second fix! At least it's all done now, thanks for pointing that out to me, still no idea why the PHP version reverted because i'm 100% certain I saw it change.

Cheers