No extension tab and no module settings missing in ACP

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Ideas Centre
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
Ron5567
Registered User
Posts: 1
Joined: Wed Apr 15, 2015 1:57 pm

No extension tab and no module settings missing in ACP

Post by Ron5567 » Wed Apr 15, 2015 2:38 pm

Hi, i have updated the forum a while ago from phpbbSeo to 3x and since then i am missing the extensions tab on ACP and also i don't see the modules in system tab, when i look at admin permissions i see this:
ACL_A_MODS yes
Can manage modules yes

you can see it in the screenshots i attached.

how can i resolve this?
Attachments
Screen Shot 2015-04-15 at 10.30.23 AM.png
Screen Shot 2015-04-15 at 10.30.07 AM.png
Screen Shot 2015-04-15 at 10.29.47 AM.png

User avatar
Puchahawa
Registered User
Posts: 768
Joined: Sat Jan 01, 2011 10:33 pm
Name: Randy

Re: No extension tab and no module settings missing in ACP

Post by Puchahawa » Wed Apr 15, 2015 7:27 pm

I don't know about the modules but the extension tab will not show unless you have activated an extension that uses the extension tab for it's settings.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66897
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: No extension tab and no module settings missing in ACP

Post by Lumpy Burgertushie » Wed Apr 15, 2015 7:42 pm

your screen shot shows exactly what it should when you click on the system tab.
if you want to see and manage the modules you have to click on one of the links in the left menu for modules.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

sceptre
Registered User
Posts: 114
Joined: Mon Feb 22, 2010 5:01 pm
Location: Alba

Re: No extension tab and no module settings missing in ACP

Post by sceptre » Wed Apr 15, 2015 8:27 pm

According to the third screenshot, the Extension management module is deactivated or missing
you can check this in system/module management .acp / click on Customise , should show styles , extension and language modules there . check the extension module is active .

User avatar
Lumpy Burgertushie
Registered User
Posts: 66897
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: No extension tab and no module settings missing in ACP

Post by Lumpy Burgertushie » Wed Apr 15, 2015 9:05 pm

no, there is no extenstion tab until and unless you have installed an extension that requires one.
If you are seeing a problem in the admin panel, you are not showing us any screenshot that shows a problem.



robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

sceptre
Registered User
Posts: 114
Joined: Mon Feb 22, 2010 5:01 pm
Location: Alba

Re: No extension tab and no module settings missing in ACP

Post by sceptre » Wed Apr 15, 2015 9:24 pm

Not the Tab Robert , the Extension management module should be between Styles and Language ones.
modules.PNG
modules.PNG (20.68 KiB) Viewed 1556 times
Have a look at the OP's 3rd screenshot then look below
mod2.PNG
mod2.PNG (9.28 KiB) Viewed 1556 times

User avatar
Lumpy Burgertushie
Registered User
Posts: 66897
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: No extension tab and no module settings missing in ACP

Post by Lumpy Burgertushie » Wed Apr 15, 2015 11:28 pm

ah yes, now I understand. sorry for the confusion.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: No extension tab and no module settings missing in ACP

Post by Oyabun1 » Wed Apr 15, 2015 11:44 pm

Ron5567 wrote:ACL_A_MODS yes
That is a non standard permission. You may have others as well as non standard modules.

If you have not added any extensions you can remove non standard modules and permissions by:
  1. Make sure you make a backup of your database before proceeding.
  2. Uploading this file, modission_reset.php, to the root of your board installation on the server.
  3. Log into the board as a founder and/or admin.
  4. Navigate your browser to the file, for example http://www.example.com/example_forum/modission_reset.php
  5. Choose modules and permissions and run the file
  6. It will tell you how many modules and permissions it deletes, or may give you some other message if all is not well. Make a note of that.
  7. It should automatically delete itself from the server, if it can't it will tell you.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

promod
Registered User
Posts: 53
Joined: Wed Sep 03, 2014 3:56 pm

Re: No extension tab and no module settings missing in ACP

Post by promod » Fri May 08, 2015 5:34 am

I have used the modission_reset.php to clear my old MOD's which was not compatible with 3.1.4. There after the extensions tab was missing.

in 3.1.4 i was using extensions like board accouncement etc....

Only way i found to get back the extensions tab back was.

1.Disable the extension
2.Delete the extension’s data
3.Delete the extension’s files from the filesystem (from ext folder)

then reupload the extension to the ext folder and then activate it. After this exercise i was able to get back the Extensions tab back in the ACP

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: No extension tab and no module settings missing in ACP

Post by Oyabun1 » Fri May 08, 2015 6:12 am

promod wrote:3.Delete the extension’s files from the filesystem (from ext folder)

then reupload the extension to the ext folder and then activate it.
There is absolutely no need to delete and reupload the files unless the extension version has been updated.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

promod
Registered User
Posts: 53
Joined: Wed Sep 03, 2014 3:56 pm

Re: No extension tab and no module settings missing in ACP

Post by promod » Fri May 08, 2015 7:08 am

^^
I was unsuccessful in the effort to get back the Extensions Tab when i tried just disable the extension/clear extension data.

For me at least the problem was solved after doing the 3rd step too i.e

3.Delete the extension’s files from the filesystem (from ext folder) then re upload.

Locked

Return to “[3.1.x] Support Forum”