Page 1 of 1

DateTime Issue After Update

Posted: Wed Apr 22, 2015 11:25 am
by gally
Hi Guys/Girls

I am in need of some serious help, I recently tried to change the theme on my board and it turns out I changed it to one where files were missing and couldn't use my board or UCP, after searching round here I managed to get that issue sorted by downloading new files and doing the database_update.php routine. Which worked great my board is back up and running with all my images, posts and users in check.

However to cause me further stress (like my morning hasn't been bad enough already) I now cannot login to my control panel as I get this error code.

Code: Select all

Fatal error: Uncaught exception 'Exception' with message 'DateTime::__construct(): Failed to parse time string (@UNIX_TIMESTAMP()) at position 0 (@): Unexpected character' in /websites/123reg/LinuxPackage23/lf/sf/lo/lfsfloorings.co.uk/public_html/DOA360/forums/phpbb/datetime.php:50 Stack trace: #0 /websites/123reg/LinuxPackage23/lf/sf/lo/lfsfloorings.co.uk/public_html/DOA360/forums/phpbb/datetime.php(50): DateTime->__construct('@UNIX_TIMESTAMP...', Object(DateTimeZone)) #1 /websites/123reg/LinuxPackage23/lf/sf/lo/lfsfloorings.co.uk/public_html/DOA360/forums/phpbb/user.php(720): phpbb\datetime->__construct(Object(phpbb\user), '@UNIX_TIMESTAMP...', Object(DateTimeZone)) #2 /websites/123reg/LinuxPackage23/lf/sf/lo/lfsfloorings.co.uk/public_html/DOA360/forums/includes/acp/acp_main.php(462): phpbb\user->format_date('UNIX_TIMESTAMP(...') #3 /websites/123reg/LinuxPackage23/lf/sf/lo/lfsfloorings.co.uk/public_html/DOA360/forums/includes/functions_module.php(674): acp_main->main('main', 'main') #4 /websites/123reg/LinuxPackage23/lf in /websites/123reg/LinuxPackage23/lf/sf/lo/lfsfloorings.co.uk/public_html/DOA360/forums/phpbb/datetime.php on line 50
I found a few forums around here that told me to use a timestamp converter and run a query to fix the issue, which I did but still I can't login to the UCP.

If there is a superhero out there, please I need you more than ever here, I am losing hair by the minute :D

Thanks in advance to anyone who can help here.

Re: DateTime Issue After Update

Posted: Wed Apr 22, 2015 11:36 am
by gally
Managed to sort this after running a file to clear my forum cache.