TokenStream.php error after upgrading to 3.1.4

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
denis4o
Registered User
Posts: 80
Joined: Fri Dec 23, 2005 10:38 am
Location: Sofia, Bulgaria
Contact:

TokenStream.php error after upgrading to 3.1.4

Post by denis4o »

Hi all,

After upgrading to 3.1.4 I am getting the following error:

Code: Select all

Fatal error: Uncaught exception 'Twig_Error_Syntax' with message 'Unexpected end of template in "posting_poll_body.html" at line 54' in /home/ladaclub/public_html/forum/vendor/twig/twig/lib/Twig/TokenStream.php:60 Stack trace: #0 /home/ladaclub/public_html/forum/vendor/twig/twig/lib/Twig/TokenParser/If.php(47): Twig_TokenStream->next() #1 /home/ladaclub/public_html/forum/vendor/twig/twig/lib/Twig/Parser.php(191): Twig_TokenParser_If->parse(Object(Twig_Token)) #2 /home/ladaclub/public_html/forum/vendor/twig/twig/lib/Twig/Parser.php(99): Twig_Parser->subparse(NULL, false) #3 /home/ladaclub/public_html/forum/vendor/twig/twig/lib/Twig/Environment.php(479): Twig_Parser->parse(Object(Twig_TokenStream)) #4 /home/ladaclub/public_html/forum/vendor/twig/twig/lib/Twig/Environment.php(529): Twig_Environment->parse(Object(Twig_TokenStream)) #5 /home/ladaclub/public_html/forum/vendor/twig/twig/lib/Twig/Environment.php(323): Twig_Environment->compileSource('<div class="pan...', 'posting_poll_bo...') #6 /home/ladaclub/public_html/forum/p in /home/ladaclub/public_html/forum/vendor/twig/twig/lib/Twig/TokenStream.php on line 60
Since I had Advanced Polls installed and it relied on a template event that was non-existent on 3.1.3. I had to manually add:

Code: Select all

<!-- EVENT posting_poll_body_options_after -->
to posting_poll_body.html

However, even after removing that line and disabling the extension I keep getting that error.

Do you have an idea how I can fix that? I get the error only when posting with the full editor.

phpBB Version: 3.1.4
PHP Version: 5.6.0
PHP Memory: 256 MB

denis4o
Registered User
Posts: 80
Joined: Fri Dec 23, 2005 10:38 am
Location: Sofia, Bulgaria
Contact:

Re: TokenStream.php error after upgrading to 3.1.4

Post by denis4o »

Seems like the issue was with the merging of the new file from 3.1.4 and the old modified one from 3.1.3. Replacing it with a fresh copy of the 3.1.4. version did the trick.

The thread can be locked.

Locked

Return to “[3.1.x] Support Forum”