Extensions not showing up at all despite trying every fix/problem there is

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
robtig
Registered User
Posts: 28
Joined: Thu May 21, 2015 3:45 pm

Extensions not showing up at all despite trying every fix/problem there is

Post by robtig »

Support Request Template
What version of phpBB are you using? phpBB 3.1.4
What is your board's URL? http://viragohelp.com/phpbb3/index.php
Who do you host your board with? Freehostia
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? prosilver modified
What language(s) is your board currently using? english
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? I did a fresh install from 3.1.2 to 3.1.4
Please describe your problem. I cant get any extension to show up in my extensions list. My site is viragohelp.com. I doubt knowing that helps for this issue. I was able to see any extensions I added when using 3.1.2. I did a fresh install to 3.1.4 and now notice I cannot get an extension to show. I know how to unzip a file. I am using filezilla to upload. I am putting the folder in ext directory which is in the root of phpbb. Same area the config is in. I am trying the boardrules extension you recommend for testing. In my directory it is ext/phpbb/boardrules as it should be. I look in my ACP/customize/ area and under manage extensions not a thing is listed. I deleted everything out of the ext folder except an index file that was there. Then re uploaded the phpbb folder with boardrules folder in it and still nothing. I do not know what else to try. All my searches bring up fixes that aren’t my problem. I triple checked spellings, triple checked folder trees being proper.... I just cant figure this out.
Generated by SRT Generator
User avatar
KevC
Support Team Member
Support Team Member
Posts: 70072
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Extensions not showing up at all despite trying every fix/problem there is

Post by KevC »

Post a screenshot of your /ext folder showing the folders and files inside it.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Extensions not showing up at all despite trying every fix/problem there is

Post by Oyabun1 »

Upload this file: ext_checker.php to the root of you board installation on the server (there will be both a common.php and config.php file there).

When the file is in place let us know.

It will enable us to do some checks on the file paths of the extension.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
robtig
Registered User
Posts: 28
Joined: Thu May 21, 2015 3:45 pm

Re: Extensions not showing up at all despite trying every fix/problem there is

Post by robtig »

Sorry for the late reply. Had to take a break from the site as other things came up.
I have some good news. The ext for testing called 'boardrules' shows up. However I can't seem to get any other ext's to show up. One I really wanted to use was phpbb gallery. I put the main folder for it into a folder called 'subblue' since it is the creators nickname for it. It just wont show up. I tried moving the directory around, etc, and nothing. Shall I put in those files you mentioned above? Please let me know what you want me to do. I will gladly give you admin rights or whatever you need to help me figure this out. Thanks a ton.
Rob

Update: I went ahead and put that file in the root of my phpbb install. Hope this helps.

Also here is the MOD https://www.phpbb.com/customise/db/mod/phpbb_gallery/
Forgot to mention this. sorry
User avatar
david63
Registered User
Posts: 18102
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Extensions not showing up at all despite trying every fix/problem there is

Post by david63 »

The link that you posted was for a 3.0 mod - no matter where you put those files they will never show up as an extension in 3.1

In 3.1 you have to use extensions - the one for the Gallery is still in Beta and it is not advisable to install it yet, but you can follow its progress here viewtopic.php?f=456&t=2273501
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
robtig
Registered User
Posts: 28
Joined: Thu May 21, 2015 3:45 pm

Re: Extensions not showing up at all despite trying every fix/problem there is

Post by robtig »

Oh OK. So the problem I am having is I am not finding the right Mods for my specific version. I thought 3.0 were fine for 3.1. Now I know better and thank you for your time. You don't happen to know of a ext for my board that will allow users their own little image hosting setup do you?
Locked

Return to “[3.1.x] Support Forum”