Not able to establish Jabber Notification

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
User avatar
KlausiMaus
Registered User
Posts: 193
Joined: Sat Nov 15, 2014 4:55 pm

Not able to establish Jabber Notification

Post by KlausiMaus »

Support Request Template
What version of phpBB are you using? phpBB 3.1.6
What is your board's URL? http://forum.kuhnert.ch
Who do you host your board with? http://www.simplehosting.ch/
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.1.5
What extensions do you have installed? http://forum.kuhnert.ch/app.php/extlist
What styles do you currently have installed? prosilver
What language(s) is your board currently using? German
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
What username can be used to view this issue? Tester
What password can be used to view this issue? $tester$
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? no action
Please describe your problem. My provider installed a new Firewall and after enabling pots 5222 and 5223 I have the situation that I cannot setup the jabber-connection in the ACP. I get an empty page and after resync I'm back to ACP jabber page.
Since it was working in the past, I assume,e that the old setup is active, but when I try to send an message I get this:
phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_jabber.php on line 568: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
Generated by SRT Generator
Klaus (http://forum.kuhnert.ch/) :: Keep it simple, stupid :!:
User avatar
KlausiMaus
Registered User
Posts: 193
Joined: Sat Nov 15, 2014 4:55 pm

Re: Not able to establish Jabber Notification

Post by KlausiMaus »

Now I see this error-log:

Jabber-Fehler
» JABBER
/memberlist.php

Die Anmeldung am Jabber-Server war nicht erfolgreich.
SEND: <?xml version='1.0' encoding='UTF-8' ?>

SEND: <stream:stream to='jabber.ccc.de' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'>

RECV: <?xml version='1.0'?><stream:stream xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' id='3962953441' from='jabber.ccc.de' version='1.0' xml:lang='en'>

RECV: <stream:features><c xmlns='http://jabber.org/protocol/caps' hash='sha-1' node='http://www.process-one.net/en/ejabberd/' ver='bYQ/IFfK87W+0ywEpUSFD2VIpW0='/><starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'><required/></starttls></stream:features>

Switching to TLS.

SEND: <starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'/>

RECV: <proceed xmlns='urn:ietf:params:xml:ns:xmpp-tls'/>

Error: TLS mode change failed.
Last edited by KlausiMaus on Fri Oct 30, 2015 6:27 pm, edited 1 time in total.
Klaus (http://forum.kuhnert.ch/) :: Keep it simple, stupid :!:
User avatar
Mick
Support Team Member
Support Team Member
Posts: 23057
Joined: Fri Aug 29, 2008 9:49 am

Re: Not able to establish Jabber Notification

Post by Mick »

If it was working before your provider added the firewall you need to speak to them.
"The more connected we get the more alone we become" - Kyle Broflovski©
User avatar
KlausiMaus
Registered User
Posts: 193
Joined: Sat Nov 15, 2014 4:55 pm

Re: Not able to establish Jabber Notification

Post by KlausiMaus »

I've already talked to him and he has opened the ports 5222 and 5223, as I said before.
Klaus (http://forum.kuhnert.ch/) :: Keep it simple, stupid :!:
User avatar
KlausiMaus
Registered User
Posts: 193
Joined: Sat Nov 15, 2014 4:55 pm

Re: Not able to establish Jabber Notification

Post by KlausiMaus »

In Addition, the ports are only outbound, should they be bidirectional?
Klaus (http://forum.kuhnert.ch/) :: Keep it simple, stupid :!:
RevRaz
Registered User
Posts: 73
Joined: Thu Dec 26, 2002 10:43 pm

Re: Not able to establish Jabber Notification

Post by RevRaz »

I've seen 3 or 4 posts now about 3.1.6 doing this, when the previous versions didn't.
User avatar
KlausiMaus
Registered User
Posts: 193
Joined: Sat Nov 15, 2014 4:55 pm

Re: Not able to establish Jabber Notification

Post by KlausiMaus »

RevRaz wrote:I've seen 3 or 4 posts now about 3.1.6 doing this, when the previous versions didn't.
Do you mean in 3 or 4 posts is reported that with 3.1.6 jabber is running?
I still have this Problem, I've disabled all Extension, but still the same.

Maybe it's helpful to get some info from admind who have jabber working, such like the jabber server they use. I use "jabber.ccc.de", with other Servers (accounts) I get no connection and othet behavier and messages.
Klaus (http://forum.kuhnert.ch/) :: Keep it simple, stupid :!:
Locked

Return to “[3.1.x] Support Forum”