Page 2 of 2

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 7:23 am
by LavIgor
Lumpy Burgertushie wrote:why are so many people/hosts upgrading to php7 when it is still in beta.
If you want to stay up-to-date, check out the downloads page: http://php.net/downloads.php.
Current stable versions are both 7.0.9 and 5.6.24.
http://php.net/supported-versions.php

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 12:30 pm
by potku
Could this error appear with PHP 5.x? Because we are kind of lost with this one... Our host upgraded to PHP 7 not knowing phpBB 3.0.x is not compatible with it, but he quickly downgraded back to PHP 5.x, and yet, we are still receicving this error. Does anyone know why that is?
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 498: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
potku.net/forum/
http://potku.net/forum/

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 12:34 pm
by david63
That is definitely a PHP 7 error and does not appear with PHP 5.x

Not sure if it will solve the problem but you could try purging the cache if you have not already done so.

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 1:20 pm
by potku
Thanks for a quick reply.

I cannot access ACP. It gives me a blank page. With FTP, I cannot see index.htm in cache folder. Hmm...

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 1:48 pm
by david63
potku wrote:I cannot access ACP. It gives me a blank page. With FTP, I cannot see index.htm in cache folder.
That doesn't really matter - it doesn't affect anything but it would be an idea to replace it at some point.

If there are any other files in the cache folder then delete them (except for .htaccess)

Failing that it will be back to your hosts as it may be that they have not reverted you back to PHP 5.x, or if they have they have not done it correctly.

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 1:54 pm
by JimA
Contact your host with the error message and point them to this topic. This is a PHP7 error which should really be resolved after downgrading. Potentially there is a caching issue here. Delete the files as David says and see what it does.

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 2:22 pm
by david63
Just has a thought - are you using Cloudflare?

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 3:30 pm
by potku
Thanks for your help, guys. :)

Our host is installing CloudLinux as we speak. Hopefully this 30+ hours downtime will shortly be history. Last weekend we transferred over to this host, and it took 1½ days to complete, so we've had some decent downtime as of late. :D

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 4:28 pm
by Sugama97
You all are fabulous. I'm learning so much just reading all of this.
I was using 7.0.6.
I contacted my Host and they said they're unable to upgrade it to 7.0.9, so I had them downgrade it to 5.6.21 and everything is working!

Thank you all so much!

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Thu Aug 18, 2016 12:50 pm
by Pierre Liberas
"why are so many people/hosts upgrading to php7 "

Really much faster and new release of others need 7.0

If you have a server with other CSS & web site or applications you must be on the same level for all

For me I have just a pb with the forum; so it's imposible to downgrade all.

Is it possible to get a release befor december ?

Thank's to the Team

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Thu Aug 18, 2016 1:26 pm
by Mick
Pierre Liberas wrote:"Is it possible to get a release befor december ?
What release?

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Thu Aug 18, 2016 2:38 pm
by RMcGirr83
Probably the release that then makes phpBB compatible with PHP 7

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Thu Aug 18, 2016 2:47 pm
by Pierre Liberas
@RMcGirr83

That's right

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sun Apr 16, 2017 7:56 pm
by rolandet
Although I'm bumping an old topic, I've stumbled upon this cause I faced the same problem, and wanted to register my solution:

Because I've installed a new wordpress, my Dutch webhost (hosting2go) automatically updated PHP to v7 for my account.
Luckily their portal allows me choose to downgrade it back to a lower version.

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sun Apr 16, 2017 8:43 pm
by JimA
rolandet wrote:
Sun Apr 16, 2017 7:56 pm
Although I'm bumping an old topic, I've stumbled upon this cause I faced the same problem, and wanted to register my solution:

Because I've installed a new wordpress, my Dutch webhost (hosting2go) automatically updated PHP to v7 for my account.
Luckily their portal allows me choose to downgrade it back to a lower version.
Given that this topic is relatively old and this information wasn't available back then, I'll add a more sustainable solution, which is upgrading to our latest version, phpBB 3.2.0. That version supports all the newer versions from PHP, including version 7.0. :)