Page 1 of 2

PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Wed Jan 13, 2016 7:41 pm
by Solidjeuh
When I change from php 5.6.16 to 7.0.1 I receive an error.
Is this because of some extensions then need an update?
I have that error on board3 portal and viewtopic.php
Maybe Advanced BBCode Box and few other extensions...?
I updated to phpBB 3.1.7-pl1 last night.

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 370: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5282: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Wed Jan 13, 2016 9:20 pm
by david63
I believe that phpBB 3.1 is not 100% compatible with php 7

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Wed Jan 13, 2016 9:26 pm
by Solidjeuh
david63 wrote:I believe that phpBB 3.1 is not 100% compatible with php 7
It seems to work, except in JV-Shoutbox and Advanced BBCode Box ..
So extensions that use BBCode.
So could be the extensions.. maybe.. :geek:
Oh well, it's not needed to upgrade to php 7.0.1, who cares :lol:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Wed Jan 13, 2016 9:32 pm
by Crizzo
phpBB 3.1.x does not support PHP 7.0 and higher. See: https://github.com/phpbb/phpbb/blob/3.1 ... r.json#L28

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Wed Jan 13, 2016 9:34 pm
by Solidjeuh
Crizzo wrote:phpBB 3.1.x does not support PHP 7.0 and higher. See: https://github.com/phpbb/phpbb/blob/3.1 ... r.json#L28
Then it's 3.2 that works with 7.0.1..? I was being stupid again.. :lol:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Wed Jan 13, 2016 9:34 pm
by 3Di
david63 wrote:I believe that phpBB 3.1 is not 100% compatible with php 7
Clearly stated into the 3.1.7-pl1 release (docs/INSTALL.html): between PHP 5.3.3+< and PHP < 7.0. If I correctly understood is equal to less than 7.0.?

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Thu Jan 14, 2016 11:52 am
by LavIgor
3Di wrote:
david63 wrote:I believe that phpBB 3.1 is not 100% compatible with php 7
Clearly stated into the 3.1.7-pl1 release (docs/INSTALL.html): between PHP 5.3.3+< and PHP < 7.0. If I correctly understood is equal to less than 7.0.?
Where have you taken this line from?
In the official package there's the following line:
PHP 5.3.3+ and PHP < 7.0 with support for the database you intend to use.
This commit includes the updated supported PHP version numbers.
As you can notice, the line in README.html states the supported version numbers more clearly:
The minimum version required is PHP 5.3.3 and the maximum supported version is any version prior to PHP 7.0.

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Thu Jan 14, 2016 12:22 pm
by RMcGirr83
3Di wrote:
david63 wrote:I believe that phpBB 3.1 is not 100% compatible with php 7
Clearly stated into the 3.1.7-pl1 release (docs/INSTALL.html): between PHP 5.3.3+< and PHP < 7.0. If I correctly understood is equal to less than 7.0.?
Not equal to less than, that would be this =< 7.0 otherwise simply less than

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Thu Jan 14, 2016 1:00 pm
by LavIgor
RMcGirr83 wrote:
3Di wrote:
david63 wrote:I believe that phpBB 3.1 is not 100% compatible with php 7
Clearly stated into the 3.1.7-pl1 release (docs/INSTALL.html): between PHP 5.3.3+< and PHP < 7.0. If I correctly understood is equal to less than 7.0.?
Not equal to less than, that would be this =< 7.0 otherwise simply less than
I didn't disagree with that statement because it is correct.

> If I correctly understood is equal to less than 7.0.?
means "equal to less than 7.0", not less than or equal to 7.0.

"Equal to" is related to the statement in this case. The statement is equal to this. ;)

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Thu Jan 14, 2016 7:17 pm
by 3Di
^ this ^

I should have wrote "means less than...", don't know. :)

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Thu Jan 14, 2016 7:19 pm
by Solidjeuh
This is very confusing for a noob like me :lol: :lol:

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 5:37 am
by Sugama97
This is very confusing.

This was all discussed in January for 3.1.7?
Is there any update since?

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 6:41 am
by JimA
Sugama97 wrote:This is very confusing.

This was all discussed in January for 3.1.7?
Is there any update since?
Hi, welcome to phpBB.com! :)

Well, not really. It is still the same in the way that the 3.1.x line is not compatible with PHP7. You'll need a PHP version that's 5.3.3 or higher, but not at high as PHP7.

We are currently in the last testing phase (RC) of our new feature release, phpBB 3.2, which will be compatible with PHP7. It's currently not suitable for use in a live environment, but I expect it to be released in the next few months. So you have two options. Either use phpBB 3.1 and downgrade your PHP version back to PHP5, or wait for the final release of phpBB 3.2 in a few months which supports PHP7.

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 7:12 am
by Lumpy Burgertushie
why are so many people/hosts upgrading to php7 when it is still in beta. it isn't even in release candidate status yet. there aren't that many programs that can use 7 yet.

5.6 is the current stable version of php.

robert

Re: PHP 7.0.1 ( PHP Warning: in file [ROOT] )

Posted: Sat Aug 13, 2016 7:14 am
by Paul
Lumpy Burgertushie wrote:why are so many people/hosts upgrading to php7 when it is still in beta. it isn't even in release candidate status yet. there aren't that many programs that can use 7 yet.

5.6 is the current stable version of php.

robert
Php7 is not in beta, the first stable release of php 7 was in december last year ;)