3.1.6 to 3.1.7PL update problem

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Ideas Centre
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
promod
Registered User
Posts: 53
Joined: Wed Sep 03, 2014 3:56 pm

3.1.6 to 3.1.7PL update problem

Post by promod » Sun Jan 31, 2016 3:58 am

I was trying to do the automatic update from 3.1.6 to 3.1.7PL in between internet connection was lost. I kept it as it is till the time connection was restored.

I have started again all over and checked the difference files and downloaded the same and uploaded the 'update files'.

Now i'm at 'Perform database update' and but when i click the 'update my database now' i'm getting the " Server Error 500"

Any help will be appreciated to recover the site

User avatar
Lumpy Burgertushie
Registered User
Posts: 66929
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.1.6 to 3.1.7PL update problem

Post by Lumpy Burgertushie » Sun Jan 31, 2016 4:12 am

ok, assuming that you have not made any edits to the core phpbb files ( you should not have ),start over. download the complete current version package.

unzip it, remove the config.php file

upload all the remaining files/folders to the server letting them overwrite what is there.

go to: yourdomain.com/yourphpbb/install/database_update.php

when you get a success message at the bottom of the page, go back to the ftp and delete the folder named install.

you are done.
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

promod
Registered User
Posts: 53
Joined: Wed Sep 03, 2014 3:56 pm

Re: 3.1.6 to 3.1.7PL update problem

Post by promod » Sun Jan 31, 2016 4:45 am

What a relief :D

Everything is normal and site is back... Thanks a ton for your help... Kudos to you

promod
Registered User
Posts: 53
Joined: Wed Sep 03, 2014 3:56 pm

Re: 3.1.6 to 3.1.7PL update problem

Post by promod » Tue Feb 02, 2016 7:07 am

Site again down for the same error... Just repeated the step again but this time not able to get the /install/database_update.php as this page also showing error 500 :oops: :o

User avatar
Lumpy Burgertushie
Registered User
Posts: 66929
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.1.6 to 3.1.7PL update problem

Post by Lumpy Burgertushie » Tue Feb 02, 2016 7:17 am

those are server errors. you need to contact your host and ask them to check the server logs to see what is causing the error.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

promod
Registered User
Posts: 53
Joined: Wed Sep 03, 2014 3:56 pm

Re: 3.1.6 to 3.1.7PL update problem

Post by promod » Tue Feb 02, 2016 10:46 am

Host informed the same below:

'PHP Fatal error: Class 'phpbb\\config_php_file' not found in /xxxxxxxx.xxx/forum/common.php on line 29'.


and my common.php line 29 says

$phpbb_config_php_file = new \phpbb\config_php_file($phpbb_root_path, $phpEx);

User avatar
Lumpy Burgertushie
Registered User
Posts: 66929
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.1.6 to 3.1.7PL update problem

Post by Lumpy Burgertushie » Tue Feb 02, 2016 3:21 pm

make sure the config.php file is in the board root and that it is not empty and does not have anything at all before the opening <?php


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

promod
Registered User
Posts: 53
Joined: Wed Sep 03, 2014 3:56 pm

Re: 3.1.6 to 3.1.7PL update problem

Post by promod » Tue Feb 02, 2016 3:29 pm

i just checked and confirming that there is nothing before<?php

<?php
// phpBB 3.0.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'mysqli';
$dbhost = 'localhost';
$dbport = 'xxxx';
$dbname = 'xxxxxxxxxxxx';
$dbuser = 'xxxxxxxxxxxxxxx';
$dbpasswd = 'xxxxxxxxxxxxxxxx';
$table_prefix = 'xxphpbb_';
$acm_type = 'file';
$load_extensions = '';

@define('PHPBB_INSTALLED', true);
// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);


Sensitive info marked with 'x'

User avatar
Lumpy Burgertushie
Registered User
Posts: 66929
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.1.6 to 3.1.7PL update problem

Post by Lumpy Burgertushie » Tue Feb 02, 2016 3:36 pm

sorry, read that wrong. there is a folder named phpbb inside your board, inside that folder is a file named config_php_file.php

make sure that file is there.

make sure that your file/folder permissions ( CHMOD ) are correct.

all folders should be 755 except for the files folder, the cache folder and the images/avatars/upload folder.
all files should be 644.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

promod
Registered User
Posts: 53
Joined: Wed Sep 03, 2014 3:56 pm

Re: 3.1.6 to 3.1.7PL update problem

Post by promod » Tue Feb 02, 2016 3:52 pm

Lumpy Burgertushie wrote:sorry, read that wrong. there is a folder named phpbb inside your board, inside that folder is a file named config_php_file.php

make sure that file is there.
Checked and confirmed that file is present inside phpbb folder
Lumpy Burgertushie wrote:make sure that your file/folder permissions ( CHMOD ) are correct.

all folders should be 755 except for the files folder, the cache folder and the images/avatars/upload folder.
all files should be 644.

robert
double checked and found to be correct as well. files folder,Cache and images/avatars/upload permission is 777. rest files are with 644 permission.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66929
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.1.6 to 3.1.7PL update problem

Post by Lumpy Burgertushie » Tue Feb 02, 2016 3:56 pm

what are you using to transfer files to the server? what ftp program?

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

promod
Registered User
Posts: 53
Joined: Wed Sep 03, 2014 3:56 pm

Re: 3.1.6 to 3.1.7PL update problem

Post by promod » Tue Feb 02, 2016 3:57 pm

FileZilla v3.14.1

Anything else to be done so that site can be recovered back?

User avatar
Lumpy Burgertushie
Registered User
Posts: 66929
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.1.6 to 3.1.7PL update problem

Post by Lumpy Burgertushie » Tue Feb 02, 2016 6:30 pm

at this point I am out of ideas. try installing a new board on the server ( leave your existing one alone )

create a new blank database, download a new set of files from here and upload all new files and run the install.
don't know if you are, but don't unzip on the server. unzip on your computer and upload the files.
see if that board works ok.
if so, then we can assume there is no problem at the server level and have to start looking at phpbb again.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

promod
Registered User
Posts: 53
Joined: Wed Sep 03, 2014 3:56 pm

Re: 3.1.6 to 3.1.7PL update problem

Post by promod » Wed Feb 03, 2016 12:45 am

I wanted to check with you, if this error related to the database?

As i had run some queries in database earlier, but after that also board was working fine

Ref: viewtopic.php?f=466&t=2335161&start=15#p14335031

promod
Registered User
Posts: 53
Joined: Wed Sep 03, 2014 3:56 pm

Re: 3.1.6 to 3.1.7PL update problem

Post by promod » Wed Feb 03, 2016 2:54 pm

I have taken the pain to re-verify all the file sizes from the new fresh 3.1.7pl1 package and file sizes in the server uploaded through FileZilla and found that some files are showing as zero size :shock:

Now changed all those zero size and other files which has size differences through a different internet broadband connection and finally......... able to get the database_update.php and now site is back in action.

Robert ... Thanks for patiently replying back to me and helping me to retrieve the site :D

Locked

Return to “[3.1.x] Support Forum”