3.1.5 download - problem with 3.1.8 install

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
tony kiteboarder
Registered User
Posts: 32
Joined: Sat Feb 27, 2016 11:37 am

3.1.5 download - problem with 3.1.8 install

Post by tony kiteboarder » Sat Feb 27, 2016 11:41 am

Hi

Managed to screw up my forum this morning using the autoupdate package
I copied the changed files and now getting a blank screen, unfortunately, through rushing I lost the back up of my forum files
Seems like the easiest way now is to reinstall 3.1.5 (version I was running) but I can't seem to find a download?

Many thanks

Tony
Last edited by tony kiteboarder on Sat Feb 27, 2016 1:17 pm, edited 1 time in total.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69430
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: 3.1.5 download

Post by KevC » Sat Feb 27, 2016 11:49 am

Just got straight for 3.1.8.

Upload all new files except config.php, /images, /ext and /files and then run the install/database_update.php file, delete /install and you're done.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

tony kiteboarder
Registered User
Posts: 32
Joined: Sat Feb 27, 2016 11:37 am

Re: 3.1.5 download

Post by tony kiteboarder » Sat Feb 27, 2016 12:16 pm

Thanks, that was easy until I went to the forum, now getting the following...

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 186: is_file(): open_basedir restriction in effect. File(./styles/prosilver/template/../../../../../../store/customcode/overall_header_head_append.html) is not within the allowed path(s): (/var/www/vhosts/kiteboarder.co.uk/:/tmp/)
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 186: is_file(): open_basedir restriction in effect. File(./styles/prosilver/theme/../../../../../../store/customcode/overall_header_head_append.html) is not within the allowed path(s): (/var/www/vhosts/kiteboarder.co.uk/:/tmp/)
Many thanks

Tony

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69430
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: 3.1.5 download - problem with 3.1.8 install

Post by KevC » Sat Feb 27, 2016 1:31 pm

Make sure you've uploaded the files correctly. It seems to be looking at some odd paths.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
tahoebuff
Registered User
Posts: 1427
Joined: Tue Jul 20, 2004 12:33 am
Location: Nevada
Name: Michael
Contact:

Re: 3.1.5 download - problem with 3.1.8 install

Post by tahoebuff » Sat Feb 27, 2016 6:25 pm

I think the Custom Code Ext. may be his problem.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66856
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.1.5 download - problem with 3.1.8 install

Post by Lumpy Burgertushie » Sat Feb 27, 2016 6:49 pm

maybe, but notice this:
open_basedir restriction in effect

that is a php setting that needs to be turned off.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

tony kiteboarder
Registered User
Posts: 32
Joined: Sat Feb 27, 2016 11:37 am

Re: 3.1.5 download - problem with 3.1.8 install

Post by tony kiteboarder » Sun Feb 28, 2016 2:19 pm

Hi

I deleted the custom code ext as recommended in the link above and emptied the cache folder, although it didn't seem to empty fully, with a lot of folders in the twig folder?

Now I get this...

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/class_loader.php on line 160: require(./ext/marttiphpbb/customcode/event/listener.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/class_loader.php on line 160: require(./ext/marttiphpbb/customcode/event/listener.php): failed to open stream: No such file or directory
Many thanks

Tony

User avatar
Lumpy Burgertushie
Registered User
Posts: 66856
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.1.5 download - problem with 3.1.8 install

Post by Lumpy Burgertushie » Sun Feb 28, 2016 5:03 pm

if you can get to the admin panel, put the customcode ext back. enable it.

then disable it, delete the data and then you can remove the actual files if you wish.

I think this problem is because you may have just deleted the custom code folder without properly disabling and deleting the data before.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

tony kiteboarder
Registered User
Posts: 32
Joined: Sat Feb 27, 2016 11:37 am

Re: 3.1.5 download - problem with 3.1.8 install

Post by tony kiteboarder » Sun Feb 28, 2016 7:33 pm

I can't get onto the forum at all, so I just deleted the extension.
Is there any other way round it?

Many Tanks

Tony

Locked

Return to “[3.1.x] Support Forum”