Multiple ACP functions causing Twig errors after upgrade

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
buksida
Registered User
Posts: 308
Joined: Thu Feb 04, 2010 9:11 am

Multiple ACP functions causing Twig errors after upgrade

Post by buksida » Fri Mar 04, 2016 2:04 am

Support Request Template
What version of phpBB are you using? phpBB 3.1.8
What is your board's URL? http://spengler.atimes.net
Who do you host your board with? Servint
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.1.7-pl1
What styles do you currently have installed? prosilver
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? Experienced with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Updated board from 3.1.7 to 3.1.8
Please describe your problem. Can no longer carry out ACP functions or purge the cache, this is a typical error:

Fatal error: Uncaught exception 'RuntimeException' with message 'Unable to create the cache directory (./../cache/twig//5/6).' in /home/atimes/subdomains/spengler/httpdocs/vendor/twig/twig/lib/Twig/Environment.php:1275 Stack trace: #0 /home/atimes/subdomains/spengler/httpdocs/vendor/twig/twig/lib/Twig/Environment.php(335): Twig_Environment->writeCacheFile('./../cache/twig...', '<?php\n\n/* acp_l...') #1 /home/atimes/subdomains/spengler/httpdocs/phpbb/template/twig/environment.php(151): Twig_Environment->loadTemplate('acp_logs.html', NULL) #2 /home/atimes/subdomains/spengler/httpdocs/vendor/twig/twig/lib/Twig/Environment.php(308): phpbb\template\twig\environment->loadTemplate('acp_logs.html') #3 /home/atimes/subdomains/spengler/httpdocs/phpbb/template/twig/twig.php(332): Twig_Environment->display('acp_logs.html', Array) #4 /home/atimes/subdomains/spengler/httpdocs/includes/functions_acp.php(181): phpbb\template\twig\twig->display('body') #5 /home/atimes/subdomains/spengler/httpdocs/adm/index.php(90): adm_page_footer() #6 { in /home/atimes/subdomains/spengler/httpdocs/vendor/twig/twig/lib/Twig/Environment.php on line 1275

Following folders already set to 777: cache, store, files
Generated by SRT Generator

buksida
Registered User
Posts: 308
Joined: Thu Feb 04, 2010 9:11 am

Re: Multiple ACP functions causing Twig errors after upgrade

Post by buksida » Sat Mar 05, 2016 3:07 am

Anyone ???

buksida
Registered User
Posts: 308
Joined: Thu Feb 04, 2010 9:11 am

Re: Multiple ACP functions causing Twig errors after upgrade

Post by buksida » Sat Mar 05, 2016 12:24 pm

Any idea where I can go then to get help with this?

Tarantino
Registered User
Posts: 740
Joined: Sat Feb 18, 2012 1:51 pm
Contact:

Re: Multiple ACP functions causing Twig errors after upgrade

Post by Tarantino » Sat Mar 05, 2016 12:30 pm

Clean the cache via ftp

buksida
Registered User
Posts: 308
Joined: Thu Feb 04, 2010 9:11 am

Re: Multiple ACP functions causing Twig errors after upgrade

Post by buksida » Sat Mar 05, 2016 12:48 pm

Did that yesterday, problem remains.

Tarantino
Registered User
Posts: 740
Joined: Sat Feb 18, 2012 1:51 pm
Contact:

Re: Multiple ACP functions causing Twig errors after upgrade

Post by Tarantino » Sat Mar 05, 2016 1:42 pm

And did you delete the twig folder?

buksida
Registered User
Posts: 308
Joined: Thu Feb 04, 2010 9:11 am

Re: Multiple ACP functions causing Twig errors after upgrade

Post by buksida » Sat Mar 05, 2016 2:49 pm

Deleted everything in cache (including Twig folder), apart from the index file.

User avatar
gn#36
Translator
Posts: 185
Joined: Fri Oct 13, 2006 1:16 pm
Contact:

Re: Multiple ACP functions causing Twig errors after upgrade

Post by gn#36 » Sun Mar 06, 2016 1:35 am

Check the write permissions of the cache folder. The folder should be globally writeable or at the very least writeable by the webserver. The error message states that it cannot create some cache file, so there is probably something wrong with the permissions.
German Support Team Member • http://www.phpbb.deMy Extensions in the CDBMy Extensions on Github • Contact with caos is inavoidable but no catastrophy if you keep an overview.

buksida
Registered User
Posts: 308
Joined: Thu Feb 04, 2010 9:11 am

Re: Multiple ACP functions causing Twig errors after upgrade

Post by buksida » Sun Mar 06, 2016 1:57 am

Permissions are 777 on the cache folder. What should they be?

User avatar
3Di
Former Team Member
Posts: 13780
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Multiple ACP functions causing Twig errors after upgrade

Post by 3Di » Sun Mar 06, 2016 3:27 am

buksida wrote:Permissions are 777 on the cache folder. What should they be?
Are correct. ;)

Feel free to try my new tool for support, I tested it and not only tells you the way your cache is chmodded but a lot of usefull infos in order to get a better support.

If you are not logged in as a founder or admin a login box will help you to get in.

Download it and FTP/copy it to your board root (i.e.: where the config.php file is)
right_install.php v1.0.0-a1 https://gist.github.com/3D-I/3dd7e3f7bf1fb5fc5261 (Work In Progress)

Point your browser to : your_board_url/right_install.php (it will self destroys once ran)

Let us see the answers it gives.

screenshot
true_version_compare-true-1.png
Regards.

Edit: new screenshot whit the PHP version check feature added
Last edited by 3Di on Sun Mar 06, 2016 4:11 am, edited 2 times in total.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

buksida
Registered User
Posts: 308
Joined: Thu Feb 04, 2010 9:11 am

Re: Multiple ACP functions causing Twig errors after upgrade

Post by buksida » Sun Mar 06, 2016 3:53 am

Thanks, get this error when trying to install:

Code: Select all

No route found for "GET /right-install.php"

User avatar
3Di
Former Team Member
Posts: 13780
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Multiple ACP functions causing Twig errors after upgrade

Post by 3Di » Sun Mar 06, 2016 4:08 am

buksida wrote:Thanks, get this error when trying to install:

Code: Select all

No route found for "GET /right-install.php"
The right filename is: right_install.php
I do have just updated the file and checks also for the PHP version. (Above screenshot updated)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

buksida
Registered User
Posts: 308
Joined: Thu Feb 04, 2010 9:11 am

Re: Multiple ACP functions causing Twig errors after upgrade

Post by buksida » Sun Mar 06, 2016 4:20 am

Doh!

Here is the screenshot:
screen.jpg

User avatar
3Di
Former Team Member
Posts: 13780
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Multiple ACP functions causing Twig errors after upgrade

Post by 3Di » Sun Mar 06, 2016 4:30 am

;) Could you please re download it? I added a check for PHP version.
Thanks.

Everythings though seems to be allright..
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

buksida
Registered User
Posts: 308
Joined: Thu Feb 04, 2010 9:11 am

Re: Multiple ACP functions causing Twig errors after upgrade

Post by buksida » Sun Mar 06, 2016 5:25 am

screen2.jpg

Locked

Return to “[3.1.x] Support Forum”