Upgrading from 3.0.6 to 3.1.8

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
User avatar
PlanetMelb
Registered User
Posts: 135
Joined: Sat May 10, 2003 5:19 am

Upgrading from 3.0.6 to 3.1.8

Post by PlanetMelb » Wed Mar 30, 2016 9:58 pm

Hi Everyone

I fear I have 'broken' my forum after trying to upgrade from 3.0.6 to 3.1.8. As I hadn't upgraded for ages and had no modifications to keep, I uploaded a fresh install of the latest version being 3.1.8 then uploaded by old config.php. I am getting this error:

Image

Obviously the "phpbb.ext" table didn't exist in the old version. I tried running install/database_update.php but also get a number of errors. I am assured by my server hosts that the old data is still there

Any help appreciated

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50665
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Upgrading from 3.0.6 to 3.1.8

Post by stevemaury » Wed Mar 30, 2016 10:58 pm

What are the "number of errors"?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
PlanetMelb
Registered User
Posts: 135
Joined: Sat May 10, 2003 5:19 am

Re: Upgrading from 3.0.6 to 3.1.8

Post by PlanetMelb » Thu Mar 31, 2016 12:33 am

Thanks for your reply

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Unknown column 'is_dynamic' in 'field list' [1054]

SQL

SELECT config_name, config_value, is_dynamic FROM phpbb_config

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysql.php
LINE: 181
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysql->sql_query()

FILE: [ROOT]/phpbb/config/db.php
LINE: 71
CALL: phpbb\db\driver\factory->sql_query()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\config\db->__construct()

FILE: [ROOT]/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 886
CALL: ReflectionClass->newInstanceArgs()

FILE: [ROOT]/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 452
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->createService()

FILE: [ROOT]/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 932
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->get()

FILE: [ROOT]/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 929
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->resolveServices()

FILE: [ROOT]/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 871
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->resolveServices()

FILE: [ROOT]/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ContainerBuilder.php
LINE: 452
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->createService()

FILE: [ROOT]/install/database_update.php
LINE: 91
CALL: Symfony\Component\DependencyInjection\ContainerBuilder->get()

Locked

Return to “[3.1.x] Support Forum”