Logged out after visiting main site after host move

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
User avatar
Virtuality
QA Team
Posts: 109
Joined: Sat Dec 14, 2002 4:44 pm
Location: Stockholm, Sweden
Contact:

Logged out after visiting main site after host move

Post by Virtuality » Mon Jun 06, 2016 2:10 pm

Support Request Template
What version of phpBB are you using? phpBB 3.1.9
What is your board's URL? http://www.carlssonplanet.com/forum/
Who do you host your board with? Bluehost
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.1.8
What extensions do you have installed? phpBB Gallery 1.2.0
Sortables Captcha 2.0.0
What styles do you currently have installed? prosilver
What language(s) is your board currently using? English and Swedish
Which database type/version are you using? MySQL 5
What is your level of experience? Experienced with PHP and phpBB
What username can be used to view this issue? Only applies on previous accounts it seems, as I cannot re-create it with a brand new user, but it is present for users that existed before the move.
What password can be used to view this issue? See above.
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? The problem appeared after moving hosts - I just moved to Bluehost. I have made similar moves many times in my life and I know how I do them, but this time something went wrong... Otherwise everything is identical to the setup at the previous host.
Please describe your problem. The problem is that if you log in, you only stay logged in until you visit the main site. After visting the main site, and going back to the forum, you will be logged out. I have changed no settings from before, and this has worked fine for years up until now.
I have of course verified cookie settings and reset all cookies and tried various browsers and so on, but it can constantly be re-created.
Generated by SRT Generator

Kind and many thanks in advance for any assistance in this matter!
As you can maybe see from my profile etc., I have fair experience with phpBB so this should hopefully not be something obvious...
Jonathan “Virtuality” Gulbrandsen - phpBB 2.x & 3.x Swedish Translator
phpbb-se.com - phpBB på svenska! | Development board for the Swedish translation of phpBB3

User avatar
Lumpy Burgertushie
Registered User
Posts: 66332
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Logged out after visiting main site after host move

Post by Lumpy Burgertushie » Mon Jun 06, 2016 3:04 pm

your board is not setting any cookies at all.

not sure why. what do you have in the admin panel for cookie settings?

what do you have in the admin panel for server settings?


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
Virtuality
QA Team
Posts: 109
Joined: Sat Dec 14, 2002 4:44 pm
Location: Stockholm, Sweden
Contact:

Re: Logged out after visiting main site after host move

Post by Virtuality » Mon Jun 06, 2016 3:22 pm

Lumpy Burgertushie wrote:your board is not setting any cookies at all.

not sure why. what do you have in the admin panel for cookie settings?

what do you have in the admin panel for server settings?


robert
Hmm. It seems to be for me though? Attaching 3 screenshots, 2 from the admin settings and 1 from Chrome showing cookies.
Screenshot 2016-06-06 17.21.56.png
Screenshot 2016-06-06 17.20.47.png
Screenshot 2016-06-06 17.20.33.png
Jonathan “Virtuality” Gulbrandsen - phpBB 2.x & 3.x Swedish Translator
phpbb-se.com - phpBB på svenska! | Development board for the Swedish translation of phpBB3

User avatar
janus_zonstraal
Registered User
Posts: 3268
Joined: Sat Aug 30, 2014 1:30 pm

Re: Logged out after visiting main site after host move

Post by janus_zonstraal » Mon Jun 06, 2016 5:25 pm

The cookies are old I think.
Nothing in FF from your forum here.
Sorry! My English is bat ;) !!!

Slayer00
Translator
Posts: 27
Joined: Tue Sep 17, 2013 1:09 pm

Re: Logged out after visiting main site after host move

Post by Slayer00 » Mon Jun 06, 2016 10:41 pm

No cookies for me either.

Nothing else to add, sorry.

User avatar
3Di
Former Team Member
Posts: 13780
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Logged out after visiting main site after host move

Post by 3Di » Tue Jun 07, 2016 1:23 am

read this post about checking your cookies and fix them
viewtopic.php?p=14447501#p14447501
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
Virtuality
QA Team
Posts: 109
Joined: Sat Dec 14, 2002 4:44 pm
Location: Stockholm, Sweden
Contact:

Re: Logged out after visiting main site after host move

Post by Virtuality » Tue Jun 07, 2016 5:32 pm

Thanks for your help guys. I am afraid I still haven't been able to solve it (and I am 100% sure the cookie settings are right, I looked at your link 3Di). Not sure what is going on, but I will keep digging into this...
Jonathan “Virtuality” Gulbrandsen - phpBB 2.x & 3.x Swedish Translator
phpbb-se.com - phpBB på svenska! | Development board for the Swedish translation of phpBB3

User avatar
Virtuality
QA Team
Posts: 109
Joined: Sat Dec 14, 2002 4:44 pm
Location: Stockholm, Sweden
Contact:

Re: Logged out after visiting main site after host move

Post by Virtuality » Wed Jun 08, 2016 12:15 pm

Hi,

This issue is confirmed resolved. Both of my issues was with the hosting provider I moved to - Bluehost. Moved away from them today and everything is back to normal and stable.

Thanks guys!

Kind regards,

Jonathan
Jonathan “Virtuality” Gulbrandsen - phpBB 2.x & 3.x Swedish Translator
phpbb-se.com - phpBB på svenska! | Development board for the Swedish translation of phpBB3

Locked

Return to “[3.1.x] Support Forum”