Avatars not showing after server move

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
User avatar
Virtuality
QA Team
Posts: 109
Joined: Sat Dec 14, 2002 4:44 pm
Location: Stockholm, Sweden
Contact:

Avatars not showing after server move

Post by Virtuality » Tue Jun 07, 2016 7:07 pm

Support Request Template
What version of phpBB are you using? phpBB 3.1.9
What is your board's URL? http://www.carlssonplanet.com/forum/
Who do you host your board with? Bluehost
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.1.8
What extensions do you have installed? phpBB Gallery 1.2.0
Sortables Captcha 2.0.0
What styles do you currently have installed? prosilver
What language(s) is your board currently using? English and Swedish
Which database type/version are you using? MySQL(i) 5.6.30
What is your level of experience? Experienced with PHP and phpBB
What username can be used to view this issue? Not needed, issue is that user-uploaded avatars are not showing.
What password can be used to view this issue? See above.
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? The problem appeared after moving hosts - I just moved to Bluehost. I have made similar moves many times in my life and I know how I do them, but this time something went wrong... Otherwise everything is identical to the setup at the previous host.
Please describe your problem. The problem is that avatars are not showing (they are returning a broken picture) for those users who have uploaded their own. I can verify all the files are in the images/avatars/upload folder (which has permissions set at 755) and that is also the folder set in ACP Avatar settings.
Here's an example thread where you have an user whose avatar doesn't work. If I go to the URL that it tries to link to and get the avatar from, I get the error "You haven’t selected an attachment to download or view."

URL to thread with avatar that does not work: http://www.carlssonplanet.com/forum/vie ... 170#p38170
URL to an avatar: http://www.carlssonplanet.com/forum/dow ... 547709.jpg

Generated by SRT Generator

Kind and many thanks in advance for any assistance in this matter!
Jonathan “Virtuality” Gulbrandsen - phpBB 2.x & 3.x Swedish Translator
phpbb-se.com - phpBB på svenska! | Development board for the Swedish translation of phpBB3

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21141
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: Avatars not showing after server move

Post by Mick » Wed Jun 08, 2016 11:35 am

Images, can be screwed up typically by uploading files through FTP as ASCII. How did you backup and upload the files from your old host to the new one? Check the images in your backup - make sure they display correctly in your favourite image viewer. If they don't they are corrupt and you will have to download them again from your original board and then FTP them to you new host making sure you transfer them in binary. Then, open the board’s /cache folder on the server and delete everything except index.htm and .htaccess.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
Virtuality
QA Team
Posts: 109
Joined: Sat Dec 14, 2002 4:44 pm
Location: Stockholm, Sweden
Contact:

Re: Avatars not showing after server move

Post by Virtuality » Wed Jun 08, 2016 12:15 pm

Hi,

This issue is confirmed resolved. Both of my issues was with the hosting provider I moved to - Bluehost. Moved away from them today and everything is back to normal and stable.

Thanks guys!

Kind regards,

Jonathan
Jonathan “Virtuality” Gulbrandsen - phpBB 2.x & 3.x Swedish Translator
phpbb-se.com - phpBB på svenska! | Development board for the Swedish translation of phpBB3

Locked

Return to “[3.1.x] Support Forum”