Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Buu
Registered User
Posts: 105
Joined: Wed Oct 16, 2013 5:50 pm

Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Buu »

Support Request Template
What version of phpBB are you using? phpBB 3.0.12
What is your board's URL? http://www.snowrippers.ro
Who do you host your board with? Comunity
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? Yes
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.0.12
What MODs do you have installed? portal
What extensions do you have installed? portal
What styles do you currently have installed? subsilver, aero
What language(s) is your board currently using? british english
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? I tried to upgrade from 3.012 to 3.1.9, i failed due to a vendor error, then i backed up
Please describe your problem. after the backup was done, in the ACP says that "Your phpBB installation is up to date. There are no updates available at this time."
A new feature release 3.1.9 is available. Please read the release announcement to learn about what it has to offer, and how to upgrade.
Generated by SRT Generator
Buu
Registered User
Posts: 105
Joined: Wed Oct 16, 2013 5:50 pm

Update from 3.0.12 to 3.1.9 error

Post by Buu »

Hello,
I have a little problem, when i tried to update my forum, from 3.0.12 to 3.1.9, this error cam out

Code: Select all

fatal error: Uncaught exception 'Twig_Error_Loader'
In this error was also something like messagebody.html.
Notice that i tried all the methods to update, with the update loader and a fresh clean kit, and deleting the images, files,store and config.
What can i do?
Can i fresh install a new forum on my host, and then do somthing with the data base to get the users and topics to the new forum? If yes, can you help me with a tutorial or something?
Thanks.
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Update from 3.0.12 to 3.1.9 error

Post by Mick »

Can you post the complete original error message please?
"The more connected we get the more alone we become" - Kyle Broflovski©
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Mick »

How did you upgrade, what method?
"The more connected we get the more alone we become" - Kyle Broflovski©
Buu
Registered User
Posts: 105
Joined: Wed Oct 16, 2013 5:50 pm

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Buu »

delete all files except images, files, store and config.php from the host, delete same folders from the new source, run the database, tried to install the new one, gave me a vendors messagebody.html error, after that i backed up and this happen
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Mick »

I've merged this with your other topic in 3.0 support - please stick to one topic per issue.

The error:

Code: Select all

Fatal error: Uncaught exception 'Twig_Error_Loader' with message 'Unable to find template "message_body.html" (looked into: ).' in /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:215 Stack trace: #0 /home/snowripp/public_html/phpbb/template/twig/loader.php(107): Twig_Loader_Filesystem->findTemplate('message_body.ht...') #1 /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Loader/Filesystem.php(139): phpbb\template\twig\loader->findTemplate('message_body.ht...') #2 /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Environment.php(312): Twig_Loader_Filesystem->getCacheKey('message_body.ht...') #3 /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Environment.php(378): Twig_Environment->getTemplateClass('message_body.ht...', NULL) #4 /home/snowripp/public_html/phpbb/template/twig/environment.php(151): Twig_Environment->loadTemplate('message_body.ht...', NULL) #5 /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Environment.php(362): phpbb\template\twig\environment->loadTemplate('message_ in /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 215
As the error states, message_body.html cannot be found. That is a file in the styles template folder and it must either be corrupt or missing, try replacing that file with a fresh one from the download package. Did you put your board back to prosilver before you upgraded?
"The more connected we get the more alone we become" - Kyle Broflovski©
Buu
Registered User
Posts: 105
Joined: Wed Oct 16, 2013 5:50 pm

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Buu »

hei, yes, the default teme was only prosilver, i tried to replace the message.body.html file with a new one, and same result ...
Can i install a fresh new 3.1.9 version, and somehow get the users and posts into it?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Mick »

Your users and posts are safe in the database, just do a file replacement (don't overwrite config.php!) It sounds as though something hasn't uploaded properly. What are you using as an FTP client? And yes, you can install a clean copy of 3.1.9 then point your config.php to the database you updated to 3.1.9. Note, if you edit config.php you'll need to purge the cache.
"The more connected we get the more alone we become" - Kyle Broflovski©
Buu
Registered User
Posts: 105
Joined: Wed Oct 16, 2013 5:50 pm

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Buu »

as a client, i use a free version of Cute FTP.
So, if i want to get a fresh start with a fresh new client, i have to install the new 3.1.9, (that means that i have to make in db another table for it? i tried to do this, but insted of create a new database, i tried to link it with the old db, but he said that the prefix is the same and i can`t do this).
How can i link the old db to a fresh new phpbb client 3.1.9?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Mick »

CuteFTP is good - well, my paid version is. You can use the same database if you like but you'll need to give it a new prefix, install won't allow you to overwrite it. Once that's done and you have a new version of 3.1 running edit config.php to suit the original database. Knowledge Base - Rebuilding Your config.php File. Just changing the prefix back to what it was in the original config.php should do it as long as the DB name and password are the same.
"The more connected we get the more alone we become" - Kyle Broflovski©
Buu
Registered User
Posts: 105
Joined: Wed Oct 16, 2013 5:50 pm

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Buu »

Hello, again :(

I tried to install a fresh new 3.1.9 version, all went good, but when i try to login in ACP this error appear ...

Code: Select all

General Error
SQL ERROR [ mysqli ]

Duplicate entry 'dbms_version' for key 'PRIMARY' [1062]

SQL

INSERT INTO test_config (config_name, config_value, is_dynamic) VALUES ('dbms_version', '5.6.30-cll-lve', 0)

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/config/db.php
LINE: 161
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/phpbb/config/db.php
LINE: 122
CALL: phpbb\config\db->set_atomic()

FILE: [ROOT]/includes/functions.php
LINE: 162
CALL: phpbb\config\db->set()

FILE: [ROOT]/includes/acp/acp_main.php
LINE: 675
CALL: set_config()

FILE: [ROOT]/includes/functions_module.php
LINE: 674
CALL: acp_main->main()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()
When i try to acces the forum, this appear:

Code: Select all

Language file ./language//common.php couldn't be opened.
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Mick »

I'm now seeing:
Language file ./language//common.php couldn't be opened
"The more connected we get the more alone we become" - Kyle Broflovski©
Buu
Registered User
Posts: 105
Joined: Wed Oct 16, 2013 5:50 pm

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Buu »

yup ... what can i do?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Mick »

It seems to me you have several files that have not uploaded properly or are corrupt.

Try a file replacement:
  1. Backup all board files and the database.
  2. Download the latest version.
  3. Unzip to your desktop and open the phpBB3 folder.
  4. Remove (delete) the config.php file, and the /images folder from the package.
  5. Via FTP or SFTP upload the remaining files and folders to the root of your board installation on the server overwriting the existing files.
  6. In your browser go to http://www.example.com/yourforum/instal ... update.php
  7. Continue that until it completes.
  8. Via FTP or SFTP delete the /install folder from the root of your board installation.
  9. Done.
You now have an up to date board containing all your users, posts, and extensions.

Only use a good FTP or SFTP client, such as WinSCP or FileZilla to transfer
the files. (File transfer utilities provided in host control panels can cause problems.)
"The more connected we get the more alone we become" - Kyle Broflovski©
Buu
Registered User
Posts: 105
Joined: Wed Oct 16, 2013 5:50 pm

Re: Wrong version in ACP after i tried to upgrade from 3.0.12 to 3.1.9

Post by Buu »

Hello,
Done all those steps, but when i launched install/database_update.php, this error appeared:

Code: Select all

SQL ERROR [ mysqli ]

Duplicate entry 'assets_version' for key 'PRIMARY' [1062]

SQL

INSERT INTO test_config (config_name, config_value, is_dynamic) VALUES ('assets_version', '0', 0)

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/config/db.php
LINE: 161
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/phpbb/config/db.php
LINE: 122
CALL: phpbb\config\db->set_atomic()

FILE: [ROOT]/phpbb/config/db.php
LINE: 188
CALL: phpbb\config\db->set()

FILE: [ROOT]/install/database_update.php
LINE: 28
CALL: phpbb\config\db->increment()

FILE: [ROOT]/install/database_update.php
LINE: 251
CALL: phpbb_end_update()
PS: after that, the forum works well untill now, i will post back when i try to change the config.php with the old one

LE:
Well, no luck, after editing the config.php with the old db settings, a vendor error appeared:

Code: Select all

Fatal error: Uncaught exception 'Twig_Error_Loader' with message 'Unable to find template "index_body.html" (looked into: ).' in /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:215 Stack trace: #0 /home/snowripp/public_html/phpbb/template/twig/loader.php(107): Twig_Loader_Filesystem->findTemplate('index_body.html') #1 /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Loader/Filesystem.php(139): phpbb\template\twig\loader->findTemplate('index_body.html') #2 /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Environment.php(312): Twig_Loader_Filesystem->getCacheKey('index_body.html') #3 /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Environment.php(378): Twig_Environment->getTemplateClass('index_body.html', NULL) #4 /home/snowripp/public_html/phpbb/template/twig/environment.php(151): Twig_Environment->loadTemplate('index_body.html', NULL) #5 /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Environment.php(362): phpbb\template\twig\environment->loadTemplate('index_body.html') #6 /hom in /home/snowripp/public_html/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 215
whats next?
Locked

Return to “[3.1.x] Support Forum”