Shifting forum from one webserver to another

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
rahulpsharma
Registered User
Posts: 15
Joined: Fri Sep 09, 2011 3:26 am

Shifting forum from one webserver to another

Post by rahulpsharma »

Request help on the following please...

1) Have a forum with approx 1000+ posts and 30 members on one webserver with 'rahulpsharma' as admin user...

2) Have taken a complete dump (dump.sql), of this running forum, using MySQL Workbench,...

3) Have also taken a backup (backup.sql) of entire forum from the Maintenance tab of Admin Panel...

Now I wish to use these two files to resurrect my forum on an entirely new webserver...!!

So,
1) I downloaded the latest PHPBB download (*.zip) file and unpacked it...

2) Created a blank database (abc) using PhpMyAdmin...

3) Installed the fresh PHPBB on this new webserver (with 'rahulpsharma' as new admin)...!!!!

Now what to do to get all the posts and members and original admin back...??

Request to kindly help...

Regards
User avatar
Lumpy Burgertushie
Registered User
Posts: 68282
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Shifting forum from one webserver to another

Post by Lumpy Burgertushie »

import your database backup into your new database.
run the install/database_update.php file if the old one is not the same version as the new one.

done.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
rahulpsharma
Registered User
Posts: 15
Joined: Fri Sep 09, 2011 3:26 am

Re: Shifting forum from one webserver to another

Post by rahulpsharma »

Sorry to persist but it didnt work or I didnt follow it properly...!!

A fresh installation requires me to create a new admin and a new blank database where all blank tables of new installations appear...!!

My older backup taken with help of MySQL Workbench (outside the forum) is complete backup, which when imported using PhpMyAdmin restores everything using the old db name... Shouldnt that backup already have the admin and a database name where it was running last...??

Sorry but I seem to be missing some step in between...!!!

Would you pls confirm that in my situation, I would need a fresh installation to be first done, right...?? This would involve all the routine steps like creating a blank db first and running /install/index.php and it would take me thru all the steps of asking for blank db name, db server, db login, db password etc and finally would ask me to 'create' a new admin with fresh password etc...!!! Once done, I delete Install Folder and end up with a blank forum...!!!

Where do I go next from here using my backup of previous forum...??

Regards,
Rahul
Pond Life
Registered User
Posts: 388
Joined: Sat Jan 20, 2007 1:55 am

Re: Shifting forum from one webserver to another

Post by Pond Life »

https://www.phpbb.com/support/docs/en/3 ... or-domain/
The documentation is for 3.0.x but the procedure should be the same for 3.1.x
Never argue with idiots, they will drag you down to their level and beat you with experience.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68282
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Shifting forum from one webserver to another

Post by Lumpy Burgertushie »

in your first post you said you already installed a fresh board on the new server.

therefore, if you then import your old database backup using phpmyadmin to the new fresh database, it will overwrite the new with the old. you will then need to check that the info in the config.php file is correct.

it should be except for possibly the table prefix. make sure that the table prefix of the old database is what you are using in the new config.php file.

the database import will overwrite all the data in the new database. therefore, your admin account will be exactly the same as it was for the old board.

that is all there is to it.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
rahulpsharma
Registered User
Posts: 15
Joined: Fri Sep 09, 2011 3:26 am

Re: Shifting forum from one webserver to another

Post by rahulpsharma »

Thank you all for your replies and help...!!

@robert: I tried doing the same thing:

1) Installed the new board on my new webserver, after creating a 'blank' db with exact same name as my old board...

2) Chose the same admin username and password when prompted while installing the new board...

3) Didnt fiddle with table name prefixes too...!!!

4) using PhpMyAdmin, imported the dump.sql file of old board and it successfully was imported ("Import has been successfully finished, 1045 queries executed. (Dump20161009.sql)")

5) Then tried running localhost/index.php and following is what I got...

"Fatal error: Uncaught exception 'Twig_Error_Loader' with message 'Unable to find template "index_body.html" (looked into: ).' in C:\xampp\htdocs\amforum\vendor\twig\twig\lib\Twig\Loader\Filesystem.php:215 Stack trace: #0 C:\xampp\htdocs\amforum\phpbb\template\twig\loader.php(107): Twig_Loader_Filesystem->findTemplate('index_body.html') #1 C:\xampp\htdocs\amforum\vendor\twig\twig\lib\Twig\Loader\Filesystem.php(139): phpbb\template\twig\loader->findTemplate('index_body.html') #2 C:\xampp\htdocs\amforum\vendor\twig\twig\lib\Twig\Environment.php(312): Twig_Loader_Filesystem->getCacheKey('index_body.html') #3 C:\xampp\htdocs\amforum\vendor\twig\twig\lib\Twig\Environment.php(378): Twig_Environment->getTemplateClass('index_body.html', NULL) #4 C:\xampp\htdocs\amforum\phpbb\template\twig\environment.php(151): Twig_Environment->loadTemplate('index_body.html', NULL) #5 C:\xampp\htdocs\amforum\vendor\twig\twig\lib\Twig\Environment.php(362): phpbb\template\twig\environment->loadTemplate('index_body.html') #6 C:\xampp\htdocs\amforum\p in C:\xampp\htdocs\amforum\vendor\twig\twig\lib\Twig\Loader\Filesystem.php on line 215"

Would greatly appreciate any help on this....!!!

My earlier board, whose backup I have, is phpbb 3.0.x and the new one is 3.1.x...

Regards and thanks in advance...

Rahul
User avatar
Lumpy Burgertushie
Registered User
Posts: 68282
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Shifting forum from one webserver to another

Post by Lumpy Burgertushie »

what php version are you running in your xammp install?
robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
rahulpsharma
Registered User
Posts: 15
Joined: Fri Sep 09, 2011 3:26 am

Re: Shifting forum from one webserver to another

Post by rahulpsharma »

Thank you once again for your reply...

My PHP version is 5.5.11; XAMPP 1.8.3...

Regards,
Rahul
rahulpsharma
Registered User
Posts: 15
Joined: Fri Sep 09, 2011 3:26 am

Re: Shifting forum from one webserver to another

Post by rahulpsharma »

rahulpsharma wrote:Thank you once again for your reply...

My PHP version is 5.5.11; XAMPP 1.8.3...

Regards,
Rahul
Taking a cue, I just now upgraded my xampp with php verion 5.6.24 and redid the entire exercise... but the same error persists...

Regards,
Rahul
User avatar
david63
Registered User
Posts: 18572
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Shifting forum from one webserver to another

Post by david63 »

It might be a silly question but does the index_body.html file exist? If it does then try re-uploading it as it may be corrupt.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
rahulpsharma
Registered User
Posts: 15
Joined: Fri Sep 09, 2011 3:26 am

Re: Shifting forum from one webserver to another

Post by rahulpsharma »

david63 wrote:It might be a silly question but does the index_body.html file exist? If it does then try re-uploading it as it may be corrupt.
Yes it does.. In localhost/styles/prosilver...

Regards,
Rahul
User avatar
david63
Registered User
Posts: 18572
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Shifting forum from one webserver to another

Post by david63 »

david63 wrote:If it does then try re-uploading it as it may be corrupt.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
rahulpsharma
Registered User
Posts: 15
Joined: Fri Sep 09, 2011 3:26 am

Re: Shifting forum from one webserver to another

Post by rahulpsharma »

david63 wrote:
david63 wrote:If it does then try re-uploading it as it may be corrupt.
Did that quite a few times... Downloaded the latest forum files from download section and unzipped them and placed them in the server root... Repeated the same exercise quite a few times by now but each time the error appears... :(...!!

Rgds,
Rahul
User avatar
2600
I've Been Banned!
Posts: 2567
Joined: Fri Nov 14, 2014 5:14 pm
Location: Area-51

Re: Shifting forum from one webserver to another

Post by 2600 »

You should have two back ups:

1) Your complete public_html folder

This contains your extensions and any of your core modifications.

2) Your databazse SQL file. This containes all the settings and posts

Do this:

Rename the site location in the ACP to reflect your new domain if you have a new domain. You probably can also do this in Xampp in localhost/phpmyadmin. Make sure your port is correct as well. Either 80 or 443 if you use SSL.

Upload that database file to your live host's phpmyadmin. Change the options in the config.php file to reflect your new database.

Upload your public_html files to the public_html folder.

Now delete everything in the cache folder except index.html and .htaccess.

That's a basic way of doing this. I have transferred my forum before and configured a complete forum in Xampp and installed it on a live website. Although, I had to use Notepadd++ and change the engine in the database to MyISAM for some reason.
Morpheus: Unfortunately, no one can be told what The Matrix is. You'll have to see it for yourself.
Hack me.
Consider a canary token.
The nature of my chosen username
:ugeek:
rahulpsharma
Registered User
Posts: 15
Joined: Fri Sep 09, 2011 3:26 am

Re: Shifting forum from one webserver to another

Post by rahulpsharma »

Bringing this issue up again for any other inputs which I can try...!!! I am still trying with the migration of my existing forum from existing webserver to the new webserver...!!

Some additional info, which I just happen to notice, is that my existing forum (the one which is running and I intend to shift to new webserver) uses MySQL Software Version 5.5.6-rc. The xampp installation which I am trying to import the old forum on, says its database is 10.1.16-MariaDB.... Are the two same and should seamlessly import from the former....??

Could this be a cause of all those errors that are being flashed after a seemingly succesfull db import process...?? Just thot to share this info, as it was not mentioned anywhere in the earlier posts...

Would deeply appreciate any help on this issue...

Regards
Rahul
Locked

Return to “[3.1.x] Support Forum”