Page 2 of 3

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 9:35 am
by Darloup
So, if I understand correctly, it's working for some people and not for others... Why would that be? A browser setting?

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 9:37 am
by FoFa
You may have activated an option do disallow "no connected people" from seeing your facebook profile page.

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 9:39 am
by Mick
Darloup wrote:So, if I understand correctly, it's working for some people and not for others... Why would that be? A browser setting?
I'm not sure, but one profile works for me and another doesn't so I can't see it's a browser problem. Do you have a friend who's profile you can use as a test?

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 9:43 am
by Darloup
FoFa wrote:You may have activated an option do disallow "no connected people" from seeing your facebook profile page.
Where is this setting on facebook?!

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 9:45 am
by FoFa
No idea, it's a suggestion. Will try with an other facebook profile

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 9:46 am
by Darloup
Mick wrote:
Darloup wrote:So, if I understand correctly, it's working for some people and not for others... Why would that be? A browser setting?
I'm not sure, but one profile works for me and another doesn't so I can't see it's a browser problem. Do you have a friend who's profile you can use as a test?
Well, if I understand correctly from FoFa (viewtopic.php?f=466&t=2389196#p14535236), the problem happens when you're NOT connected to facebook and you're trying to visit a page...

Is there a facebook setting on my page to solve the problem?

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 9:47 am
by Mick
@Darloup: Please be aware that we don't support FB or any other third party software here. If you have an issue or a question about the use of FB you should go to FB support.

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 9:52 am
by Darloup
Hey Mick, I've just entered my facebook page in php.BB under my profile. I can understand what you say if a user cannot see my page owing to facebook code when it tries to access it and the user is not connected to facebook. It still doesn't explain why my facebook link is not shown under memberlist.php.

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 9:53 am
by FoFa
Tried this :
- logged in with my personal profile, as we are friends on facebook : profile access
- logged in with a neutral profil, which you are not friend with on facebook : profile access
- logged out : 404 page error

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 9:58 am
by Mick
I don't know if this is anything to do with it:
Facebook wrote:Go to Settings. Click on Privacy on left panel.
Check on the Check box for "Do you want other search engines to link to your timeline?" under section "Who can look me up?"

This will let you view your profile even when you are not logged in. But this will also make search engines to cache information of your profile.
There are many more questions and answers at FB support.

Hmm, I just put your FB profile into my profile on my test site and it now works fine and it's good via Google as well, unless you've done something in the meantime?

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 10:11 am
by Darloup
Mick wrote:I don't know if this is anything to do with it:
Facebook wrote:Go to Settings. Click on Privacy on left panel.
Check on the Check box for "Do you want other search engines to link to your timeline?" under section "Who can look me up?"

This will let you view your profile even when you are not logged in. But this will also make search engines to cache information of your profile.
There are many more questions and answers on FB support.
That was clever of you Mick but, unfortunately, it didn't solve the problem...

What I'd really like to know is if anybody on this forum has the same problem (or indeed on any other forum). Namely, they have written their facebook page detail in their UCP, but it doesn't not appear correctly on membership.php (if the option to do so is activated). After all, I just wish membership.php to display this link as I'm sure hundreds of Members also wish to so do.
Hmm, I just put your FB profile into my profile on my test site and it now works fine and it's good via Google as well, unless you've done something in the meantime?
I've just changed the Privacy Settings according to your instructions. This didn't solve the display problem in membership.php

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 10:24 am
by Mick
Try purging the cache.

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 10:26 am
by Darloup
Mick wrote:Try purging the cache.
That's the first thing I did... :(

It might help a lot if a kind soul who had a phpBB forum would (temporarily) allow the facebook link to be displayed in membership.php and see if s/he can reproduce the problem :mrgreen:

At the end of the day, the facebook link is correctly displayed in the user profile and mini-profile but not in membership.php...

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 10:44 am
by RMcGirr83
It is not a link when viewing memberlist probably because of this line found with memberlist.php $use_contact_fields = false; and the html would probably have to be changed as well to get the a href.

Re: Cannot display properly my website and my facebook page links

Posted: Mon Oct 10, 2016 10:54 am
by Darloup
RMcGirr83 wrote:It is not a link when viewing memberlist probably because of this line found with memberlist.php $use_contact_fields = false; and the html would probably have to be changed as well to get the a href.
So, basically, you're telling me it's a phpBB coding issue? Surely, if the facebook link can be properly displayed in profile and mini-profile, it should also be able to be properly displayed in membership.php!