Invalid form error while creating phpBB Native Fulltext index - timeout problem?

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
whocarez
Registered User
Posts: 144
Joined: Sat Apr 18, 2009 9:19 pm

Invalid form error while creating phpBB Native Fulltext index - timeout problem?

Post by whocarez » Mon Oct 24, 2016 9:05 am

Support Request Template
What version of phpBB are you using? phpBB 3.1.10
What is your board's URL? No answer given
Who do you host your board with? No answer given
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.1.9
What extensions do you have installed? No answer given
What styles do you currently have installed? No answer given
What language(s) is your board currently using? No answer given
Which database type/version are you using? MariaDB
What is your level of experience? Comfortable with PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? I tried to recreate the phpBB Native Fulltext index.
Please describe your problem. When I try to create a Fulltext index I run every time in a "The submitted form was invalid. Try submitting again." error. But the index is created and mariadb is busy with creating it for a while (110 000+ posts). I end up with 55604 words and about 226730 relations.
The database is InnoDB, I tried it also with converting all the tables to MyISAM and Aria, but also every time the same. No php errors, no errors in the webserver software. So I think, that might be a timeout related problem.
What recommendations do you have for php or the webserver for timeouts?
What would be the right command to create this index direct in mysql to look for errors or answers?

used software:
lighttpd/1.4.42 (ssl)
PHP 5.4.45-0+deb7u5
mysqld 10.1.18-MariaDB-1~wheezy
Generated by SRT Generator

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21735
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Invalid form error while creating phpBB Native Fulltext index - timeout problem?

Post by Mick » Mon Oct 24, 2016 9:41 am

Have you spoken to your hosts about the time out? You may be able to see something pertaining to the issue in the server error logs for both PHP and MySQL. If you can't get at them your host should be able to help.
"The more connected we get the more alone we become" - Kyle Broflovski

whocarez
Registered User
Posts: 144
Joined: Sat Apr 18, 2009 9:19 pm

Re: Invalid form error while creating phpBB Native Fulltext index - timeout problem?

Post by whocarez » Mon Oct 24, 2016 9:47 am

It's a VServer, so everything is under my control. At least I hope so :-)

Maybe I should measure the time between starting the process and appearing of this "invalid formular" message.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21735
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Invalid form error while creating phpBB Native Fulltext index - timeout problem?

Post by Mick » Mon Oct 24, 2016 10:10 am

You should be able to see the server logs in that case. Unfortunately we are unable to give you advice about server set up but there are plenty of external sites dealing with PHP and MySQL issues.
"The more connected we get the more alone we become" - Kyle Broflovski

whocarez
Registered User
Posts: 144
Joined: Sat Apr 18, 2009 9:19 pm

Re: Invalid form error while creating phpBB Native Fulltext index - timeout problem?

Post by whocarez » Mon Oct 24, 2016 12:48 pm

I could the problem a little bit isolate.
It's not about a timeout, but about the redirecting after the status message:
"All posts up to post id %2$d have now been indexed, of which %1$d posts were within this step."

"Continue previous indexing process" helps to go a step further.

So phpbb isn't getting at this moment, what it expected ... This is one example header:

Code: Select all

GET /adm/index.php?i=acp_search&sid=979554d2fab4d6afb7edfeaefcc1e433&mode=index&action=create&skip_rows=10000&sid=979554d2fab4d6afb7edfeaefcc1e433 HTTP/1.1
Host: testforum.xxxx:443
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Accept-Encoding: gzip, deflate, sdch, br
Accept-Language: ru,uk;q=0.8,de;q=0.6,en;q=0.4
Cookie: users_resolution=1920x1080; __utmt=1; cookieconsent_dismissed=yes; testforum_xert234_u=53; testforum_xert234_k=; testforum_xert234_sid=979554d2fab4d6afb7edfeaefcc1e433; __utma=230320793.1144248276.1477316625.1477316625.1477316625.1; __utmb=230320793.5.10.1477316625; __utmc=230320793; __utmz=230320793.1477316625.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)
Referer: https://testforum.xxxx/adm/index.php?i=acp_search&sid=979554d2fab4d6afb7edfeaefcc1e433&mode=index&action=create
Upgrade-Insecure-Requests: 1
User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.71 Safari/537.36

HTTP/1.1 200 OK
Cache-Control: private, no-cache="set-cookie"
Connection: keep-alive
Content-Encoding: gzip
Content-Length: 2689
Content-Type: text/html; charset=UTF-8
Date: Mon, 24 Oct 2016 13:51:25 GMT
Expires: Mon, 24 Oct 2016 13:51:25 GMT
Keep-Alive: timeout=35
Server: nginx
Strict-Transport-Security: max-age=31536000; preload
Vary: Accept-Encoding
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1; mode=block
the complete server config is
nginx <---> varnish <---> lighttpd <---> php-fpm <---> mariadb

I would exclude varnish as a reason for this behavior, because return (pipe); gives the same result.

Any hint?

whocarez
Registered User
Posts: 144
Joined: Sat Apr 18, 2009 9:19 pm

Re: Invalid form error while creating phpBB Native Fulltext index - timeout problem?

Post by whocarez » Fri Mar 03, 2017 11:22 am


Locked

Return to “[3.1.x] Support Forum”