Page 1 of 1

'view first unread post' icon sends to older, wrong post

Posted: Tue Dec 13, 2016 8:51 pm
by Zunflappie
With reference to: viewtopic.php?f=46&t=2298066

Maybe an old post, but Google brought me here.
I have exactly the same problemen, latest version op phpBB 3.1.
It started about 2 updates ago, but the files are fine (checked).

Any solutions?
Yes, it sounds like a database-problem. Tried to recalculate everything via admin. Didnt fix.
Yes, its on larger topics (20 pages or more, but also on 'old topics' with 800 pages).

Re: 'view first unread post' icon sends to older, wrong post

Posted: Fri Dec 16, 2016 10:13 am
by Mick
Please fill out the Support Request Template and post it back here to enable us to assist you better.

Re: 'view first unread post' icon sends to older, wrong post

Posted: Sat Dec 17, 2016 11:46 am
by Zunflappie
Support Request Template
What version of phpBB are you using? phpBB 3.1.10
What is your board's URL? http://http://zundappforum.com/
Who do you host your board with? Versio (Dutch professional hosting)
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? Yes
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.1.9
What MODs do you have installed? None
What extensions do you have installed? Snel-reactie == (fast-reaction-box below page)
Antispam by teamtalk
What styles do you currently have installed? Prosilver
What language(s) is your board currently using? Dutch
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Just update using auto-package
Please describe your problem. The 'view first unread post' links seem to be broken, for all users, Moderators and Admin. They will land on an older page, rather than the most recent post. By contrast, the 'view latest post' icon does work reliably however.
Generated by SRT Generator

Re: 'view first unread post' icon sends to older, wrong post

Posted: Tue Dec 20, 2016 8:40 pm
by Zunflappie
Somebody at our forum told me today his problem with the paging is solved....

strange thing: we didnt do anything.
It is with the local-storage of cookies or something?

Re: 'view first unread post' icon sends to older, wrong post

Posted: Tue Dec 20, 2016 9:38 pm
by david63
Zunflappie wrote:It is with the local-storage of cookies or something?
Do you use a caching service such as Cloudflare as this, if it is not configured correctly could be the cause of this type of problem.

Re: 'view first unread post' icon sends to older, wrong post

Posted: Sat Dec 24, 2016 11:48 am
by Zunflappie
We dont use any of that kind add-ons.
Also already cleared cache a dozen times.

Re: 'view first unread post' icon sends to older, wrong post

Posted: Tue May 09, 2017 11:20 am
by njs
This seems to happen on 3.2 as well, which was migrated from 3.0.11 which showed the same symptoms.

On topics with a large amount of posts, the &view=unread doesn't jump to the correct page, the post icons on that page are all normal, and are marking the unread posts correctly starting on the first unread post. Meaning that, the post icon show the correct behaviour, but the page to jump to is the wrong one.

This seem to be a long standing issue, is there any solution for it ?

Re: 'view first unread post' icon sends to older, wrong post

Posted: Tue May 09, 2017 11:40 am
by david63
njs wrote:
Tue May 09, 2017 11:20 am
This seem to be a long standing issue, is there any solution for it ?
Post it in the Bug Tracker - if it is not already there.

Re: 'view first unread post' icon sends to older, wrong post

Posted: Tue May 09, 2017 12:06 pm
by njs
While writing the bug report I found what the issue is.

This is the browser caching working, it shows on the network tab that it is reading the page from the disk and not from the network.

So it will use the redirect it had previously cached.

Is there anyway to bypass cache for these urls ?