Page 1 of 1

Installed Ext and can't access ACP

Posted: Fri Jan 13, 2017 7:56 pm
by Lon2
Hello. I'm in dire straits! I installed phpBB3 SEO Sitemap Extension on phpBB 3.1.10 and I can't access ACP after enabling it. I installed this same Extension (exact same copy) on another 3.1.10 instance a year ago and it installed and has been working since. I've tried the Extension support but got no help whatsoever. I've tried renaming the extension folder (shredder), manually deleted phpBB cache files (/cache/ all files except .htaccess and index.php) as well as browser cache, and still can't access ACP. Is there a way to manually remove an Extension or disable it without ACP access? What are my options besides reloading the entire forum? Any help would be greatly appreciated!

P.S. Everything else on the forum works fine.

Re: Installed Ext and can't access ACP

Posted: Fri Jan 13, 2017 8:06 pm
by 3Di
[Extensions][How-To] Hard disable extension(s)

Re: Installed Ext and can't access ACP

Posted: Fri Jan 13, 2017 8:47 pm
by Lon2
I greatly appreciate your post, sDi! It allowed me to get into ACP but I'm seeing the following error in Extensions Manager:

The “shredder/sitemap” extension is not valid.
The requested file could not be found: ./../ext/shredder/sitemap/composer.json


It looks like there's still part of the installation somewhere. I have the Extension files. What are some common installer files that are modified?

P.S. I completely deleted the Extension files and folder manually.

Re: Installed Ext and can't access ACP

Posted: Fri Jan 13, 2017 9:08 pm
by 3Di
Lon2 wrote:
Fri Jan 13, 2017 8:47 pm
P.S. I completely deleted the Extension files and folder manually.
And where did you read to do that?

Put back the extension in the right place, refresh that page, delete its data via teh "delete data" link.

Now you can delete that folder. And purge the cache.

Re: Installed Ext and can't access ACP

Posted: Fri Jan 13, 2017 9:22 pm
by Lon2
Not sure where I read it but I re-uploaded the files and that did it! Can't thank you enough! :D

Now I just need to figure out why the Ext is working on my other forum and not this one... :?

Or find another sitemap option.