Page 1 of 1

Forced SSL fails

Posted: Tue Jan 24, 2017 10:28 am
by DoYouSpeakWak
Support Request Template
What version of phpBB are you using? phpBB 3.1.10
What is your board's URL? https://psyke-sex.dk/debat/
Who do you host your board with? simplex
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.0.14
What extensions do you have installed? Open urls in new window
What styles do you currently have installed? subsilver2, prosilver
What language(s) is your board currently using? Danish
Which database type/version are you using? MySQL 5
What is your level of experience? Experienced with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Updated the forum from 3.0.14 to 3.1.10 without any issues at all. Everything works fine expect for forced SSL
Please describe your problem. Server URL settings are as follow. But the board does not force SSL.

Image

No alterations have been made to any redirect file in the server root or forum root.

http://psyke-sex.dk/ should force ssl.
https://psyke-sex.dk/

What could be wrong ?
Generated by SRT Generator

Re: Forced SSL fails

Posted: Tue Jan 24, 2017 3:50 pm
by Lumpy Burgertushie
did you set cookie secure to yes under the cookie settings page?


robert

Re: Forced SSL fails

Posted: Wed Jan 25, 2017 7:41 am
by DoYouSpeakWak
Yes I did. The board have been running with ssl for some years on phpBB 3.0.X,. I havnt changed the server/cookie settings after the upgrade to 3.1

Image

Re: Forced SSL fails

Posted: Wed Jan 25, 2017 9:16 am
by Paul
Server settings does not force redirecting. You will need to create a redirect in your htaccess.

Re: Forced SSL fails

Posted: Wed Jan 25, 2017 11:13 am
by DoYouSpeakWak
Paul wrote:
Wed Jan 25, 2017 9:16 am
Server settings does not force redirecting. You will need to create a redirect in your htaccess.
Thx for clearing That up. So no reason to mess with the phpBB ssl functions if you are using ssl.

So the "force" function doesnt not force anything. Great function. It should at least force the selected port when your logged in. A bug, no just a non-working function.

Re: Forced SSL fails

Posted: Wed Jan 25, 2017 12:03 pm
by Paul
It is forced when actual redirects are done, not on all locations.