Strange caching problem

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
User avatar
rogerclark
Registered User
Posts: 86
Joined: Thu Aug 18, 2016 11:53 am
Location: Melbourne Australia
Name: Roger Clark
Contact:

Strange caching problem

Post by rogerclark »

I've suddenly started to get a weird form of caching issue on my site.

The notifications counts are not getting updated when anyone reads a post, (nor are the PM counts)

Some people have also reported being dumped back to the login screen when they look in the Unread posts page.

If I go to an existing topic with new posts, I have to press refresh in the browser 2 or 3 times to see them all, as each time I press refresh I get a few more posts dislayed

(I'm running 3.1.3, which I know I should upgrade)

I didnt make any changes to the site apart from adding a new "forum", and I didnt see any problems immediately after adding the forum, and the problems started to happen during the night when I had not touched the site

I contacted my host (HostGator) and they claim nothing has changed on the server hardware or software config



Does anyone have any ideas whats happened?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 24054
Joined: Fri Aug 29, 2008 9:49 am
Contact:

Re: Strange caching problem

Post by Mick »

Please fill out the Support Request Template and post it back here to enable us to assist you better.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination. The bad news is, whatever humans can imagine, they can usually create." - Harmony Cobel
User avatar
lizad
Registered User
Posts: 13
Joined: Thu Feb 02, 2017 12:46 pm
Name: Liz Brooks
Contact:

Re: Strange caching problem

Post by lizad »

Hello,it looks like a possible server error as we are having the EXACT same problems as of last night and we are using Hostgator aswell.

were using 3.1.10

Watching with interest
User avatar
lizad
Registered User
Posts: 13
Joined: Thu Feb 02, 2017 12:46 pm
Name: Liz Brooks
Contact:

Re: Strange caching problem

Post by lizad »

Hi admin, may i fill in the same support request template and post it here as we have the exact same problem. As stated before, Hostgator claim it isn't them?

Thank you
chronologyproject
Registered User
Posts: 29
Joined: Sat Jan 01, 2005 5:35 pm
Location: Alabama
Contact:

Re: Strange caching problem

Post by chronologyproject »

I use Hostgator and I'm having the same problem.

Internet Explorer and Edge have no problem. Firefox and Chrome do.

It's not just read and unread messages. It's last post, and new posts not showing up in threads, and even the time.

It's caused by Firefox not recognizing that the page has changed, and Firefox is loading from its cache. If you click the reload button in Firefox, everything is corrected, but ONLY for THAT PAGE, that one instance. You have to reload EVERY page, every time you go to that page.

You can go to my page:

http://www.chronologyproject.com/phpbb2/

and check the board time. Spend a couple of minutes browsing through threads, and then return to the main forum page. It still shows the old time. Click the refresh/reload button, and everything's fine.

I have tried:
Clearing the browser's cache.
Clearing the forum's cache.
Changing the forum's cookie name.

Chrome is having additional problems with logging people out. At first I thought it was a problem with a new version of Firefox, since I hadn't changed anything, and Firefox pushed out an update earlier this week. But with further problems with Chrome, and the apparent common denominator of Hostgator, I'm looking at them. Can anyone provide any thoughts as to what we need to say to Hostgator?
chronologyproject
Registered User
Posts: 29
Joined: Sat Jan 01, 2005 5:35 pm
Location: Alabama
Contact:

Re: Strange caching problem

Post by chronologyproject »

Support Request Template
What version of phpBB are you using? phpBB 3.1.9
What is your board's URL? http://www.chronologyproject.com/phpbb2
Who do you host your board with? hostgator
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.0-B1
What extensions do you have installed? Site Logo
What styles do you currently have installed? Prosilver, child of prosilver that allows me to add a background image
What language(s) is your board currently using? English
Which database type/version are you using? I Don't Know
What is your level of experience? Comfortable with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? None. Problem started about two days ago.
Please describe your problem. See above, but basically Firefox is not auto-refreshing when a page changes.
Generated by SRT Generator
User avatar
RMcGirr83
Former Team Member
Posts: 21963
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr

Re: Strange caching problem

Post by RMcGirr83 »

Using cloudflare?
Former Modifications/Extensions Team Member | My extensions | github | All requests for support via PM will be ignored
Appreciate the extensions/mods/support then buy me a beerImage
User avatar
lizad
Registered User
Posts: 13
Joined: Thu Feb 02, 2017 12:46 pm
Name: Liz Brooks
Contact:

Re: Strange caching problem

Post by lizad »

after being on with hostgator for 2-3 hours, As expected...its not us.

They say they are not using any caching on the server side( but then say they're using Varnish). They say that cloudfare or cloudfront is not installed on the servers
chronologyproject
Registered User
Posts: 29
Joined: Sat Jan 01, 2005 5:35 pm
Location: Alabama
Contact:

Re: Strange caching problem

Post by chronologyproject »

RMcGirr83 wrote:
Thu Feb 02, 2017 3:05 pm
Using cloudflare?
Nope.

From Hostgator's support site:
What is CloudFlare? How Do I Enable?
Overview Statistics & Settings Threat Control FAQ
Note: The CloudFlare plugin will no longer be available to customers who have not already used it. For the best CDN/Firewall solution, HostGator recommends using TrueSpeed/TrueShield, included in all SiteLock offers.
I've never had cloudflare, so it's not (easily) available to me. I don't use SiteLock, so I don't use TrueSpeed/TrueShield.
User avatar
joshuadenmark
Registered User
Posts: 37
Joined: Sat Aug 07, 2010 11:54 am
Contact:

Re: Strange caching problem

Post by joshuadenmark »

Sorry for hijacking - got the same issue on Hostgator - PhpBB 3.1.4 nothing changed at the forum, just error out of the blue.
User avatar
supanet
Registered User
Posts: 244
Joined: Sat Dec 15, 2012 4:20 pm
Location: UK
Contact:

Re: Strange caching problem

Post by supanet »

Was just about to make a post about this when i noticed this thread. :o
I am also experiencing the exact same caching problems, read posts are showing up as unread etc...

I'm also with Host Gator and running 3.1.10 and haven't installed or updated anything in the last few weeks.

This has only started over the last two days and is affecting chrome, Firefox and Ps4 browser (whatever that is)
according to the members.

Hope someone can come up with a solution soon. :ugeek:
User avatar
rogerclark
Registered User
Posts: 86
Joined: Thu Aug 18, 2016 11:53 am
Location: Melbourne Australia
Name: Roger Clark
Contact:

Re: Strange caching problem

Post by rogerclark »

I contacted HostGator support, via online textnchat, but they claimed there had been no changes to the physical machine or software setup.

But I got the feeling that most of the responses I got could have been generated by a chatbot.

I have a thread on the forum which has the issue

http://stm32duino.com/viewtopic.php?f=45&t=1759

Were we are trying to work out whats going on.

It looks very much like a cache problem at HostGator :-(
User avatar
joshuadenmark
Registered User
Posts: 37
Joined: Sat Aug 07, 2010 11:54 am
Contact:

Re: Strange caching problem

Post by joshuadenmark »

rogerclark wrote:
Thu Feb 02, 2017 7:34 pm
I contacted HostGator support, via online textnchat, but they claimed there had been no changes to the physical machine or software setup.

But I got the feeling that most of the responses I got could have been generated by a chatbot.

I have a thread on the forum which has the issue

http://stm32duino.com/viewtopic.php?f=45&t=1759

Were we are trying to work out whats going on.

It looks very much like a cache problem at HostGator :-(
Thanks - I will post here if I got this solved. Good luck guys!
User avatar
HangLoose
Registered User
Posts: 92
Joined: Thu Dec 31, 2015 9:56 pm

Re: Strange caching problem

Post by HangLoose »

Same problem here - as reported in this thread:
viewtopic.php?f=466&t=2407346

3.1.10
Hostgator

Seems everyone wants to pass it to someone else though.
I could use some advice, along with a link to the tutorial..... :mrgreen:
User avatar
RMcGirr83
Former Team Member
Posts: 21963
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr

Re: Strange caching problem

Post by RMcGirr83 »

The common theme here is host gator. Ignore first level support as they are pretty much worthless and go up to the second level.
Former Modifications/Extensions Team Member | My extensions | github | All requests for support via PM will be ignored
Appreciate the extensions/mods/support then buy me a beerImage
Locked

Return to “[3.1.x] Support Forum”