[phpBB Debug] PHP Warning

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Ideas Centre
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
User avatar
Poweagralo
Registered User
Posts: 18
Joined: Sun Mar 08, 2009 4:22 pm
Contact:

[phpBB Debug] PHP Warning

Post by Poweagralo » Sat May 13, 2017 9:43 pm

Just gone on my forums today and there's this error. I wasn't doing anything to it at the time, just found the site today with this error. How do I fix please?
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/db/driver/mysql.php on line 275: mysql_fetch_assoc(): 216 is not a valid MySQL result resource
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/db/driver/mysql.php on line 275: mysql_fetch_assoc(): 219 is not a valid MySQL result resource

Warning: Cannot modify header information - headers already sent by (output started at /public_html/scoutforum/includes/functions.php:3257) in public_html/scoutforum/includes/functions.php on line 1949
Return to index page
General Error
NO_STYLE_DATA

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/user.php
LINE: 301
CALL: trigger_error()

FILE: [ROOT]/index.php
LINE: 29
CALL: phpbb\user->setup()
Last edited by Mick on Mon May 15, 2017 10:16 pm, edited 1 time in total.
Reason: Added useful topic description.

GoesOn
Registered User
Posts: 413
Joined: Sun Mar 05, 2017 7:31 pm

Re: Help!

Post by GoesOn » Sat May 13, 2017 9:59 pm

Do you have back up on the server and restore to earlier?
English is not my native language :!:

User avatar
david63
Jr. Extension Validator
Posts: 14644
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Help!

Post by david63 » Sat May 13, 2017 10:05 pm

If you have not changed anything and you suddenly get errors the it is more than likely that your hosts have changed something - ask them.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Poweagralo
Registered User
Posts: 18
Joined: Sun Mar 08, 2009 4:22 pm
Contact:

Re: [phpBB Debug] PHP Warning

Post by Poweagralo » Mon May 15, 2017 11:02 pm

Thanks. I've asked the question to my hosting provider. It looks like they clearly have changed something, as I am having issues with wordpress permissions too.

User avatar
Poweagralo
Registered User
Posts: 18
Joined: Sun Mar 08, 2009 4:22 pm
Contact:

Re: [phpBB Debug] PHP Warning

Post by Poweagralo » Wed May 17, 2017 9:41 pm

Thanks guys for the help so far.

They've said that they haven't changed anything, although there was an issue with the databases which they've fixed.

I now have a different General Error message.
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/db/driver/mysql.php on line 275: mysql_fetch_assoc(): 191 is not a valid MySQL result resource
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/db/driver/mysql.php on line 275: mysql_fetch_assoc(): 222 is not a valid MySQL result resource
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/db/driver/mysql.php on line 275: mysql_fetch_assoc(): 224 is not a valid MySQL result resource

Warning: Cannot modify header information - headers already sent by (output started at /websites/123reg/includes/functions.php:3257) in /includes/functions.php on line 1949
Return to index page
General Error
NO_STYLE_DATA

User avatar
Furball Zen
Registered User
Posts: 381
Joined: Thu Oct 18, 2007 9:38 pm

Re: [phpBB Debug] PHP Warning

Post by Furball Zen » Thu Feb 22, 2018 5:09 pm

Ooops.
I am the almighty Furball Zen. Hear me fluff.

Site Admin: too many to list ;)
Port 80 is for your server, port 3306 is for your db :)
If your forum displays correctly in IE, it needs to be fixed :)

Locked

Return to “[3.1.x] Support Forum”

Who is online

Users browsing this forum: kentaifina and 20 guests