Unable to re-autheticate to access ACP

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Scam Warning
Post Reply
joenglish
Registered User
Posts: 4
Joined: Fri Nov 17, 2017 1:27 pm

Unable to re-autheticate to access ACP

Post by joenglish » Fri Nov 17, 2017 1:35 pm

Support Request Template
What version of phpBB are you using? phpBB 3.1.6
What is your board's URL? https://www.englishclub.com/tefl/
Who do you host your board with? Gossamer Host
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.1.4
What extensions do you have installed? Board Rules (https://www.englishclub.com/tefl/app.php/rules)
What styles do you currently have installed? ProSilverSE
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? No action as far as I know. The problem just started around Oct 17. I have another identical phpBB install on the *same* site/server (https://www.englishclub.com/esl-forums/) and the *same* problem. I have another identical install on a *different* site/server (https://www.tefl.net/forums/) and there is *no problem*.
Please describe your problem. All normal users can login ok. I can also login with my admin username BUT cannot re-authenticate to access ACP. When I try to re-authenticate, *nothing* happens - no warning, no "wrong password", nothing. The same is true of another admin on a different continent.
Generated by SRT Generator

User avatar
Mick
Support Team Member
Support Team Member
Posts: 18111
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Unable to re-autheticate to access ACP

Post by Mick » Fri Nov 17, 2017 2:10 pm

The board isn’t setting cookies properly, you may have to speak to your host about that. I can confirm the server that works properly is setting cookies correctly.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

joenglish
Registered User
Posts: 4
Joined: Fri Nov 17, 2017 1:27 pm

Re: Unable to re-autheticate to access ACP

Post by joenglish » Fri Nov 17, 2017 2:43 pm

Thank you Mick. I will check that out.

joenglish
Registered User
Posts: 4
Joined: Fri Nov 17, 2017 1:27 pm

Re: Unable to re-autheticate to access ACP

Post by joenglish » Fri Nov 17, 2017 3:31 pm

Host says cookies are being set correctly:
Cookies are being set correctly. I added these 2 simple php files that you can use to test.

First, go to https://www.englishclub.com/tefl/cookie2.php, which checks if a test cookie is set. This should show that it isn't set. Then go to https://www.englishclub.com/tefl/cookie.php to set the cookie, and finally go back to the first https://www.englishclub.com/tefl/cookie2.php url and you'll see that the test now shows that the cookie is set.
Can you think of anything else that could be causing this?

Many thanks
Jo

User avatar
Brf
Support Team Member
Support Team Member
Posts: 50730
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Unable to re-autheticate to access ACP

Post by Brf » Fri Nov 17, 2017 3:43 pm

Your site is using Varnish. I was thinking there is a patch for that.

joenglish
Registered User
Posts: 4
Joined: Fri Nov 17, 2017 1:27 pm

Re: Unable to re-autheticate to access ACP

Post by joenglish » Fri Nov 17, 2017 4:02 pm

Thanks. You're absolutely right Brf, but it's been using Varnish for ages and this never happened before.

What's the patch you're referring to? Is it for Varnish or for phpBB?

Post Reply

Return to “[3.1.x] Support Forum”

Who is online

Users browsing this forum: Bing [Bot], D3ad3y3, stevemaury and 33 guests