Problem with Unread Posts after sever migration

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Post Reply
HaloPolicja
Registered User
Posts: 23
Joined: Tue Aug 02, 2016 1:02 pm

Problem with Unread Posts after sever migration

Post by HaloPolicja » Sat Jan 13, 2018 2:26 pm

Since moving my board to a different server with same config (phpbb3.1.10, Debian 8, nginx, php5.6.30, mariadb, sphinx, memcache, cloudflare) I have problem with caching unread posts. When I click on Unread posts, click on any unread topic, reply (or not), click on unread posts again i still have this topic in my unread posts. I have to refresh my browser for it to disappear.

Tried using file cache, restarting server, still same thing happens. I have MariaDB query cache disabled. Thank you for help.

User avatar
Lumpy Burgertushie
Registered User
Posts: 64287
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Problem with Unread Posts after sever migration

Post by Lumpy Burgertushie » Sat Jan 13, 2018 3:48 pm

try disabling cloudfare to test.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

HaloPolicja
Registered User
Posts: 23
Joined: Tue Aug 02, 2016 1:02 pm

Re: Problem with Unread Posts after sever migration

Post by HaloPolicja » Sun Jan 14, 2018 5:51 pm

Lumpy Burgertushie wrote:
Sat Jan 13, 2018 3:48 pm
try disabling cloudfare to test.
Same thing happens :|

HaloPolicja
Registered User
Posts: 23
Joined: Tue Aug 02, 2016 1:02 pm

Re: Problem with Unread Posts after sever migration

Post by HaloPolicja » Fri Jan 26, 2018 8:08 pm

Anyone?

HaloPolicja
Registered User
Posts: 23
Joined: Tue Aug 02, 2016 1:02 pm

Re: Problem with Unread Posts after sever migration

Post by HaloPolicja » Sat Feb 24, 2018 2:47 pm

Fixed it by adding

Code: Select all

add_header Cache-Control "no-cache"
to php files it nginx. It might be an overkill, but it works.

Post Reply

Return to “[3.1.x] Support Forum”

Who is online

Users browsing this forum: No registered users and 20 guests